Concert Namespace

[image]

Concert Web Services Library
Concert Namespace
Send Feedback

Classes

 | Class | Description
Public class | AssetHealth | This service provides access to the current asset health for a specified Tango database. Access from http://www.tf7.com/Concert/AssetHealth.asmx
Public class | AssetHealth..::..AssetHealthData | The asset health information collection
Public class | AssetHealth..::..AssetHealthLevelItem | The data for a specific asset health level
Public class | ConcertDatabaseAlias | This class provides information to select a database using a two part value.
Public class | ConcertDatabaseAliasAndExternalInterfaceUser | This class provides information to select a database using a two part value and a Tango user login information. Every Tango database has a GUID (globally unique identifier). A common alias type for all Tango databases is "TangoDatabaseGUID" and is paired with the database GUID. When you log into a Tango database, the GUID is visible on the URL.
Public class | ConditionEntry | This service provides access to Technology Condition Entries in Tango Access from http://www.tf7.com/Concert/ConditionEntry.asmx
Public class | ConditionEntry..::..ConditionEntryAttribute | This class indicates condition entry attribute values
Public class | ConditionEntry..::..ConditionEntryValue | A pairing of a value type and the matching value.
Public class | IConditionEntryEvent | Summary description for IConditionEntryEvent This interface describes how to consume the 24/7 Concert web service for condition entries.
Public class | IConditionEntryEvent..::..FaultItem | A single Tango Fault Item
Public class | IConditionEntryEvent..::..TangoAlias | A Tango location alias.
Public class | IConditionEntryEvent..::..TangoLocation | Tango Location info associated with an asset component
Public class | ITangoEquipmentEvent | A service interface definition. It is expected that partner companies will implement this interface to receive events about equipment
Public class | OilDataSubmission | The OilDataSubmission service provides 3rd party oil labs to submit information to Oilography via a set of web services. There is also a set of optional oil lab partner services the lab can expose to allow Oilography to perform advanced integration. Access from http://www.tf7.com/Concert/OilDataSubmission.asmx
Public class | OilDataSubmission..::..AddOilDataSetCommentsResponse | Response associated with an attempt to add an oil dataset comment
Public class | OilDataSubmission..::..DataSetComment | The information used ot add/edit a comment.
Public class | OilDataSubmission..::..ExternalLinkedDocument | Information about an external linked document (ie. external photo, external report, etc).
Public class | OilDataSubmission..::..OilDataSetStatus | The status of the oil data set
Public class | OilDataSubmission..::..OilTest | Defines a type of oil test
Public class | OilDataSubmission..::..OilValueLabStatus | The status of an oil value based on lab analysis
Public class | PartnerSystemSecurity | Used to pass security info to a partner system. Implementation is up to the partner -- you can go without if you want, but it is not recommended
Public class | TangoEquipment | Service methods used to access and control Tango equipment. Access from http://www.tf7.com/Concert/TangoEquipment.asmx
Public class | TangoEquipment..::..EquipmentHistoryItem | Tango Equipment history item
Public class | TangoEquipment..::..EquipmentTypeInfo | A Tango equipment type
Public class | TangoEquipment..::..InstallationInfo | The information that indicates where the equipment was installed to.
Public class | TangoEquipment..::..NewPropertyValue | Data for and equipment property value
Public class | TangoEquipment..::..PropertyMapping | A mapped property configuration
Public class | TangoEquipment..::..VendorItem | A vendor
Public class | TangoLocation | Service methods used to access and control Tango locations. Access from http://www.tf7.com/Concert/TangoLocation.asmx
Public class | TangoLocation..::..AliasLocationValue | A location ID and alias value
Public class | TangoLocation..::..AliasMapping | A mapping between a location and an alias type
Public class | TangoLocation..::..AliasValue | A location alias value
Public class | TangoLocation..::..AttributeTypeAndValue | An attribute type and attribute value association.
Public class | TangoLocation..::..AttributeTypeDefinintion | Tango Tree Item Attribute. Meta data related to extended definitions of Tango locations.
Public class | TangoLocation..::..LocationInfo | Location information
Public class | TangoLocation..::..LocationOrAliasUnion | A union of either a location ID or a location alias
Public class | TangoLocation..::..LocationOrAliasUnion..::..AliasData | A Tango location by its Tango alias value
Public class | TangoLocation..::..LocationOrAliasUnion..::..LocationID | A Tango location by its internal Tango ID
Public class | TangoLocation..::..RemovalInfo | Information about the equipment removal
Public class | TangoLocation..::..TangoItemAttributeValue | A location, attribute type and attribute value association.
Public class | TangoUser | This service provides method to manage Tango user configurations externally. Please note that this is a powerful service and if used, can cause features to be visible to users who are not intended to see certain features or data in Tango. By using this service the customer acknowledges that they may expose sensitive information to users that should not have access to such information. Point of View Concepts: There are users and user templates. Templates are used to allow you to setup a set of user rights or a set of user locations and then associate users to the templates. This is very useful when using the automated interfaces and/or managing users.
Public class | TangoUser..::..CustomerInfo | Customer information
Public class | TangoUser..::..UriTypeItem | A type of Tango resource Uri
Public class | TangoUser..::..UserInfo | User information

Enumerations

 | Enumeration | Description
Public enumeration | ConditionEntry..::..ConditionEntryValueType | The types of condition entry values
Public enumeration | ITangoEquipmentEvent..::..ChangeNoticeType | Indicates why this call is being made. This way partner systems have a context for the call. It is possible that in some cases a partner system might behave differently based on the notice type.
Public enumeration | TangoLocation..::..TangoItemAttributeType | An enumeration of an attribute type. You will ned to pass this in if you want to save attribute data.


AssetHealth Class

[image]

Concert Web Services Library
AssetHealth Class
Members See Also Send Feedback
This service provides access to the current asset health for a specified Tango database. Access from http://www.tf7.com/Concert/AssetHealth.asmx

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class AssetHealth : ConcertWebServiceBase
Visual Basic
Public Class AssetHealth
    Inherits ConcertWebServiceBase

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..MarshalByValueComponent
System.Web.Services..::..WebService
ConcertWebServiceBase
Concert..::..AssetHealth

See Also

AssetHealth Members
Concert Namespace


AssetHealth Members

[image] [image]

Concert Web Services Library
AssetHealth Members
AssetHealth Class Methods See Also Send Feedback

The AssetHealth type exposes the following members.

Methods

 | Name | Description
Public method | GetAssetHealth | Depricated
Public method | GetAssetHealthData | Return the asset health. Replaces GetAssetHealth method

See Also

AssetHealth Class


AssetHealth Methods

[image] [image]

Concert Web Services Library
AssetHealth Methods
AssetHealth Class See Also Send Feedback

The AssetHealth type exposes the following members.

Methods

 | Name | Description
Public method | GetAssetHealth | Depricated
Public method | GetAssetHealthData | Return the asset health. Replaces GetAssetHealth method

See Also

AssetHealth Class


AssetHealth.GetAssetHealth Method

[image]

Concert Web Services Library
AssetHealth..::..GetAssetHealth Method
AssetHealth Class See Also Send Feedback
Depricated

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public XmlNode GetAssetHealth(
    string DatabaseAlias,
    string DatabaseAliasType,
    Nullable<DateTime> AsOfDate,
    string UserName,
    string UserPassword
)
Visual Basic
Public Function GetAssetHealth (
    DatabaseAlias As String,
    DatabaseAliasType As String,
    AsOfDate As Nullable(Of DateTime),
    UserName As String,
    UserPassword As String
) As XmlNode

Parameters

DatabaseAlias
Type: System..::..String
A database alias for the Tango database you want to access.
DatabaseAliasType
Type: System..::..String
A type of database alias used to access the Tango database you want.
AsOfDate
Type: System..::..Nullable <(Of <(<' DateTime >)>)>
The date you want the Asset Health data of
UserName
Type: System..::..String
The user name of a Tango user allowed to access Concert
UserPassword
Type: System..::..String
The user password of a Tango user allowed to access Concert

Return Value

Type: XmlNode
Xml data with asset health informaiton

See Also

AssetHealth Class
AssetHealth Members


AssetHealth.GetAssetHealthData Method

[image]

Concert Web Services Library
AssetHealth..::..GetAssetHealthData Method
AssetHealth Class See Also Send Feedback
Return the asset health. Replaces GetAssetHealth method

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AssetHealth..::..AssetHealthData GetAssetHealthData(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser,
    Nullable<DateTime> AsOfDate
)
Visual Basic
Public Function GetAssetHealthData (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser,
    AsOfDate As Nullable(Of DateTime)
) As AssetHealth..::..AssetHealthData

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information
AsOfDate
Type: System..::..Nullable <(Of <(<' DateTime >)>)>
The date you wish to get the asset health level. Optional -- if not passed we use now.

Return Value

Type: AssetHealth..::..AssetHealthData
An asset health levels object.

See Also

AssetHealth Class
AssetHealth Members


AssetHealth.AssetHealthData Class

[image]

Concert Web Services Library
AssetHealth..::..AssetHealthData Class
AssetHealth Class Members See Also Send Feedback
The asset health information collection

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class AssetHealthData
Visual Basic
Public Class AssetHealthData

Inheritance Hierarchy

System..::..Object
Concert..::..AssetHealth..::..AssetHealthData

See Also

AssetHealth..::..AssetHealthData Members


AssetHealth.AssetHealthData Members

[image] [image]

Concert Web Services Library
AssetHealth..::..AssetHealthData Members
AssetHealth..::..AssetHealthData Class Constructors Fields See Also Send Feedback

The AssetHealth..::..AssetHealthData type exposes the following members.

Constructors

 | Name | Description
Public method | AssetHealth..::..AssetHealthData | Initializes a new instance of the AssetHealth..::..AssetHealthData class

Fields

 | Name | Description
Public field | Green | Reports amount of green items
Public field | Red | Reports amount of red items
Public field | TotalNumberOfAssets | The total number of assets being considered
Public field | Yellow | Reports amount of yellow items

See Also

AssetHealth..::..AssetHealthData Class


AssetHealth.AssetHealthData Constructor

[image]

Concert Web Services Library
AssetHealth..::..AssetHealthData Constructor
AssetHealth..::..AssetHealthData Class See Also Send Feedback
Initializes a new instance of the AssetHealth..::..AssetHealthData class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AssetHealthData()
Visual Basic
Public Sub New

See Also

AssetHealth..::..AssetHealthData Class
AssetHealth..::..AssetHealthData Members


AssetHealth.AssetHealthData Fields

[image] [image]

Concert Web Services Library
AssetHealth..::..AssetHealthData Fields
AssetHealth..::..AssetHealthData Class See Also Send Feedback

The AssetHealth..::..AssetHealthData type exposes the following members.

Fields

 | Name | Description
Public field | Green | Reports amount of green items
Public field | Red | Reports amount of red items
Public field | TotalNumberOfAssets | The total number of assets being considered
Public field | Yellow | Reports amount of yellow items

See Also

AssetHealth..::..AssetHealthData Class


AssetHealth.AssetHealthData.Green Field

[image]

Concert Web Services Library
AssetHealth..::..AssetHealthData..::..Green Field
AssetHealth..::..AssetHealthData Class See Also Send Feedback
Reports amount of green items

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AssetHealth..::..AssetHealthLevelItem Green
Visual Basic
Public Green As AssetHealth..::..AssetHealthLevelItem

Field Value

Type: AssetHealth..::..AssetHealthLevelItem

See Also

AssetHealth..::..AssetHealthData Class
AssetHealth..::..AssetHealthData Members


AssetHealth.AssetHealthData.Red Field

[image]

Concert Web Services Library
AssetHealth..::..AssetHealthData..::..Red Field
AssetHealth..::..AssetHealthData Class See Also Send Feedback
Reports amount of red items

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AssetHealth..::..AssetHealthLevelItem Red
Visual Basic
Public Red As AssetHealth..::..AssetHealthLevelItem

Field Value

Type: AssetHealth..::..AssetHealthLevelItem

See Also

AssetHealth..::..AssetHealthData Class
AssetHealth..::..AssetHealthData Members


AssetHealth.AssetHealthData.TotalNumberOfAssets Field

[image]

Concert Web Services Library
AssetHealth..::..AssetHealthData..::..TotalNumberOfAssets Field
AssetHealth..::..AssetHealthData Class See Also Send Feedback
The total number of assets being considered

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int TotalNumberOfAssets
Visual Basic
Public TotalNumberOfAssets As Integer

Field Value

Type: Int32

See Also

AssetHealth..::..AssetHealthData Class
AssetHealth..::..AssetHealthData Members


AssetHealth.AssetHealthData.Yellow Field

[image]

Concert Web Services Library
AssetHealth..::..AssetHealthData..::..Yellow Field
AssetHealth..::..AssetHealthData Class See Also Send Feedback
Reports amount of yellow items

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AssetHealth..::..AssetHealthLevelItem Yellow
Visual Basic
Public Yellow As AssetHealth..::..AssetHealthLevelItem

Field Value

Type: AssetHealth..::..AssetHealthLevelItem

See Also

AssetHealth..::..AssetHealthData Class
AssetHealth..::..AssetHealthData Members


AssetHealth.AssetHealthLevelItem Class

[image]

Concert Web Services Library
AssetHealth..::..AssetHealthLevelItem Class
AssetHealth Class Members See Also Send Feedback
The data for a specific asset health level

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class AssetHealthLevelItem
Visual Basic
Public Class AssetHealthLevelItem

Inheritance Hierarchy

System..::..Object
Concert..::..AssetHealth..::..AssetHealthLevelItem

See Also

AssetHealth..::..AssetHealthLevelItem Members


AssetHealth.AssetHealthLevelItem Members

[image] [image]

Concert Web Services Library
AssetHealth..::..AssetHealthLevelItem Members
AssetHealth..::..AssetHealthLevelItem Class Constructors Fields See Also Send Feedback

The AssetHealth..::..AssetHealthLevelItem type exposes the following members.

Constructors

 | Name | Description
Public method | AssetHealth..::..AssetHealthLevelItem | Initializes a new instance of the AssetHealth..::..AssetHealthLevelItem class

Fields

 | Name | Description
Public field | AssetCount | How many items are at the specified asset health level
Public field | PercentageOfAssets | The percentage of assets at the specified asset health level

See Also

AssetHealth..::..AssetHealthLevelItem Class


AssetHealth.AssetHealthLevelItem Constructor

[image]

Concert Web Services Library
AssetHealth..::..AssetHealthLevelItem Constructor
AssetHealth..::..AssetHealthLevelItem Class See Also Send Feedback
Initializes a new instance of the AssetHealth..::..AssetHealthLevelItem class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AssetHealthLevelItem()
Visual Basic
Public Sub New

See Also

AssetHealth..::..AssetHealthLevelItem Class
AssetHealth..::..AssetHealthLevelItem Members


AssetHealth.AssetHealthLevelItem Fields

[image] [image]

Concert Web Services Library
AssetHealth..::..AssetHealthLevelItem Fields
AssetHealth..::..AssetHealthLevelItem Class See Also Send Feedback

The AssetHealth..::..AssetHealthLevelItem type exposes the following members.

Fields

 | Name | Description
Public field | AssetCount | How many items are at the specified asset health level
Public field | PercentageOfAssets | The percentage of assets at the specified asset health level

See Also

AssetHealth..::..AssetHealthLevelItem Class


AssetHealth.AssetHealthLevelItem.AssetCount Field

[image]

Concert Web Services Library
AssetHealth..::..AssetHealthLevelItem..::..AssetCount Field
AssetHealth..::..AssetHealthLevelItem Class See Also Send Feedback
How many items are at the specified asset health level

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int AssetCount
Visual Basic
Public AssetCount As Integer

Field Value

Type: Int32

See Also

AssetHealth..::..AssetHealthLevelItem Class
AssetHealth..::..AssetHealthLevelItem Members


AssetHealth.AssetHealthLevelItem.PercentageOfAssets Field

[image]

Concert Web Services Library
AssetHealth..::..AssetHealthLevelItem..::..PercentageOfAssets Field
AssetHealth..::..AssetHealthLevelItem Class See Also Send Feedback
The percentage of assets at the specified asset health level

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float PercentageOfAssets
Visual Basic
Public PercentageOfAssets As Single

Field Value

Type: Single

See Also

AssetHealth..::..AssetHealthLevelItem Class
AssetHealth..::..AssetHealthLevelItem Members


ConcertDatabaseAlias Class

[image]

Concert Web Services Library
ConcertDatabaseAlias Class
Members See Also Send Feedback
This class provides information to select a database using a two part value.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class ConcertDatabaseAlias
Visual Basic
<SerializableAttribute>
Public Class ConcertDatabaseAlias

Inheritance Hierarchy

System..::..Object
Concert..::..ConcertDatabaseAlias
Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser

See Also

ConcertDatabaseAlias Members


ConcertDatabaseAlias Members

[image] [image]

Concert Web Services Library
ConcertDatabaseAlias Members
ConcertDatabaseAlias Class Fields See Also Send Feedback

The ConcertDatabaseAlias type exposes the following members.

Fields

 | Name | Description
Public field | DatabaseAlias | A database alias is a value by which a database is known. The Tango database GUID (TangoDatabaseGUID) is one option, but other options such as "SAPPlantNumber" can be used to identify the database by an external value.
Public field | DatabaseAliasType | Indicates the type of value being passed in DatabaseAlias. The most common value is TangoDatabaseGUID. Other options exist or can be added as needed.

See Also

ConcertDatabaseAlias Class


ConcertDatabaseAlias Fields

[image] [image]

Concert Web Services Library
ConcertDatabaseAlias Fields
ConcertDatabaseAlias Class See Also Send Feedback

The ConcertDatabaseAlias type exposes the following members.

Fields

 | Name | Description
Public field | DatabaseAlias | A database alias is a value by which a database is known. The Tango database GUID (TangoDatabaseGUID) is one option, but other options such as "SAPPlantNumber" can be used to identify the database by an external value.
Public field | DatabaseAliasType | Indicates the type of value being passed in DatabaseAlias. The most common value is TangoDatabaseGUID. Other options exist or can be added as needed.

See Also

ConcertDatabaseAlias Class


ConcertDatabaseAlias.DatabaseAlias Field

[image]

Concert Web Services Library
ConcertDatabaseAlias..::..DatabaseAlias Field
ConcertDatabaseAlias Class See Also Send Feedback
A database alias is a value by which a database is known. The Tango database GUID (TangoDatabaseGUID) is one option, but other options such as "SAPPlantNumber" can be used to identify the database by an external value.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DatabaseAlias
Visual Basic
Public DatabaseAlias As String

Field Value

Type: String

See Also

ConcertDatabaseAlias Class
ConcertDatabaseAlias Members


ConcertDatabaseAlias.DatabaseAliasType Field

[image]

Concert Web Services Library
ConcertDatabaseAlias..::..DatabaseAliasType Field
ConcertDatabaseAlias Class See Also Send Feedback
Indicates the type of value being passed in DatabaseAlias. The most common value is TangoDatabaseGUID. Other options exist or can be added as needed.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DatabaseAliasType
Visual Basic
Public DatabaseAliasType As String

Field Value

Type: String

See Also

ConcertDatabaseAlias Class
ConcertDatabaseAlias Members


ConcertDatabaseAliasAndExternalInterfaceUser Class

[image]

Concert Web Services Library
ConcertDatabaseAliasAndExternalInterfaceUser Class
Members See Also Send Feedback
This class provides information to select a database using a two part value and a Tango user login information. Every Tango database has a GUID (globally unique identifier). A common alias type for all Tango databases is "TangoDatabaseGUID" and is paired with the database GUID. When you log into a Tango database, the GUID is visible on the URL.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class ConcertDatabaseAliasAndExternalInterfaceUser : ConcertDatabaseAlias
Visual Basic
<SerializableAttribute>
Public Class ConcertDatabaseAliasAndExternalInterfaceUser
    Inherits ConcertDatabaseAlias

Inheritance Hierarchy

System..::..Object
Concert..::..ConcertDatabaseAlias
Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser

See Also

ConcertDatabaseAliasAndExternalInterfaceUser Members


ConcertDatabaseAliasAndExternalInterfaceUser Members

[image] [image]

Concert Web Services Library
ConcertDatabaseAliasAndExternalInterfaceUser Members
ConcertDatabaseAliasAndExternalInterfaceUser Class Fields See Also Send Feedback

The ConcertDatabaseAliasAndExternalInterfaceUser type exposes the following members.

Fields

 | Name | Description
Public field | DatabaseAlias | A database alias is a value by which a database is known. The Tango database GUID (TangoDatabaseGUID) is one option, but other options such as "SAPPlantNumber" can be used to identify the database by an external value. (Inherited from ConcertDatabaseAlias.)
Public field | DatabaseAliasType | Indicates the type of value being passed in DatabaseAlias. The most common value is TangoDatabaseGUID. Other options exist or can be added as needed. (Inherited from ConcertDatabaseAlias.)
Public field | Password | Tango user password
Public field | UserName | Tango username. The user must be setup as: AssumeDemotedUserRolesByDefault = true, HasEditLocationRights = false, HasEditEquipmentRights = false

See Also

ConcertDatabaseAliasAndExternalInterfaceUser Class


ConcertDatabaseAliasAndExternalInterfaceUser Fields

[image] [image]

Concert Web Services Library
ConcertDatabaseAliasAndExternalInterfaceUser Fields
ConcertDatabaseAliasAndExternalInterfaceUser Class See Also Send Feedback

The ConcertDatabaseAliasAndExternalInterfaceUser type exposes the following members.

Fields

 | Name | Description
Public field | DatabaseAlias | A database alias is a value by which a database is known. The Tango database GUID (TangoDatabaseGUID) is one option, but other options such as "SAPPlantNumber" can be used to identify the database by an external value. (Inherited from ConcertDatabaseAlias.)
Public field | DatabaseAliasType | Indicates the type of value being passed in DatabaseAlias. The most common value is TangoDatabaseGUID. Other options exist or can be added as needed. (Inherited from ConcertDatabaseAlias.)
Public field | Password | Tango user password
Public field | UserName | Tango username. The user must be setup as: AssumeDemotedUserRolesByDefault = true, HasEditLocationRights = false, HasEditEquipmentRights = false

See Also

ConcertDatabaseAliasAndExternalInterfaceUser Class


ConcertDatabaseAliasAndExternalInterfaceUser.Password Field

[image]

Concert Web Services Library
ConcertDatabaseAliasAndExternalInterfaceUser..::..Password Field
ConcertDatabaseAliasAndExternalInterfaceUser Class See Also Send Feedback
Tango user password

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Password
Visual Basic
Public Password As String

Field Value

Type: String

See Also

ConcertDatabaseAliasAndExternalInterfaceUser Class
ConcertDatabaseAliasAndExternalInterfaceUser Members


ConcertDatabaseAliasAndExternalInterfaceUser.UserName Field

[image]

Concert Web Services Library
ConcertDatabaseAliasAndExternalInterfaceUser..::..UserName Field
ConcertDatabaseAliasAndExternalInterfaceUser Class See Also Send Feedback
Tango username. The user must be setup as: AssumeDemotedUserRolesByDefault = true, HasEditLocationRights = false, HasEditEquipmentRights = false

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string UserName
Visual Basic
Public UserName As String

Field Value

Type: String

See Also

ConcertDatabaseAliasAndExternalInterfaceUser Class
ConcertDatabaseAliasAndExternalInterfaceUser Members


ConditionEntry Class

[image]

Concert Web Services Library
ConditionEntry Class
Members See Also Send Feedback
This service provides access to Technology Condition Entries in Tango Access from http://www.tf7.com/Concert/ConditionEntry.asmx

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ConditionEntry : ConcertWebServiceBase
Visual Basic
Public Class ConditionEntry
    Inherits ConcertWebServiceBase

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..MarshalByValueComponent
System.Web.Services..::..WebService
ConcertWebServiceBase
Concert..::..ConditionEntry

See Also

ConditionEntry Members


ConditionEntry Members

[image] [image]

Concert Web Services Library
ConditionEntry Members
ConditionEntry Class Constructors Methods See Also Send Feedback

The ConditionEntry type exposes the following members.

Constructors

 | Name | Description
Public method | ConditionEntry | Initializes a new instance of the ConditionEntry class

Methods

 | Name | Description
Public method | CheckOff | Used to checkoff a condition entry
Public method | ConditionEntriesByModificationTimeRange | Fetch all entries between two dates
Public method | ConditionEntriesByModificationTimestamp | Determine which condition entries have changed since a specified date
Public method | SetConditionEntryValue | Set condition entry values in Tango
Public method | SetWorkOrderByWorkRequest | Set the work order number based on an existing work order request number

See Also

ConditionEntry Class


ConditionEntry Constructor

[image]

Concert Web Services Library
ConditionEntry Constructor
ConditionEntry Class See Also Send Feedback
Initializes a new instance of the ConditionEntry class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ConditionEntry()
Visual Basic
Public Sub New

See Also

ConditionEntry Class
ConditionEntry Members


ConditionEntry Methods

[image] [image]

Concert Web Services Library
ConditionEntry Methods
ConditionEntry Class See Also Send Feedback

The ConditionEntry type exposes the following members.

Methods

 | Name | Description
Public method | CheckOff | Used to checkoff a condition entry
Public method | ConditionEntriesByModificationTimeRange | Fetch all entries between two dates
Public method | ConditionEntriesByModificationTimestamp | Determine which condition entries have changed since a specified date
Public method | SetConditionEntryValue | Set condition entry values in Tango
Public method | SetWorkOrderByWorkRequest | Set the work order number based on an existing work order request number

See Also

ConditionEntry Class


ConditionEntry.CheckOff Method

[image]

Concert Web Services Library
ConditionEntry..::..CheckOff Method
ConditionEntry Class See Also Send Feedback
Used to checkoff a condition entry

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public XmlNode CheckOff(
    string DatabaseAlias,
    string DatabaseAliasType,
    string CheckoffUserName,
    string CheckoffUserPassword,
    string WorkOrderCode,
    string CheckoffComments,
    bool CheckoffEntireCase,
    ConditionEntry..::..ConditionEntryAttribute[] conditionEntryAttributes
)
Visual Basic
Public Function CheckOff (
    DatabaseAlias As String,
    DatabaseAliasType As String,
    CheckoffUserName As String,
    CheckoffUserPassword As String,
    WorkOrderCode As String,
    CheckoffComments As String,
    CheckoffEntireCase As Boolean,
    conditionEntryAttributes As ConditionEntry..::..ConditionEntryAttribute()
) As XmlNode

Parameters

DatabaseAlias
Type: System..::..String
A value used to reference this database
DatabaseAliasType
Type: System..::..String
The description of the value used to reference the database
CheckoffUserName
Type: System..::..String
The user name to be associated with the checkoff of the condition entry
CheckoffUserPassword
Type: System..::..String
The password for the user to be associated with the checkoff of the condition entry
WorkOrderCode
Type: System..::..String
The work order number associated with the condition entry (or entries) being checked off
CheckoffComments
Type: System..::..String
Any comments to be associated with the checkoff
CheckoffEntireCase
Type: System..::..Boolean
Do we want all condition entries in the case to be checked off even if they don't have a matching work order number
conditionEntryAttributes
Type: array< Concert..::..ConditionEntry..::..ConditionEntryAttribute >[]()[][]
An array of condition entry attributes to be saved after the checkoff has been completed.

Return Value

Type: XmlNode

See Also

ConditionEntry Class
ConditionEntry Members


ConditionEntry.ConditionEntriesByModificationTimeRange Method

[image]

Concert Web Services Library
ConditionEntry..::..ConditionEntriesByModificationTimeRange Method
ConditionEntry Class See Also Send Feedback
Fetch all entries between two dates

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public XmlNode ConditionEntriesByModificationTimeRange(
    DateTime StartingDate,
    DateTime EndingDate,
    string DatabaseAlias,
    string DatabaseAliasType,
    string UserName,
    string UserPassword
)
Visual Basic
Public Function ConditionEntriesByModificationTimeRange (
    StartingDate As DateTime,
    EndingDate As DateTime,
    DatabaseAlias As String,
    DatabaseAliasType As String,
    UserName As String,
    UserPassword As String
) As XmlNode

Parameters

StartingDate
Type: System..::..DateTime
Starting timestamp for the modification time range
EndingDate
Type: System..::..DateTime
Ending timestamp for the modification time range
DatabaseAlias
Type: System..::..String
A value used to reference this database
DatabaseAliasType
Type: System..::..String
The description of the value used to reference the database
UserName
Type: System..::..String
The user name attributed to the change
UserPassword
Type: System..::..String
The user password attributed to the change

Return Value

Type: XmlNode
A list of the condition entry information

See Also

ConditionEntry Class
ConditionEntry Members


ConditionEntry.ConditionEntriesByModificationTimestamp Method

[image]

Concert Web Services Library
ConditionEntry..::..ConditionEntriesByModificationTimestamp Method
ConditionEntry Class See Also Send Feedback
Determine which condition entries have changed since a specified date

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public XmlNode ConditionEntriesByModificationTimestamp(
    DateTime ChangesFollowingTimestamp,
    string DatabaseAlias,
    string DatabaseAliasType,
    string UserName,
    string UserPassword
)
Visual Basic
Public Function ConditionEntriesByModificationTimestamp (
    ChangesFollowingTimestamp As DateTime,
    DatabaseAlias As String,
    DatabaseAliasType As String,
    UserName As String,
    UserPassword As String
) As XmlNode

Parameters

ChangesFollowingTimestamp
Type: System..::..DateTime
Fetch all entries which have changed starting with and including this date until now
DatabaseAlias
Type: System..::..String
A value used to reference this database
DatabaseAliasType
Type: System..::..String
The description of the value used to reference the database
UserName
Type: System..::..String
The user name attributed to the change
UserPassword
Type: System..::..String
The user password attributed to the change

Return Value

Type: XmlNode
A list of the condition entry information

See Also

ConditionEntry Class
ConditionEntry Members


ConditionEntry.SetConditionEntryValue Method

[image]

Concert Web Services Library
ConditionEntry..::..SetConditionEntryValue Method
ConditionEntry Class See Also Send Feedback
Set condition entry values in Tango

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetConditionEntryValue(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser,
    Guid ConditionEntryGuid,
    List<ConditionEntry..::..ConditionEntryValue> ConditionEntryValues
)
Visual Basic
Public Sub SetConditionEntryValue (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser,
    ConditionEntryGuid As Guid,
    ConditionEntryValues As List(Of ConditionEntry..::..ConditionEntryValue)
)

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Login credentials
ConditionEntryGuid
Type: System..::..Guid
Unique identifier associated with the condition entry we'll be updating
ConditionEntryValues
Type: System.Collections.Generic..::..List <(Of <(<' ConditionEntry..::..ConditionEntryValue >)>)>
One or more values to change for the specified condition entry

See Also

ConditionEntry Class
ConditionEntry Members


ConditionEntry.SetWorkOrderByWorkRequest Method

[image]

Concert Web Services Library
ConditionEntry..::..SetWorkOrderByWorkRequest Method
ConditionEntry Class See Also Send Feedback
Set the work order number based on an existing work order request number

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public XmlNode SetWorkOrderByWorkRequest(
    string DatabaseAlias,
    string DatabaseAliasType,
    string UserName,
    string UserPassword,
    string WorkRequestCode,
    string WorkOrderCode,
    bool OverrideExistingWorkOrderValues
)
Visual Basic
Public Function SetWorkOrderByWorkRequest (
    DatabaseAlias As String,
    DatabaseAliasType As String,
    UserName As String,
    UserPassword As String,
    WorkRequestCode As String,
    WorkOrderCode As String,
    OverrideExistingWorkOrderValues As Boolean
) As XmlNode

Parameters

DatabaseAlias
Type: System..::..String
A value used to reference this database
DatabaseAliasType
Type: System..::..String
The description of the value used to reference the database
UserName
Type: System..::..String
The user name attributed to the change
UserPassword
Type: System..::..String
The user password attributed to the change
WorkRequestCode
Type: System..::..String
The work request code we're using to look up the condition entry to update
WorkOrderCode
Type: System..::..String
The work order number we're going to write to the condition entries mathing the work request code.
OverrideExistingWorkOrderValues
Type: System..::..Boolean
Do we want to overwrite and existing work order code with a new work order code.

Return Value

Type: XmlNode

See Also

ConditionEntry Class
ConditionEntry Members


ConditionEntry.ConditionEntryAttribute Class

[image]

Concert Web Services Library
ConditionEntry..::..ConditionEntryAttribute Class
ConditionEntry Class Members See Also Send Feedback
This class indicates condition entry attribute values

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ConditionEntryAttribute
Visual Basic
Public Class ConditionEntryAttribute

Inheritance Hierarchy

System..::..Object
Concert..::..ConditionEntry..::..ConditionEntryAttribute

See Also

ConditionEntry..::..ConditionEntryAttribute Members


ConditionEntry.ConditionEntryAttribute Members

[image] [image]

Concert Web Services Library
ConditionEntry..::..ConditionEntryAttribute Members
ConditionEntry..::..ConditionEntryAttribute Class Constructors Properties See Also Send Feedback

The ConditionEntry..::..ConditionEntryAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ConditionEntry..::..ConditionEntryAttribute | Initializes a new instance of the ConditionEntry..::..ConditionEntryAttribute class

Properties

 | Name | Description
Public property | AttributeTypeName | The type of condition entry attribute (Area Of Responsibility, Corrective Work Code, Status Comment, etc)
Public property | AttributeValue | The value associated with the condition entry attribute (for an Area Of Responsibility it might be "CoGen")

See Also

ConditionEntry..::..ConditionEntryAttribute Class


ConditionEntry.ConditionEntryAttribute Constructor

[image]

Concert Web Services Library
ConditionEntry..::..ConditionEntryAttribute Constructor
ConditionEntry..::..ConditionEntryAttribute Class See Also Send Feedback
Initializes a new instance of the ConditionEntry..::..ConditionEntryAttribute class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ConditionEntryAttribute()
Visual Basic
Public Sub New

See Also

ConditionEntry..::..ConditionEntryAttribute Class
ConditionEntry..::..ConditionEntryAttribute Members


ConditionEntry.ConditionEntryAttribute Properties

[image] [image]

Concert Web Services Library
ConditionEntry..::..ConditionEntryAttribute Properties
ConditionEntry..::..ConditionEntryAttribute Class See Also Send Feedback

The ConditionEntry..::..ConditionEntryAttribute type exposes the following members.

Properties

 | Name | Description
Public property | AttributeTypeName | The type of condition entry attribute (Area Of Responsibility, Corrective Work Code, Status Comment, etc)
Public property | AttributeValue | The value associated with the condition entry attribute (for an Area Of Responsibility it might be "CoGen")

See Also

ConditionEntry..::..ConditionEntryAttribute Class


ConditionEntry.ConditionEntryAttribute.AttributeTypeName Property

[image]

Concert Web Services Library
ConditionEntry..::..ConditionEntryAttribute..::..AttributeTypeName Property
ConditionEntry..::..ConditionEntryAttribute Class See Also Send Feedback
The type of condition entry attribute (Area Of Responsibility, Corrective Work Code, Status Comment, etc)

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string AttributeTypeName { get; set; }
Visual Basic
Public Property AttributeTypeName As String
    Get
    Set

Property Value

Type: String

See Also

ConditionEntry..::..ConditionEntryAttribute Class
ConditionEntry..::..ConditionEntryAttribute Members


ConditionEntry.ConditionEntryAttribute.AttributeValue Property

[image]

Concert Web Services Library
ConditionEntry..::..ConditionEntryAttribute..::..AttributeValue Property
ConditionEntry..::..ConditionEntryAttribute Class See Also Send Feedback
The value associated with the condition entry attribute (for an Area Of Responsibility it might be "CoGen")

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string AttributeValue { get; set; }
Visual Basic
Public Property AttributeValue As String
    Get
    Set

Property Value

Type: String

See Also

ConditionEntry..::..ConditionEntryAttribute Class
ConditionEntry..::..ConditionEntryAttribute Members


ConditionEntry.ConditionEntryValue Class

[image]

Concert Web Services Library
ConditionEntry..::..ConditionEntryValue Class
ConditionEntry Class Members See Also Send Feedback
A pairing of a value type and the matching value.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ConditionEntryValue
Visual Basic
Public Class ConditionEntryValue

Inheritance Hierarchy

System..::..Object
Concert..::..ConditionEntry..::..ConditionEntryValue

See Also

ConditionEntry..::..ConditionEntryValue Members


ConditionEntry.ConditionEntryValue Members

[image] [image]

Concert Web Services Library
ConditionEntry..::..ConditionEntryValue Members
ConditionEntry..::..ConditionEntryValue Class Constructors Properties See Also Send Feedback

The ConditionEntry..::..ConditionEntryValue type exposes the following members.

Constructors

 | Name | Description
Public method | ConditionEntry..::..ConditionEntryValue | Initializes a new instance of the ConditionEntry..::..ConditionEntryValue class

Properties

 | Name | Description
Public property | ConditionEntryValueType | The type of condition entry value. See ConditionEntryValueType for known values -- use the name of the enumeration for this value. Other values may exist
Public property | Value | The condition entry value To allow for easy transmission, all data should be converted to text. For date values it is recommended you pass as: yyyy-mm-dd hh:mm:ss.ms -- use military time for hours

See Also

ConditionEntry..::..ConditionEntryValue Class


ConditionEntry.ConditionEntryValue Constructor

[image]

Concert Web Services Library
ConditionEntry..::..ConditionEntryValue Constructor
ConditionEntry..::..ConditionEntryValue Class See Also Send Feedback
Initializes a new instance of the ConditionEntry..::..ConditionEntryValue class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ConditionEntryValue()
Visual Basic
Public Sub New

See Also

ConditionEntry..::..ConditionEntryValue Class
ConditionEntry..::..ConditionEntryValue Members


ConditionEntry.ConditionEntryValue Properties

[image] [image]

Concert Web Services Library
ConditionEntry..::..ConditionEntryValue Properties
ConditionEntry..::..ConditionEntryValue Class See Also Send Feedback

The ConditionEntry..::..ConditionEntryValue type exposes the following members.

Properties

 | Name | Description
Public property | ConditionEntryValueType | The type of condition entry value. See ConditionEntryValueType for known values -- use the name of the enumeration for this value. Other values may exist
Public property | Value | The condition entry value To allow for easy transmission, all data should be converted to text. For date values it is recommended you pass as: yyyy-mm-dd hh:mm:ss.ms -- use military time for hours

See Also

ConditionEntry..::..ConditionEntryValue Class


ConditionEntry.ConditionEntryValue.ConditionEntryValueType Property

[image]

Concert Web Services Library
ConditionEntry..::..ConditionEntryValue..::..ConditionEntryValueType Property
ConditionEntry..::..ConditionEntryValue Class See Also Send Feedback
The type of condition entry value. See ConditionEntryValueType for known values -- use the name of the enumeration for this value. Other values may exist

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ConditionEntryValueType { get; set; }
Visual Basic
Public Property ConditionEntryValueType As String
    Get
    Set

Property Value

Type: String

See Also

ConditionEntry..::..ConditionEntryValue Class
ConditionEntry..::..ConditionEntryValue Members


ConditionEntry.ConditionEntryValue.Value Property

[image]

Concert Web Services Library
ConditionEntry..::..ConditionEntryValue..::..Value Property
ConditionEntry..::..ConditionEntryValue Class See Also Send Feedback
The condition entry value To allow for easy transmission, all data should be converted to text. For date values it is recommended you pass as: yyyy-mm-dd hh:mm:ss.ms -- use military time for hours

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set

Property Value

Type: String

See Also

ConditionEntry..::..ConditionEntryValue Class
ConditionEntry..::..ConditionEntryValue Members


ConditionEntry.ConditionEntryValueType Enumeration

[image]

Concert Web Services Library
ConditionEntry..::..ConditionEntryValueType Enumeration
ConditionEntry Class See Also Send Feedback
The types of condition entry values

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum ConditionEntryValueType
Visual Basic
Public Enumeration ConditionEntryValueType

Members

Member name | Value | Description
WorkRequestNumber | 0 | The work order request number value
WorkOrderNumber | 1 | The work order number value

See Also

Concert Namespace


IConditionEntryEvent Class

[image]

Concert Web Services Library
IConditionEntryEvent Class
Members See Also Send Feedback
Summary description for IConditionEntryEvent This interface describes how to consume the 24/7 Concert web service for condition entries.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class IConditionEntryEvent : ConcertWebServiceBase
Visual Basic
Public Class IConditionEntryEvent
    Inherits ConcertWebServiceBase

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..MarshalByValueComponent
System.Web.Services..::..WebService
ConcertWebServiceBase
Concert..::..IConditionEntryEvent

See Also

IConditionEntryEvent Members


IConditionEntryEvent Members

[image] [image]

Concert Web Services Library
IConditionEntryEvent Members
IConditionEntryEvent Class Constructors Methods See Also Send Feedback

The IConditionEntryEvent type exposes the following members.

Constructors

 | Name | Description
Public method | IConditionEntryEvent | Initializes a new instance of the IConditionEntryEvent class

Methods

 | Name | Description
Public method | ConditionEntryEvent | This external method is called as a result of a change to a condition entry. The type of change is indicated by the event type.

See Also

IConditionEntryEvent Class


IConditionEntryEvent Constructor

[image]

Concert Web Services Library
IConditionEntryEvent Constructor
IConditionEntryEvent Class See Also Send Feedback
Initializes a new instance of the IConditionEntryEvent class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IConditionEntryEvent()
Visual Basic
Public Sub New

See Also

IConditionEntryEvent Class
IConditionEntryEvent Members


IConditionEntryEvent Methods

[image] [image]

Concert Web Services Library
IConditionEntryEvent Methods
IConditionEntryEvent Class See Also Send Feedback

The IConditionEntryEvent type exposes the following members.

Methods

 | Name | Description
Public method | ConditionEntryEvent | This external method is called as a result of a change to a condition entry. The type of change is indicated by the event type.

See Also

IConditionEntryEvent Class


IConditionEntryEvent.ConditionEntryEvent Method

[image]

Concert Web Services Library
IConditionEntryEvent..::..ConditionEntryEvent Method
IConditionEntryEvent Class See Also Send Feedback
This external method is called as a result of a change to a condition entry. The type of change is indicated by the event type.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public XmlNode ConditionEntryEvent(
    string EventName,
    IConditionEntryEvent..::..TangoLocation Location,
    DateTime ConditionEntryDate,
    string SeverityName,
    int SeverityLevel,
    string ConditionComment,
    string Recommendations,
    IConditionEntryEvent..::..FaultItem[] FaultItem
)
Visual Basic
Public Function ConditionEntryEvent (
    EventName As String,
    Location As IConditionEntryEvent..::..TangoLocation,
    ConditionEntryDate As DateTime,
    SeverityName As String,
    SeverityLevel As Integer,
    ConditionComment As String,
    Recommendations As String,
    FaultItem As IConditionEntryEvent..::..FaultItem()
) As XmlNode

Parameters

EventName
Type: System..::..String
The type of event that has jut occured for a condition entry: GenerateWorkRequest GenerateWorkOrder ConditionEntryCheckOff ConditionEntryClosure
Location
Type: Concert..::..IConditionEntryEvent..::..TangoLocation
The location where the work order is being entered against
ConditionEntryDate
Type: System..::..DateTime
When the condition entry was added to the Tango database
SeverityName
Type: System..::..String
The name associated with the severity of the condition entry
SeverityLevel
Type: System..::..Int32
The numeric serverity value stored in the Tango database
ConditionComment
Type: System..::..String
Any comment associated with the condition entry
Recommendations
Type: System..::..String
Any recommendations associated with the condition entry
FaultItem
Type: array< Concert..::..IConditionEntryEvent..::..FaultItem >[]()[][]
The faults names associated with the condition entry

Return Value

Type: XmlNode
"Success: {Work Order Number}" when the work order is created. {Work Order Number} = The generated work order number "Failure: {Failure reason}" when there is a problem and no work order was created {Failure reason} = The reason the work order was not created

See Also

IConditionEntryEvent Class
IConditionEntryEvent Members


IConditionEntryEvent.FaultItem Class

[image]

Concert Web Services Library
IConditionEntryEvent..::..FaultItem Class
IConditionEntryEvent Class Members See Also Send Feedback
A single Tango Fault Item

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class FaultItem
Visual Basic
Public Class FaultItem

Inheritance Hierarchy

System..::..Object
Concert..::..IConditionEntryEvent..::..FaultItem

See Also

IConditionEntryEvent..::..FaultItem Members


IConditionEntryEvent.FaultItem Members

[image] [image]

Concert Web Services Library
IConditionEntryEvent..::..FaultItem Members
IConditionEntryEvent..::..FaultItem Class Properties See Also Send Feedback

The IConditionEntryEvent..::..FaultItem type exposes the following members.

Properties

 | Name | Description
Public property | FaultGroupName | The fault type (ie. Bearing Fault, Pump Fault, Electrical Fault)
Public property | FaultTypeItemGUID | The unique Tango identifier for the fault
Public property | FaultTypeItemName | The specific fault name (ie. Outer race bearing damage)

See Also

IConditionEntryEvent..::..FaultItem Class


IConditionEntryEvent.FaultItem Properties

[image] [image]

Concert Web Services Library
IConditionEntryEvent..::..FaultItem Properties
IConditionEntryEvent..::..FaultItem Class See Also Send Feedback

The IConditionEntryEvent..::..FaultItem type exposes the following members.

Properties

 | Name | Description
Public property | FaultGroupName | The fault type (ie. Bearing Fault, Pump Fault, Electrical Fault)
Public property | FaultTypeItemGUID | The unique Tango identifier for the fault
Public property | FaultTypeItemName | The specific fault name (ie. Outer race bearing damage)

See Also

IConditionEntryEvent..::..FaultItem Class


IConditionEntryEvent.FaultItem.FaultGroupName Property

[image]

Concert Web Services Library
IConditionEntryEvent..::..FaultItem..::..FaultGroupName Property
IConditionEntryEvent..::..FaultItem Class See Also Send Feedback
The fault type (ie. Bearing Fault, Pump Fault, Electrical Fault)

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string FaultGroupName { get; set; }
Visual Basic
Public Property FaultGroupName As String
    Get
    Set

Property Value

Type: String

See Also

IConditionEntryEvent..::..FaultItem Class
IConditionEntryEvent..::..FaultItem Members


IConditionEntryEvent.FaultItem.FaultTypeItemGUID Property

[image]

Concert Web Services Library
IConditionEntryEvent..::..FaultItem..::..FaultTypeItemGUID Property
IConditionEntryEvent..::..FaultItem Class See Also Send Feedback
The unique Tango identifier for the fault

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid FaultTypeItemGUID { get; set; }
Visual Basic
Public Property FaultTypeItemGUID As Guid
    Get
    Set

Property Value

Type: Guid

See Also

IConditionEntryEvent..::..FaultItem Class
IConditionEntryEvent..::..FaultItem Members


IConditionEntryEvent.FaultItem.FaultTypeItemName Property

[image]

Concert Web Services Library
IConditionEntryEvent..::..FaultItem..::..FaultTypeItemName Property
IConditionEntryEvent..::..FaultItem Class See Also Send Feedback
The specific fault name (ie. Outer race bearing damage)

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string FaultTypeItemName { get; set; }
Visual Basic
Public Property FaultTypeItemName As String
    Get
    Set

Property Value

Type: String

See Also

IConditionEntryEvent..::..FaultItem Class
IConditionEntryEvent..::..FaultItem Members


IConditionEntryEvent.TangoAlias Class

[image]

Concert Web Services Library
IConditionEntryEvent..::..TangoAlias Class
IConditionEntryEvent Class Members See Also Send Feedback
A Tango location alias.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TangoAlias
Visual Basic
Public Class TangoAlias

Inheritance Hierarchy

System..::..Object
Concert..::..IConditionEntryEvent..::..TangoAlias

See Also

IConditionEntryEvent..::..TangoAlias Members


IConditionEntryEvent.TangoAlias Members

[image] [image]

Concert Web Services Library
IConditionEntryEvent..::..TangoAlias Members
IConditionEntryEvent..::..TangoAlias Class Constructors Properties See Also Send Feedback

The IConditionEntryEvent..::..TangoAlias type exposes the following members.

Constructors

 | Name | Description
Public method | IConditionEntryEvent..::..TangoAlias | Initializes a new instance of the IConditionEntryEvent..::..TangoAlias class

Properties

 | Name | Description
Public property | AliasTypeDesc | The type of alias (ie. If this is an SAP alias, the type description would be "SAP".
Public property | AliasValue | The alias value (ie. If this is an SAP alias, this would be the SAP number)

See Also

IConditionEntryEvent..::..TangoAlias Class


IConditionEntryEvent.TangoAlias Constructor

[image]

Concert Web Services Library
IConditionEntryEvent..::..TangoAlias Constructor
IConditionEntryEvent..::..TangoAlias Class See Also Send Feedback
Initializes a new instance of the IConditionEntryEvent..::..TangoAlias class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoAlias()
Visual Basic
Public Sub New

See Also

IConditionEntryEvent..::..TangoAlias Class
IConditionEntryEvent..::..TangoAlias Members


IConditionEntryEvent.TangoAlias Properties

[image] [image]

Concert Web Services Library
IConditionEntryEvent..::..TangoAlias Properties
IConditionEntryEvent..::..TangoAlias Class See Also Send Feedback

The IConditionEntryEvent..::..TangoAlias type exposes the following members.

Properties

 | Name | Description
Public property | AliasTypeDesc | The type of alias (ie. If this is an SAP alias, the type description would be "SAP".
Public property | AliasValue | The alias value (ie. If this is an SAP alias, this would be the SAP number)

See Also

IConditionEntryEvent..::..TangoAlias Class


IConditionEntryEvent.TangoAlias.AliasTypeDesc Property

[image]

Concert Web Services Library
IConditionEntryEvent..::..TangoAlias..::..AliasTypeDesc Property
IConditionEntryEvent..::..TangoAlias Class See Also Send Feedback
The type of alias (ie. If this is an SAP alias, the type description would be "SAP".

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string AliasTypeDesc { get; set; }
Visual Basic
Public Property AliasTypeDesc As String
    Get
    Set

Property Value

Type: String

See Also

IConditionEntryEvent..::..TangoAlias Class
IConditionEntryEvent..::..TangoAlias Members


IConditionEntryEvent.TangoAlias.AliasValue Property

[image]

Concert Web Services Library
IConditionEntryEvent..::..TangoAlias..::..AliasValue Property
IConditionEntryEvent..::..TangoAlias Class See Also Send Feedback
The alias value (ie. If this is an SAP alias, this would be the SAP number)

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string AliasValue { get; set; }
Visual Basic
Public Property AliasValue As String
    Get
    Set

Property Value

Type: String

See Also

IConditionEntryEvent..::..TangoAlias Class
IConditionEntryEvent..::..TangoAlias Members


IConditionEntryEvent.TangoLocation Class

[image]

Concert Web Services Library
IConditionEntryEvent..::..TangoLocation Class
IConditionEntryEvent Class Members See Also Send Feedback
Tango Location info associated with an asset component

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TangoLocation
Visual Basic
Public Class TangoLocation

Inheritance Hierarchy

System..::..Object
Concert..::..IConditionEntryEvent..::..TangoLocation

See Also

IConditionEntryEvent..::..TangoLocation Members


IConditionEntryEvent.TangoLocation Members

[image] [image]

Concert Web Services Library
IConditionEntryEvent..::..TangoLocation Members
IConditionEntryEvent..::..TangoLocation Class Constructors Properties See Also Send Feedback

The IConditionEntryEvent..::..TangoLocation type exposes the following members.

Constructors

 | Name | Description
Public method | IConditionEntryEvent..::..TangoLocation | Initializes a new instance of the IConditionEntryEvent..::..TangoLocation class

Properties

 | Name | Description
Public property | Aliases | The Tango alias values associated with the specified location
Public property | Asset | The Tango asset name
Public property | AssetComponent | The Tango asset component name
Public property | Function | The Tango function name
Public property | HostedDatabaseGUID | The database GUID for the
Public property | Plant | The Tango plant name
Public property | Unit | The Tango unit name

See Also

IConditionEntryEvent..::..TangoLocation Class


IConditionEntryEvent.TangoLocation Constructor

[image]

Concert Web Services Library
IConditionEntryEvent..::..TangoLocation Constructor
IConditionEntryEvent..::..TangoLocation Class See Also Send Feedback
Initializes a new instance of the IConditionEntryEvent..::..TangoLocation class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoLocation()
Visual Basic
Public Sub New

See Also

IConditionEntryEvent..::..TangoLocation Class
IConditionEntryEvent..::..TangoLocation Members


IConditionEntryEvent.TangoLocation Properties

[image] [image]

Concert Web Services Library
IConditionEntryEvent..::..TangoLocation Properties
IConditionEntryEvent..::..TangoLocation Class See Also Send Feedback

The IConditionEntryEvent..::..TangoLocation type exposes the following members.

Properties

 | Name | Description
Public property | Aliases | The Tango alias values associated with the specified location
Public property | Asset | The Tango asset name
Public property | AssetComponent | The Tango asset component name
Public property | Function | The Tango function name
Public property | HostedDatabaseGUID | The database GUID for the
Public property | Plant | The Tango plant name
Public property | Unit | The Tango unit name

See Also

IConditionEntryEvent..::..TangoLocation Class


IConditionEntryEvent.TangoLocation.Aliases Property

[image]

Concert Web Services Library
IConditionEntryEvent..::..TangoLocation..::..Aliases Property
IConditionEntryEvent..::..TangoLocation Class See Also Send Feedback
The Tango alias values associated with the specified location

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IConditionEntryEvent..::..TangoAlias[] Aliases { get; set; }
Visual Basic
Public Property Aliases As IConditionEntryEvent..::..TangoAlias()
    Get
    Set

Property Value

Type: array< IConditionEntryEvent..::..TangoAlias >[]()[][]

See Also

IConditionEntryEvent..::..TangoLocation Class
IConditionEntryEvent..::..TangoLocation Members


IConditionEntryEvent.TangoLocation.Asset Property

[image]

Concert Web Services Library
IConditionEntryEvent..::..TangoLocation..::..Asset Property
IConditionEntryEvent..::..TangoLocation Class See Also Send Feedback
The Tango asset name

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Asset { get; set; }
Visual Basic
Public Property Asset As String
    Get
    Set

Property Value

Type: String

See Also

IConditionEntryEvent..::..TangoLocation Class
IConditionEntryEvent..::..TangoLocation Members


IConditionEntryEvent.TangoLocation.AssetComponent Property

[image]

Concert Web Services Library
IConditionEntryEvent..::..TangoLocation..::..AssetComponent Property
IConditionEntryEvent..::..TangoLocation Class See Also Send Feedback
The Tango asset component name

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string AssetComponent { get; set; }
Visual Basic
Public Property AssetComponent As String
    Get
    Set

Property Value

Type: String

See Also

IConditionEntryEvent..::..TangoLocation Class
IConditionEntryEvent..::..TangoLocation Members


IConditionEntryEvent.TangoLocation.Function Property

[image]

Concert Web Services Library
IConditionEntryEvent..::..TangoLocation..::..Function Property
IConditionEntryEvent..::..TangoLocation Class See Also Send Feedback
The Tango function name

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Function { get; set; }
Visual Basic
Public Property Function As String
    Get
    Set

Property Value

Type: String

See Also

IConditionEntryEvent..::..TangoLocation Class
IConditionEntryEvent..::..TangoLocation Members


IConditionEntryEvent.TangoLocation.HostedDatabaseGUID Property

[image]

Concert Web Services Library
IConditionEntryEvent..::..TangoLocation..::..HostedDatabaseGUID Property
IConditionEntryEvent..::..TangoLocation Class See Also Send Feedback
The database GUID for the

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid HostedDatabaseGUID { get; set; }
Visual Basic
Public Property HostedDatabaseGUID As Guid
    Get
    Set

Property Value

Type: Guid

See Also

IConditionEntryEvent..::..TangoLocation Class
IConditionEntryEvent..::..TangoLocation Members


IConditionEntryEvent.TangoLocation.Plant Property

[image]

Concert Web Services Library
IConditionEntryEvent..::..TangoLocation..::..Plant Property
IConditionEntryEvent..::..TangoLocation Class See Also Send Feedback
The Tango plant name

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Plant { get; set; }
Visual Basic
Public Property Plant As String
    Get
    Set

Property Value

Type: String

See Also

IConditionEntryEvent..::..TangoLocation Class
IConditionEntryEvent..::..TangoLocation Members


IConditionEntryEvent.TangoLocation.Unit Property

[image]

Concert Web Services Library
IConditionEntryEvent..::..TangoLocation..::..Unit Property
IConditionEntryEvent..::..TangoLocation Class See Also Send Feedback
The Tango unit name

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Unit { get; set; }
Visual Basic
Public Property Unit As String
    Get
    Set

Property Value

Type: String

See Also

IConditionEntryEvent..::..TangoLocation Class
IConditionEntryEvent..::..TangoLocation Members


ITangoEquipmentEvent Class

[image]

Concert Web Services Library
ITangoEquipmentEvent Class
Members See Also Send Feedback
A service interface definition. It is expected that partner companies will implement this interface to receive events about equipment

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ITangoEquipmentEvent : WebService
Visual Basic
Public Class ITangoEquipmentEvent
    Inherits WebService

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..MarshalByValueComponent
System.Web.Services..::..WebService
Concert..::..ITangoEquipmentEvent

See Also

ITangoEquipmentEvent Members


ITangoEquipmentEvent Members

[image] [image]

Concert Web Services Library
ITangoEquipmentEvent Members
ITangoEquipmentEvent Class Constructors Methods See Also Send Feedback

The ITangoEquipmentEvent type exposes the following members.

Constructors

 | Name | Description
Public method | ITangoEquipmentEvent | Initializes a new instance of the ITangoEquipmentEvent class

Methods

 | Name | Description
Public method | EquipmentDefinitionChangeNotice | This method is called when a new piece of Tango equipment is added to the database or a change is noted. Because the credentials are passed, we recommend that you require and HTTPS connection when being called. Partner NOTE: Not all changes may be reported: Currently, this is only intended to indicate user changes, not changes that might occur at the database level or due to application logic. Please contact 24/7 Systems to determine which user actions will trigger this call. 24/7 NOTE: ExternalInterfaceSubscription.ExternalInterfaceSubscriptionTangoObjectTypeName = 'EquipmentDefinitionChangeNotice', ExternalInterfaceSubscription.ExternalInterfaceSubscriptionEventName = ChangeNoticeType name (ie AddedByUser, ChangedByUser, etc)

See Also

ITangoEquipmentEvent Class


ITangoEquipmentEvent Constructor

[image]

Concert Web Services Library
ITangoEquipmentEvent Constructor
ITangoEquipmentEvent Class See Also Send Feedback
Initializes a new instance of the ITangoEquipmentEvent class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ITangoEquipmentEvent()
Visual Basic
Public Sub New

See Also

ITangoEquipmentEvent Class
ITangoEquipmentEvent Members


ITangoEquipmentEvent Methods

[image] [image]

Concert Web Services Library
ITangoEquipmentEvent Methods
ITangoEquipmentEvent Class See Also Send Feedback

The ITangoEquipmentEvent type exposes the following members.

Methods

 | Name | Description
Public method | EquipmentDefinitionChangeNotice | This method is called when a new piece of Tango equipment is added to the database or a change is noted. Because the credentials are passed, we recommend that you require and HTTPS connection when being called. Partner NOTE: Not all changes may be reported: Currently, this is only intended to indicate user changes, not changes that might occur at the database level or due to application logic. Please contact 24/7 Systems to determine which user actions will trigger this call. 24/7 NOTE: ExternalInterfaceSubscription.ExternalInterfaceSubscriptionTangoObjectTypeName = 'EquipmentDefinitionChangeNotice', ExternalInterfaceSubscription.ExternalInterfaceSubscriptionEventName = ChangeNoticeType name (ie AddedByUser, ChangedByUser, etc)

See Also

ITangoEquipmentEvent Class


ITangoEquipmentEvent.EquipmentDefinitionChangeNotice Method

[image]

Concert Web Services Library
ITangoEquipmentEvent..::..EquipmentDefinitionChangeNotice Method
ITangoEquipmentEvent Class See Also Send Feedback
This method is called when a new piece of Tango equipment is added to the database or a change is noted. Because the credentials are passed, we recommend that you require and HTTPS connection when being called. Partner NOTE: Not all changes may be reported: Currently, this is only intended to indicate user changes, not changes that might occur at the database level or due to application logic. Please contact 24/7 Systems to determine which user actions will trigger this call. 24/7 NOTE: ExternalInterfaceSubscription.ExternalInterfaceSubscriptionTangoObjectTypeName = 'EquipmentDefinitionChangeNotice', ExternalInterfaceSubscription.ExternalInterfaceSubscriptionEventName = ChangeNoticeType name (ie AddedByUser, ChangedByUser, etc)

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void EquipmentDefinitionChangeNotice(
    PartnerSystemSecurity partnerSecurityInfo,
    Guid equipmentGuid,
    EquipmentInfo equipmentInfo,
    ITangoEquipmentEvent..::..ChangeNoticeType noticeType
)
Visual Basic
Public Sub EquipmentDefinitionChangeNotice (
    partnerSecurityInfo As PartnerSystemSecurity,
    equipmentGuid As Guid,
    equipmentInfo As EquipmentInfo,
    noticeType As ITangoEquipmentEvent..::..ChangeNoticeType
)

Parameters

partnerSecurityInfo
Type: Concert..::..PartnerSystemSecurity
Security info used to ensure the caller has rights
equipmentGuid
Type: System..::..Guid
The unique Tango ID for the piece of equipment being changed
equipmentInfo
Type: EquipmentInfo
The equipment information being passed to the partner system
noticeType
Type: Concert..::..ITangoEquipmentEvent..::..ChangeNoticeType
The type of change which occured in Tango

See Also

ITangoEquipmentEvent Class
ITangoEquipmentEvent Members


ITangoEquipmentEvent.ChangeNoticeType Enumeration

[image]

Concert Web Services Library
ITangoEquipmentEvent..::..ChangeNoticeType Enumeration
ITangoEquipmentEvent Class See Also Send Feedback
Indicates why this call is being made. This way partner systems have a context for the call. It is possible that in some cases a partner system might behave differently based on the notice type.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum ChangeNoticeType
Visual Basic
Public Enumeration ChangeNoticeType

Members

Member name | Value | Description
AddedByUser | 0 | The equipment definition was added by a user
ChangedByUser | 1 | The equipment definition was changed by a user

See Also

Concert Namespace


OilDataSubmission Class

[image]

Concert Web Services Library
OilDataSubmission Class
Members See Also Send Feedback
The OilDataSubmission service provides 3rd party oil labs to submit information to Oilography via a set of web services. There is also a set of optional oil lab partner services the lab can expose to allow Oilography to perform advanced integration. Access from http://www.tf7.com/Concert/OilDataSubmission.asmx

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class OilDataSubmission : ConcertWebServiceBase
Visual Basic
Public Class OilDataSubmission
    Inherits ConcertWebServiceBase

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..MarshalByValueComponent
System.Web.Services..::..WebService
ConcertWebServiceBase
Concert..::..OilDataSubmission

See Also

OilDataSubmission Members


OilDataSubmission Members

[image] [image]

Concert Web Services Library
OilDataSubmission Members
OilDataSubmission Class Methods See Also Send Feedback

The OilDataSubmission type exposes the following members.

Methods

 | Name | Description
Public method | AddOilDataSetComments | Add a comment to an oil data set. Also allows you to indicate where a linked document exists that can be referenced from the oil report. Limitation note (Nov 27, 2013): All comments added this way are assumed to have come from the oil lab. Linked documents will only be added for new comments. (ie. no editing). If a comment text and type are the same as an existing comment, the comment and the linked documents will be ignored.
Public method | FetchCommentTypeList | An oil data set can be submitted with a set of comments. This lists the known types. This list can be added to by contacting 24/7 Systems.
Public method | FetchLinkedDocumentTypeList | An oil data set comment can have an associated linked document such as a photograph. It is often useful to know what sort of linked document is available to provide special context sensitive support. This method lists the known document type names. This list can be added to by contacting 24/7 Systems.
Public method | FetchOilDataSetStatusList | Fetch a list of known OilDataSetStatus values for the speified OilLabGUID. Used mainly when forming data to be passed to SubmitOilTestData. Oil data set status values are used to indicate how bad a sample is. This list can be added to by contacting 24/7 Systems.
Public method | FetchOilTestList | Lists all know test types. Also indicates if the test value is numeric, what units are associated, and which group and sub-group is will be presented with in the Oilography oil report. Used mainly when forming data to be passed to SubmitOilTestData. This list can be added to by contacting 24/7 Systems.
Public method | FetchOilValueLabStatusList | Lists the status options for a test value within a data set being submitted for the specified lab. Provides information on the display and usage of each option. This list can be added to by contacting 24/7 Systems.
Public method | SendSampleDataToPartnerService | Send or re-send the sample data to a partner service. This is useful in cases where it is unclear if all the information was available or if a seperate system needs access to sample data.
Public method | SubmitOilSamplePoints | Allows the lab to submit sample point locations to Oilography. Most labs make this call directly before submitting test data. This can lead to the lab and plant falling out of synch until the next call to the SubmitOilSamplePoints method for a point. A more streamlined approach is to make this call when changes are made in the lab system or a point is added. This ensures the lab and plant are always up to date. A response is provided to indicate how many points were added and how many were updated. We recommend you check the result. Please see TF7OilSamplePointSubmission.xsd.
Public method | SubmitOilTestData | Allows the lab to submit oil data. A response is provided to indicate if there were any reasons that the data was not acceptable. We recommend you check the result. PLEASE NOTE: Oilography does not allow two samples for the same sample point to have the exact same sample timestamp. The timestamp must be at least a second different and the timestamp percision is down to 1/1000 of a millisecond. Please contact TF7OilSubmission.xsd.
Public method | SwapOilDataSetLocation | Frequently sample bottles or labels are swapped in the field by accident. This allow the lab to swap two samples. If you prefer to avoid writing code, there is a simple user interface available at: https:\\www.tf7.com\Concert\Oilography\SwapOilDataSetsEditor.aspx
Public method | UpdateTF7SampleCodeWithLabSampleCode | If a sample arrives at the lab and still has the random 24/7 Systems sample ID. Internally, all Oilography samples start with a sample code in a TF7-nnnnnn format. If you would like to modify it in Oilography, this method give you the opportunity to do so.

See Also

OilDataSubmission Class


OilDataSubmission Methods

[image] [image]

Concert Web Services Library
OilDataSubmission Methods
OilDataSubmission Class See Also Send Feedback

The OilDataSubmission type exposes the following members.

Methods

 | Name | Description
Public method | AddOilDataSetComments | Add a comment to an oil data set. Also allows you to indicate where a linked document exists that can be referenced from the oil report. Limitation note (Nov 27, 2013): All comments added this way are assumed to have come from the oil lab. Linked documents will only be added for new comments. (ie. no editing). If a comment text and type are the same as an existing comment, the comment and the linked documents will be ignored.
Public method | FetchCommentTypeList | An oil data set can be submitted with a set of comments. This lists the known types. This list can be added to by contacting 24/7 Systems.
Public method | FetchLinkedDocumentTypeList | An oil data set comment can have an associated linked document such as a photograph. It is often useful to know what sort of linked document is available to provide special context sensitive support. This method lists the known document type names. This list can be added to by contacting 24/7 Systems.
Public method | FetchOilDataSetStatusList | Fetch a list of known OilDataSetStatus values for the speified OilLabGUID. Used mainly when forming data to be passed to SubmitOilTestData. Oil data set status values are used to indicate how bad a sample is. This list can be added to by contacting 24/7 Systems.
Public method | FetchOilTestList | Lists all know test types. Also indicates if the test value is numeric, what units are associated, and which group and sub-group is will be presented with in the Oilography oil report. Used mainly when forming data to be passed to SubmitOilTestData. This list can be added to by contacting 24/7 Systems.
Public method | FetchOilValueLabStatusList | Lists the status options for a test value within a data set being submitted for the specified lab. Provides information on the display and usage of each option. This list can be added to by contacting 24/7 Systems.
Public method | SendSampleDataToPartnerService | Send or re-send the sample data to a partner service. This is useful in cases where it is unclear if all the information was available or if a seperate system needs access to sample data.
Public method | SubmitOilSamplePoints | Allows the lab to submit sample point locations to Oilography. Most labs make this call directly before submitting test data. This can lead to the lab and plant falling out of synch until the next call to the SubmitOilSamplePoints method for a point. A more streamlined approach is to make this call when changes are made in the lab system or a point is added. This ensures the lab and plant are always up to date. A response is provided to indicate how many points were added and how many were updated. We recommend you check the result. Please see TF7OilSamplePointSubmission.xsd.
Public method | SubmitOilTestData | Allows the lab to submit oil data. A response is provided to indicate if there were any reasons that the data was not acceptable. We recommend you check the result. PLEASE NOTE: Oilography does not allow two samples for the same sample point to have the exact same sample timestamp. The timestamp must be at least a second different and the timestamp percision is down to 1/1000 of a millisecond. Please contact TF7OilSubmission.xsd.
Public method | SwapOilDataSetLocation | Frequently sample bottles or labels are swapped in the field by accident. This allow the lab to swap two samples. If you prefer to avoid writing code, there is a simple user interface available at: https:\\www.tf7.com\Concert\Oilography\SwapOilDataSetsEditor.aspx
Public method | UpdateTF7SampleCodeWithLabSampleCode | If a sample arrives at the lab and still has the random 24/7 Systems sample ID. Internally, all Oilography samples start with a sample code in a TF7-nnnnnn format. If you would like to modify it in Oilography, this method give you the opportunity to do so.

See Also

OilDataSubmission Class


OilDataSubmission.AddOilDataSetComments Method

[image]

Concert Web Services Library
OilDataSubmission..::..AddOilDataSetComments Method
OilDataSubmission Class See Also Send Feedback
Add a comment to an oil data set. Also allows you to indicate where a linked document exists that can be referenced from the oil report. Limitation note (Nov 27, 2013): All comments added this way are assumed to have come from the oil lab. Linked documents will only be added for new comments. (ie. no editing). If a comment text and type are the same as an existing comment, the comment and the linked documents will be ignored.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public OilDataSubmission..::..AddOilDataSetCommentsResponse[] AddOilDataSetComments(
    string OilLabGUID,
    string UserName,
    string Password,
    OilDataSubmission..::..DataSetComment[] Comments
)
Visual Basic
Public Function AddOilDataSetComments (
    OilLabGUID As String,
    UserName As String,
    Password As String,
    Comments As OilDataSubmission..::..DataSetComment()
) As OilDataSubmission..::..AddOilDataSetCommentsResponse()

Parameters

OilLabGUID
Type: System..::..String
The GUID associated with the lab submitting the data. Do not share your lab GUID with customers.
UserName
Type: System..::..String
User name attributed to the comment
Password
Type: System..::..String
Password of the user attributed to the comment
Comments
Type: array< Concert..::..OilDataSubmission..::..DataSetComment >[]()[][]
One or more comment objects. Check the response to see if each comment object is handled or not.

Return Value

Type: array< OilDataSubmission..::..AddOilDataSetCommentsResponse >[]()[][]
A list of responses -- one item for each item in teh Comments object.

See Also

OilDataSubmission Class
OilDataSubmission Members


OilDataSubmission.FetchCommentTypeList Method

[image]

Concert Web Services Library
OilDataSubmission..::..FetchCommentTypeList Method
OilDataSubmission Class See Also Send Feedback
An oil data set can be submitted with a set of comments. This lists the known types. This list can be added to by contacting 24/7 Systems.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string[] FetchCommentTypeList()
Visual Basic
Public Function FetchCommentTypeList As String()

Return Value

Type: array< String >[]()[][]

See Also

OilDataSubmission Class
OilDataSubmission Members


OilDataSubmission.FetchLinkedDocumentTypeList Method

[image]

Concert Web Services Library
OilDataSubmission..::..FetchLinkedDocumentTypeList Method
OilDataSubmission Class See Also Send Feedback
An oil data set comment can have an associated linked document such as a photograph. It is often useful to know what sort of linked document is available to provide special context sensitive support. This method lists the known document type names. This list can be added to by contacting 24/7 Systems.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string[] FetchLinkedDocumentTypeList()
Visual Basic
Public Function FetchLinkedDocumentTypeList As String()

Return Value

Type: array< String >[]()[][]

See Also

OilDataSubmission Class
OilDataSubmission Members


OilDataSubmission.FetchOilDataSetStatusList Method

[image]

Concert Web Services Library
OilDataSubmission..::..FetchOilDataSetStatusList Method
OilDataSubmission Class See Also Send Feedback
Fetch a list of known OilDataSetStatus values for the speified OilLabGUID. Used mainly when forming data to be passed to SubmitOilTestData. Oil data set status values are used to indicate how bad a sample is. This list can be added to by contacting 24/7 Systems.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public OilDataSubmission..::..OilDataSetStatus[] FetchOilDataSetStatusList(
    string OilLabGUID
)
Visual Basic
Public Function FetchOilDataSetStatusList (
    OilLabGUID As String
) As OilDataSubmission..::..OilDataSetStatus()

Parameters

OilLabGUID
Type: System..::..String
The GUID associated with the lab submitting the data. Do not share your lab GUID with customers.

Return Value

Type: array< OilDataSubmission..::..OilDataSetStatus >[]()[][]

See Also

OilDataSubmission Class
OilDataSubmission Members


OilDataSubmission.FetchOilTestList Method

[image]

Concert Web Services Library
OilDataSubmission..::..FetchOilTestList Method
OilDataSubmission Class See Also Send Feedback
Lists all know test types. Also indicates if the test value is numeric, what units are associated, and which group and sub-group is will be presented with in the Oilography oil report. Used mainly when forming data to be passed to SubmitOilTestData. This list can be added to by contacting 24/7 Systems.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public OilDataSubmission..::..OilTest[] FetchOilTestList()
Visual Basic
Public Function FetchOilTestList As OilDataSubmission..::..OilTest()

Return Value

Type: array< OilDataSubmission..::..OilTest >[]()[][]

See Also

OilDataSubmission Class
OilDataSubmission Members


OilDataSubmission.FetchOilValueLabStatusList Method

[image]

Concert Web Services Library
OilDataSubmission..::..FetchOilValueLabStatusList Method
OilDataSubmission Class See Also Send Feedback
Lists the status options for a test value within a data set being submitted for the specified lab. Provides information on the display and usage of each option. This list can be added to by contacting 24/7 Systems.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public OilDataSubmission..::..OilValueLabStatus[] FetchOilValueLabStatusList(
    string OilLabGUID
)
Visual Basic
Public Function FetchOilValueLabStatusList (
    OilLabGUID As String
) As OilDataSubmission..::..OilValueLabStatus()

Parameters

OilLabGUID
Type: System..::..String
The GUID associated with the lab submitting the data. Do not share your lab GUID with customers.

Return Value

Type: array< OilDataSubmission..::..OilValueLabStatus >[]()[][]

See Also

OilDataSubmission Class
OilDataSubmission Members


OilDataSubmission.SendSampleDataToPartnerService Method

[image]

Concert Web Services Library
OilDataSubmission..::..SendSampleDataToPartnerService Method
OilDataSubmission Class See Also Send Feedback
Send or re-send the sample data to a partner service. This is useful in cases where it is unclear if all the information was available or if a seperate system needs access to sample data.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SendSampleDataToPartnerService(
    string OilLabGUID,
    string LabSampleCode
)
Visual Basic
Public Sub SendSampleDataToPartnerService (
    OilLabGUID As String,
    LabSampleCode As String
)

Parameters

OilLabGUID
Type: System..::..String
The GUID associated with the lab submitting the data. Do not share your lab GUID with customers.
LabSampleCode
Type: System..::..String
The lab sample code or TF7-nnnnnn code for the sample.

See Also

OilDataSubmission Class
OilDataSubmission Members


OilDataSubmission.SubmitOilSamplePoints Method

[image]

Concert Web Services Library
OilDataSubmission..::..SubmitOilSamplePoints Method
OilDataSubmission Class See Also Send Feedback
Allows the lab to submit sample point locations to Oilography. Most labs make this call directly before submitting test data. This can lead to the lab and plant falling out of synch until the next call to the SubmitOilSamplePoints method for a point. A more streamlined approach is to make this call when changes are made in the lab system or a point is added. This ensures the lab and plant are always up to date. A response is provided to indicate how many points were added and how many were updated. We recommend you check the result. Please see TF7OilSamplePointSubmission.xsd.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public XmlNode SubmitOilSamplePoints(
    string OilLabGUID,
    XmlNode SamplePointXML
)
Visual Basic
Public Function SubmitOilSamplePoints (
    OilLabGUID As String,
    SamplePointXML As XmlNode
) As XmlNode

Parameters

OilLabGUID
Type: System..::..String
The GUID associated with the lab submitting the data. Do not share your lab GUID with customers.
SamplePointXML
Type: System.Xml..::..XmlNode
The XML for a submission per TF7OilSamplePointSubmission.xsd.

Return Value

Type: XmlNode
An XML response indicating if there was success or failure

See Also

OilDataSubmission Class
OilDataSubmission Members


OilDataSubmission.SubmitOilTestData Method

[image]

Concert Web Services Library
OilDataSubmission..::..SubmitOilTestData Method
OilDataSubmission Class See Also Send Feedback
Allows the lab to submit oil data. A response is provided to indicate if there were any reasons that the data was not acceptable. We recommend you check the result. PLEASE NOTE: Oilography does not allow two samples for the same sample point to have the exact same sample timestamp. The timestamp must be at least a second different and the timestamp percision is down to 1/1000 of a millisecond. Please contact TF7OilSubmission.xsd.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public XmlNode SubmitOilTestData(
    string OilLabGUID,
    string UniqueSubmissionCode,
    XmlNode OilDataXML
)
Visual Basic
Public Function SubmitOilTestData (
    OilLabGUID As String,
    UniqueSubmissionCode As String,
    OilDataXML As XmlNode
) As XmlNode

Parameters

OilLabGUID
Type: System..::..String
The GUID associated with the lab submitting the data. Do not share your lab GUID with customers.
UniqueSubmissionCode
Type: System..::..String
A unique value for diagnostic purposes different submissions can be noted.
OilDataXML
Type: System.Xml..::..XmlNode
The XML for a submission per TF7OilSubmission.xsd.

Return Value

Type: XmlNode
An XML response indicating if there was success or failure

See Also

OilDataSubmission Class
OilDataSubmission Members


OilDataSubmission.SwapOilDataSetLocation Method

[image]

Concert Web Services Library
OilDataSubmission..::..SwapOilDataSetLocation Method
OilDataSubmission Class See Also Send Feedback
Frequently sample bottles or labels are swapped in the field by accident. This allow the lab to swap two samples. If you prefer to avoid writing code, there is a simple user interface available at: https:\\www.tf7.com\Concert\Oilography\SwapOilDataSetsEditor.aspx

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SwapOilDataSetLocation(
    string OilLabGUID,
    string UserName,
    string Password,
    string LabSampleCode1,
    string LabSampleCode2
)
Visual Basic
Public Sub SwapOilDataSetLocation (
    OilLabGUID As String,
    UserName As String,
    Password As String,
    LabSampleCode1 As String,
    LabSampleCode2 As String
)

Parameters

OilLabGUID
Type: System..::..String
The GUID associated with the lab submitting the data. Do not share your lab GUID with customers.
UserName
Type: System..::..String
User name attributed to the swap
Password
Type: System..::..String
Password of the user attributed to the swap
LabSampleCode1
Type: System..::..String
The lab sample code for the first bottle.
LabSampleCode2
Type: System..::..String
The lab sample code for the second bottle.

See Also

OilDataSubmission Class
OilDataSubmission Members


OilDataSubmission.UpdateTF7SampleCodeWithLabSampleCode Method

[image]

Concert Web Services Library
OilDataSubmission..::..UpdateTF7SampleCodeWithLabSampleCode Method
OilDataSubmission Class See Also Send Feedback
If a sample arrives at the lab and still has the random 24/7 Systems sample ID. Internally, all Oilography samples start with a sample code in a TF7-nnnnnn format. If you would like to modify it in Oilography, this method give you the opportunity to do so.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void UpdateTF7SampleCodeWithLabSampleCode(
    string OilLabGUID,
    string TF7SampleCode,
    string LabSampleCode
)
Visual Basic
Public Sub UpdateTF7SampleCodeWithLabSampleCode (
    OilLabGUID As String,
    TF7SampleCode As String,
    LabSampleCode As String
)

Parameters

OilLabGUID
Type: System..::..String
The GUID associated with the lab submitting the data. Do not share your lab GUID with customers.
TF7SampleCode
Type: System..::..String
The TF7-nnnnnn value you want to change.
LabSampleCode
Type: System..::..String
The value you want the TF7-nnnnnn value changed to.

See Also

OilDataSubmission Class
OilDataSubmission Members


OilDataSubmission.AddOilDataSetCommentsResponse Class

[image]

Concert Web Services Library
OilDataSubmission..::..AddOilDataSetCommentsResponse Class
OilDataSubmission Class Members See Also Send Feedback
Response associated with an attempt to add an oil dataset comment

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class AddOilDataSetCommentsResponse
Visual Basic
Public Class AddOilDataSetCommentsResponse

Inheritance Hierarchy

System..::..Object
Concert..::..OilDataSubmission..::..AddOilDataSetCommentsResponse

See Also

OilDataSubmission..::..AddOilDataSetCommentsResponse Members


OilDataSubmission.AddOilDataSetCommentsResponse Members

[image] [image]

Concert Web Services Library
OilDataSubmission..::..AddOilDataSetCommentsResponse Members
OilDataSubmission..::..AddOilDataSetCommentsResponse Class Fields See Also Send Feedback

The OilDataSubmission..::..AddOilDataSetCommentsResponse type exposes the following members.

Fields

 | Name | Description
Public field | AddedComment | Was the comment added
Public field | ReasonNotAdded | If not added, why?
Public field | UniqueCommentSubmissionID | The unique ID for the submission item

See Also

OilDataSubmission..::..AddOilDataSetCommentsResponse Class


OilDataSubmission.AddOilDataSetCommentsResponse Fields

[image] [image]

Concert Web Services Library
OilDataSubmission..::..AddOilDataSetCommentsResponse Fields
OilDataSubmission..::..AddOilDataSetCommentsResponse Class See Also Send Feedback

The OilDataSubmission..::..AddOilDataSetCommentsResponse type exposes the following members.

Fields

 | Name | Description
Public field | AddedComment | Was the comment added
Public field | ReasonNotAdded | If not added, why?
Public field | UniqueCommentSubmissionID | The unique ID for the submission item

See Also

OilDataSubmission..::..AddOilDataSetCommentsResponse Class


OilDataSubmission.AddOilDataSetCommentsResponse.AddedComment Field

[image]

Concert Web Services Library
OilDataSubmission..::..AddOilDataSetCommentsResponse..::..AddedComment Field
OilDataSubmission..::..AddOilDataSetCommentsResponse Class See Also Send Feedback
Was the comment added

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AddedComment
Visual Basic
Public AddedComment As Boolean

Field Value

Type: Boolean

See Also

OilDataSubmission..::..AddOilDataSetCommentsResponse Class
OilDataSubmission..::..AddOilDataSetCommentsResponse Members


OilDataSubmission.AddOilDataSetCommentsResponse.ReasonNotAdded Field

[image]

Concert Web Services Library
OilDataSubmission..::..AddOilDataSetCommentsResponse..::..ReasonNotAdded Field
OilDataSubmission..::..AddOilDataSetCommentsResponse Class See Also Send Feedback
If not added, why?

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ReasonNotAdded
Visual Basic
Public ReasonNotAdded As String

Field Value

Type: String

See Also

OilDataSubmission..::..AddOilDataSetCommentsResponse Class
OilDataSubmission..::..AddOilDataSetCommentsResponse Members


OilDataSubmission.AddOilDataSetCommentsResponse.UniqueCommentSubmissionID Field

[image]

Concert Web Services Library
OilDataSubmission..::..AddOilDataSetCommentsResponse..::..UniqueCommentSubmissionID Field
OilDataSubmission..::..AddOilDataSetCommentsResponse Class See Also Send Feedback
The unique ID for the submission item

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string UniqueCommentSubmissionID
Visual Basic
Public UniqueCommentSubmissionID As String

Field Value

Type: String

See Also

OilDataSubmission..::..AddOilDataSetCommentsResponse Class
OilDataSubmission..::..AddOilDataSetCommentsResponse Members


OilDataSubmission.DataSetComment Class

[image]

Concert Web Services Library
OilDataSubmission..::..DataSetComment Class
OilDataSubmission Class Members See Also Send Feedback
The information used ot add/edit a comment.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DataSetComment
Visual Basic
Public Class DataSetComment

Inheritance Hierarchy

System..::..Object
Concert..::..OilDataSubmission..::..DataSetComment

See Also

OilDataSubmission..::..DataSetComment Members


OilDataSubmission.DataSetComment Members

[image] [image]

Concert Web Services Library
OilDataSubmission..::..DataSetComment Members
OilDataSubmission..::..DataSetComment Class Fields See Also Send Feedback

The OilDataSubmission..::..DataSetComment type exposes the following members.

Fields

 | Name | Description
Public field | CommentText | The comment text.
Public field | CommentTypeName | The name of the type of comment (see FetchCommentTypeList for options)
Public field | DisplayOrder | (Optional) What order to display this comment relative to the other comments. 1 is shown before 2.
Public field | LabSampleCode | Identifies which oil data set the comment is associated with.
Public field | LinkedDocuments | A list of zero or more external linked documents. Is linked via a URL to the document.
Public field | ProvideVerboseErrors | (Optional) Instead of terse errors, you can request verbose errors to understand why a submittion was rejected.
Public field | UniqueCommentSubmissionID | A unique id for each item being submitted -- allows you to relate this item to the response item returned for each comment submitted

See Also

OilDataSubmission..::..DataSetComment Class


OilDataSubmission.DataSetComment Fields

[image] [image]

Concert Web Services Library
OilDataSubmission..::..DataSetComment Fields
OilDataSubmission..::..DataSetComment Class See Also Send Feedback

The OilDataSubmission..::..DataSetComment type exposes the following members.

Fields

 | Name | Description
Public field | CommentText | The comment text.
Public field | CommentTypeName | The name of the type of comment (see FetchCommentTypeList for options)
Public field | DisplayOrder | (Optional) What order to display this comment relative to the other comments. 1 is shown before 2.
Public field | LabSampleCode | Identifies which oil data set the comment is associated with.
Public field | LinkedDocuments | A list of zero or more external linked documents. Is linked via a URL to the document.
Public field | ProvideVerboseErrors | (Optional) Instead of terse errors, you can request verbose errors to understand why a submittion was rejected.
Public field | UniqueCommentSubmissionID | A unique id for each item being submitted -- allows you to relate this item to the response item returned for each comment submitted

See Also

OilDataSubmission..::..DataSetComment Class


OilDataSubmission.DataSetComment.CommentText Field

[image]

Concert Web Services Library
OilDataSubmission..::..DataSetComment..::..CommentText Field
OilDataSubmission..::..DataSetComment Class See Also Send Feedback
The comment text.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string CommentText
Visual Basic
Public CommentText As String

Field Value

Type: String

See Also

OilDataSubmission..::..DataSetComment Class
OilDataSubmission..::..DataSetComment Members


OilDataSubmission.DataSetComment.CommentTypeName Field

[image]

Concert Web Services Library
OilDataSubmission..::..DataSetComment..::..CommentTypeName Field
OilDataSubmission..::..DataSetComment Class See Also Send Feedback
The name of the type of comment (see FetchCommentTypeList for options)

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string CommentTypeName
Visual Basic
Public CommentTypeName As String

Field Value

Type: String

See Also

OilDataSubmission..::..DataSetComment Class
OilDataSubmission..::..DataSetComment Members


OilDataSubmission.DataSetComment.DisplayOrder Field

[image]

Concert Web Services Library
OilDataSubmission..::..DataSetComment..::..DisplayOrder Field
OilDataSubmission..::..DataSetComment Class See Also Send Feedback
(Optional) What order to display this comment relative to the other comments. 1 is shown before 2.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<int> DisplayOrder
Visual Basic
Public DisplayOrder As Nullable(Of Integer)

Field Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

OilDataSubmission..::..DataSetComment Class
OilDataSubmission..::..DataSetComment Members


OilDataSubmission.DataSetComment.LabSampleCode Field

[image]

Concert Web Services Library
OilDataSubmission..::..DataSetComment..::..LabSampleCode Field
OilDataSubmission..::..DataSetComment Class See Also Send Feedback
Identifies which oil data set the comment is associated with.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string LabSampleCode
Visual Basic
Public LabSampleCode As String

Field Value

Type: String

See Also

OilDataSubmission..::..DataSetComment Class
OilDataSubmission..::..DataSetComment Members


OilDataSubmission.DataSetComment.LinkedDocuments Field

[image]

Concert Web Services Library
OilDataSubmission..::..DataSetComment..::..LinkedDocuments Field
OilDataSubmission..::..DataSetComment Class See Also Send Feedback
A list of zero or more external linked documents. Is linked via a URL to the document.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public OilDataSubmission..::..ExternalLinkedDocument[] LinkedDocuments
Visual Basic
Public LinkedDocuments As OilDataSubmission..::..ExternalLinkedDocument()

Field Value

Type: array< OilDataSubmission..::..ExternalLinkedDocument >[]()[][]

See Also

OilDataSubmission..::..DataSetComment Class
OilDataSubmission..::..DataSetComment Members


OilDataSubmission.DataSetComment.ProvideVerboseErrors Field

[image]

Concert Web Services Library
OilDataSubmission..::..DataSetComment..::..ProvideVerboseErrors Field
OilDataSubmission..::..DataSetComment Class See Also Send Feedback
(Optional) Instead of terse errors, you can request verbose errors to understand why a submittion was rejected.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ProvideVerboseErrors
Visual Basic
Public ProvideVerboseErrors As Boolean

Field Value

Type: Boolean

See Also

OilDataSubmission..::..DataSetComment Class
OilDataSubmission..::..DataSetComment Members


OilDataSubmission.DataSetComment.UniqueCommentSubmissionID Field

[image]

Concert Web Services Library
OilDataSubmission..::..DataSetComment..::..UniqueCommentSubmissionID Field
OilDataSubmission..::..DataSetComment Class See Also Send Feedback
A unique id for each item being submitted -- allows you to relate this item to the response item returned for each comment submitted

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string UniqueCommentSubmissionID
Visual Basic
Public UniqueCommentSubmissionID As String

Field Value

Type: String

See Also

OilDataSubmission..::..DataSetComment Class
OilDataSubmission..::..DataSetComment Members


OilDataSubmission.ExternalLinkedDocument Class

[image]

Concert Web Services Library
OilDataSubmission..::..ExternalLinkedDocument Class
OilDataSubmission Class Members See Also Send Feedback
Information about an external linked document (ie. external photo, external report, etc).

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ExternalLinkedDocument
Visual Basic
Public Class ExternalLinkedDocument

Inheritance Hierarchy

System..::..Object
Concert..::..OilDataSubmission..::..ExternalLinkedDocument

See Also

OilDataSubmission..::..ExternalLinkedDocument Members


OilDataSubmission.ExternalLinkedDocument Members

[image] [image]

Concert Web Services Library
OilDataSubmission..::..ExternalLinkedDocument Members
OilDataSubmission..::..ExternalLinkedDocument Class Fields See Also Send Feedback

The OilDataSubmission..::..ExternalLinkedDocument type exposes the following members.

Fields

 | Name | Description
Public field | LinkedDocumentDescription | A comment to go with the document. Example: "Left Side Picture", "Right Side Picture".
Public field | LinkedDocumentTypeName | See FetchLinkedDocumentTypeList for options
Public field | URL | The URL to the external document

See Also

OilDataSubmission..::..ExternalLinkedDocument Class


OilDataSubmission.ExternalLinkedDocument Fields

[image] [image]

Concert Web Services Library
OilDataSubmission..::..ExternalLinkedDocument Fields
OilDataSubmission..::..ExternalLinkedDocument Class See Also Send Feedback

The OilDataSubmission..::..ExternalLinkedDocument type exposes the following members.

Fields

 | Name | Description
Public field | LinkedDocumentDescription | A comment to go with the document. Example: "Left Side Picture", "Right Side Picture".
Public field | LinkedDocumentTypeName | See FetchLinkedDocumentTypeList for options
Public field | URL | The URL to the external document

See Also

OilDataSubmission..::..ExternalLinkedDocument Class


OilDataSubmission.ExternalLinkedDocument.LinkedDocumentDescription Field

[image]

Concert Web Services Library
OilDataSubmission..::..ExternalLinkedDocument..::..LinkedDocumentDescription Field
OilDataSubmission..::..ExternalLinkedDocument Class See Also Send Feedback
A comment to go with the document. Example: "Left Side Picture", "Right Side Picture".

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string LinkedDocumentDescription
Visual Basic
Public LinkedDocumentDescription As String

Field Value

Type: String

See Also

OilDataSubmission..::..ExternalLinkedDocument Class
OilDataSubmission..::..ExternalLinkedDocument Members


OilDataSubmission.ExternalLinkedDocument.LinkedDocumentTypeName Field

[image]

Concert Web Services Library
OilDataSubmission..::..ExternalLinkedDocument..::..LinkedDocumentTypeName Field
OilDataSubmission..::..ExternalLinkedDocument Class See Also Send Feedback
See FetchLinkedDocumentTypeList for options

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string LinkedDocumentTypeName
Visual Basic
Public LinkedDocumentTypeName As String

Field Value

Type: String

See Also

OilDataSubmission..::..ExternalLinkedDocument Class
OilDataSubmission..::..ExternalLinkedDocument Members


OilDataSubmission.ExternalLinkedDocument.URL Field

[image]

Concert Web Services Library
OilDataSubmission..::..ExternalLinkedDocument..::..URL Field
OilDataSubmission..::..ExternalLinkedDocument Class See Also Send Feedback
The URL to the external document

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string URL
Visual Basic
Public URL As String

Field Value

Type: String

See Also

OilDataSubmission..::..ExternalLinkedDocument Class
OilDataSubmission..::..ExternalLinkedDocument Members


OilDataSubmission.OilDataSetStatus Class

[image]

Concert Web Services Library
OilDataSubmission..::..OilDataSetStatus Class
OilDataSubmission Class Members See Also Send Feedback
The status of the oil data set

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class OilDataSetStatus
Visual Basic
Public Class OilDataSetStatus

Inheritance Hierarchy

System..::..Object
Concert..::..OilDataSubmission..::..OilDataSetStatus

See Also

OilDataSubmission..::..OilDataSetStatus Members


OilDataSubmission.OilDataSetStatus Members

[image] [image]

Concert Web Services Library
OilDataSubmission..::..OilDataSetStatus Members
OilDataSubmission..::..OilDataSetStatus Class Properties See Also Send Feedback

The OilDataSubmission..::..OilDataSetStatus type exposes the following members.

Properties

 | Name | Description
Public property | ID | The internal Oilography idenfitifer for this status
Public property | IsLabSpecfic | Is this status option specified to the lab or general to Oilography
Public property | OilDataSetStatusColor | The color used to represent the status
Public property | OilDataSetStatusName | The name of the data set status
Public property | OilDataSetStatusSeverityIndex | Severity of the status (0 is best, 100 is worst)
Public property | PromptForTechnologyConditionEntry | Does this status cause the analyst to fill out a condition entry
Public property | RequireReview | When submitted to Oilography, does this status force the analyst to review the data set

See Also

OilDataSubmission..::..OilDataSetStatus Class


OilDataSubmission.OilDataSetStatus Properties

[image] [image]

Concert Web Services Library
OilDataSubmission..::..OilDataSetStatus Properties
OilDataSubmission..::..OilDataSetStatus Class See Also Send Feedback

The OilDataSubmission..::..OilDataSetStatus type exposes the following members.

Properties

 | Name | Description
Public property | ID | The internal Oilography idenfitifer for this status
Public property | IsLabSpecfic | Is this status option specified to the lab or general to Oilography
Public property | OilDataSetStatusColor | The color used to represent the status
Public property | OilDataSetStatusName | The name of the data set status
Public property | OilDataSetStatusSeverityIndex | Severity of the status (0 is best, 100 is worst)
Public property | PromptForTechnologyConditionEntry | Does this status cause the analyst to fill out a condition entry
Public property | RequireReview | When submitted to Oilography, does this status force the analyst to review the data set

See Also

OilDataSubmission..::..OilDataSetStatus Class


OilDataSubmission.OilDataSetStatus.ID Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilDataSetStatus..::..ID Property
OilDataSubmission..::..OilDataSetStatus Class See Also Send Feedback
The internal Oilography idenfitifer for this status

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int ID { get; set; }
Visual Basic
Public Property ID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OilDataSubmission..::..OilDataSetStatus Class
OilDataSubmission..::..OilDataSetStatus Members


OilDataSubmission.OilDataSetStatus.IsLabSpecfic Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilDataSetStatus..::..IsLabSpecfic Property
OilDataSubmission..::..OilDataSetStatus Class See Also Send Feedback
Is this status option specified to the lab or general to Oilography

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsLabSpecfic { get; set; }
Visual Basic
Public Property IsLabSpecfic As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

OilDataSubmission..::..OilDataSetStatus Class
OilDataSubmission..::..OilDataSetStatus Members


OilDataSubmission.OilDataSetStatus.OilDataSetStatusColor Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilDataSetStatus..::..OilDataSetStatusColor Property
OilDataSubmission..::..OilDataSetStatus Class See Also Send Feedback
The color used to represent the status

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string OilDataSetStatusColor { get; set; }
Visual Basic
Public Property OilDataSetStatusColor As String
    Get
    Set

Property Value

Type: String

See Also

OilDataSubmission..::..OilDataSetStatus Class
OilDataSubmission..::..OilDataSetStatus Members


OilDataSubmission.OilDataSetStatus.OilDataSetStatusName Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilDataSetStatus..::..OilDataSetStatusName Property
OilDataSubmission..::..OilDataSetStatus Class See Also Send Feedback
The name of the data set status

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string OilDataSetStatusName { get; set; }
Visual Basic
Public Property OilDataSetStatusName As String
    Get
    Set

Property Value

Type: String

See Also

OilDataSubmission..::..OilDataSetStatus Class
OilDataSubmission..::..OilDataSetStatus Members


OilDataSubmission.OilDataSetStatus.OilDataSetStatusSeverityIndex Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilDataSetStatus..::..OilDataSetStatusSeverityIndex Property
OilDataSubmission..::..OilDataSetStatus Class See Also Send Feedback
Severity of the status (0 is best, 100 is worst)

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int OilDataSetStatusSeverityIndex { get; set; }
Visual Basic
Public Property OilDataSetStatusSeverityIndex As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OilDataSubmission..::..OilDataSetStatus Class
OilDataSubmission..::..OilDataSetStatus Members


OilDataSubmission.OilDataSetStatus.PromptForTechnologyConditionEntry Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilDataSetStatus..::..PromptForTechnologyConditionEntry Property
OilDataSubmission..::..OilDataSetStatus Class See Also Send Feedback
Does this status cause the analyst to fill out a condition entry

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool PromptForTechnologyConditionEntry { get; set; }
Visual Basic
Public Property PromptForTechnologyConditionEntry As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

OilDataSubmission..::..OilDataSetStatus Class
OilDataSubmission..::..OilDataSetStatus Members


OilDataSubmission.OilDataSetStatus.RequireReview Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilDataSetStatus..::..RequireReview Property
OilDataSubmission..::..OilDataSetStatus Class See Also Send Feedback
When submitted to Oilography, does this status force the analyst to review the data set

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool RequireReview { get; set; }
Visual Basic
Public Property RequireReview As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

OilDataSubmission..::..OilDataSetStatus Class
OilDataSubmission..::..OilDataSetStatus Members


OilDataSubmission.OilTest Class

[image]

Concert Web Services Library
OilDataSubmission..::..OilTest Class
OilDataSubmission Class Members See Also Send Feedback
Defines a type of oil test

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class OilTest
Visual Basic
Public Class OilTest

Inheritance Hierarchy

System..::..Object
Concert..::..OilDataSubmission..::..OilTest

See Also

OilDataSubmission..::..OilTest Members


OilDataSubmission.OilTest Members

[image] [image]

Concert Web Services Library
OilDataSubmission..::..OilTest Members
OilDataSubmission..::..OilTest Class Properties See Also Send Feedback

The OilDataSubmission..::..OilTest type exposes the following members.

Properties

 | Name | Description
Public property | GroupName | What group does the test belong to?
Public property | ID | Internal Oilography identifier
Public property | IsNumericValue | A is test value numeric
Public property | SubGroupName | What sub-group does the test belong to?
Public property | TestName | The name of the test (ie. Iron, Viscosity @ 40C, Flash Point)
Public property | TestNameAbbreviation | The test name abbreviation
Public property | Units | Measurement units associated with the test (ppm, Deg F, nothing)

See Also

OilDataSubmission..::..OilTest Class


OilDataSubmission.OilTest Properties

[image] [image]

Concert Web Services Library
OilDataSubmission..::..OilTest Properties
OilDataSubmission..::..OilTest Class See Also Send Feedback

The OilDataSubmission..::..OilTest type exposes the following members.

Properties

 | Name | Description
Public property | GroupName | What group does the test belong to?
Public property | ID | Internal Oilography identifier
Public property | IsNumericValue | A is test value numeric
Public property | SubGroupName | What sub-group does the test belong to?
Public property | TestName | The name of the test (ie. Iron, Viscosity @ 40C, Flash Point)
Public property | TestNameAbbreviation | The test name abbreviation
Public property | Units | Measurement units associated with the test (ppm, Deg F, nothing)

See Also

OilDataSubmission..::..OilTest Class


OilDataSubmission.OilTest.GroupName Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilTest..::..GroupName Property
OilDataSubmission..::..OilTest Class See Also Send Feedback
What group does the test belong to?

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string GroupName { get; set; }
Visual Basic
Public Property GroupName As String
    Get
    Set

Property Value

Type: String

See Also

OilDataSubmission..::..OilTest Class
OilDataSubmission..::..OilTest Members


OilDataSubmission.OilTest.ID Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilTest..::..ID Property
OilDataSubmission..::..OilTest Class See Also Send Feedback
Internal Oilography identifier

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int ID { get; set; }
Visual Basic
Public Property ID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OilDataSubmission..::..OilTest Class
OilDataSubmission..::..OilTest Members


OilDataSubmission.OilTest.IsNumericValue Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilTest..::..IsNumericValue Property
OilDataSubmission..::..OilTest Class See Also Send Feedback
A is test value numeric

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsNumericValue { get; set; }
Visual Basic
Public Property IsNumericValue As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

OilDataSubmission..::..OilTest Class
OilDataSubmission..::..OilTest Members


OilDataSubmission.OilTest.SubGroupName Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilTest..::..SubGroupName Property
OilDataSubmission..::..OilTest Class See Also Send Feedback
What sub-group does the test belong to?

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string SubGroupName { get; set; }
Visual Basic
Public Property SubGroupName As String
    Get
    Set

Property Value

Type: String

See Also

OilDataSubmission..::..OilTest Class
OilDataSubmission..::..OilTest Members


OilDataSubmission.OilTest.TestName Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilTest..::..TestName Property
OilDataSubmission..::..OilTest Class See Also Send Feedback
The name of the test (ie. Iron, Viscosity @ 40C, Flash Point)

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string TestName { get; set; }
Visual Basic
Public Property TestName As String
    Get
    Set

Property Value

Type: String

See Also

OilDataSubmission..::..OilTest Class
OilDataSubmission..::..OilTest Members


OilDataSubmission.OilTest.TestNameAbbreviation Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilTest..::..TestNameAbbreviation Property
OilDataSubmission..::..OilTest Class See Also Send Feedback
The test name abbreviation

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string TestNameAbbreviation { get; set; }
Visual Basic
Public Property TestNameAbbreviation As String
    Get
    Set

Property Value

Type: String

See Also

OilDataSubmission..::..OilTest Class
OilDataSubmission..::..OilTest Members


OilDataSubmission.OilTest.Units Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilTest..::..Units Property
OilDataSubmission..::..OilTest Class See Also Send Feedback
Measurement units associated with the test (ppm, Deg F, nothing)

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Units { get; set; }
Visual Basic
Public Property Units As String
    Get
    Set

Property Value

Type: String

See Also

OilDataSubmission..::..OilTest Class
OilDataSubmission..::..OilTest Members


OilDataSubmission.OilValueLabStatus Class

[image]

Concert Web Services Library
OilDataSubmission..::..OilValueLabStatus Class
OilDataSubmission Class Members See Also Send Feedback
The status of an oil value based on lab analysis

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class OilValueLabStatus
Visual Basic
Public Class OilValueLabStatus

Inheritance Hierarchy

System..::..Object
Concert..::..OilDataSubmission..::..OilValueLabStatus

See Also

OilDataSubmission..::..OilValueLabStatus Members


OilDataSubmission.OilValueLabStatus Members

[image] [image]

Concert Web Services Library
OilDataSubmission..::..OilValueLabStatus Members
OilDataSubmission..::..OilValueLabStatus Class Properties See Also Send Feedback

The OilDataSubmission..::..OilValueLabStatus type exposes the following members.

Properties

 | Name | Description
Public property | ID | The internal Oilography ID for the status
Public property | IsLabSpecfic | Is this status specific to the lab or general to Oilography?
Public property | OilDataValueLabStatusBackgroundColor | Background color when displayed
Public property | OilDataValueLabStatusForegroundColor | Foreground color when displayed
Public property | OilDataValueLabStatusName | The status name
Public property | OilDataValueLabStatusSeverityIndex | A scale from 0-100 (0 is best, 100 is worst)

See Also

OilDataSubmission..::..OilValueLabStatus Class


OilDataSubmission.OilValueLabStatus Properties

[image] [image]

Concert Web Services Library
OilDataSubmission..::..OilValueLabStatus Properties
OilDataSubmission..::..OilValueLabStatus Class See Also Send Feedback

The OilDataSubmission..::..OilValueLabStatus type exposes the following members.

Properties

 | Name | Description
Public property | ID | The internal Oilography ID for the status
Public property | IsLabSpecfic | Is this status specific to the lab or general to Oilography?
Public property | OilDataValueLabStatusBackgroundColor | Background color when displayed
Public property | OilDataValueLabStatusForegroundColor | Foreground color when displayed
Public property | OilDataValueLabStatusName | The status name
Public property | OilDataValueLabStatusSeverityIndex | A scale from 0-100 (0 is best, 100 is worst)

See Also

OilDataSubmission..::..OilValueLabStatus Class


OilDataSubmission.OilValueLabStatus.ID Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilValueLabStatus..::..ID Property
OilDataSubmission..::..OilValueLabStatus Class See Also Send Feedback
The internal Oilography ID for the status

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int ID { get; set; }
Visual Basic
Public Property ID As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OilDataSubmission..::..OilValueLabStatus Class
OilDataSubmission..::..OilValueLabStatus Members


OilDataSubmission.OilValueLabStatus.IsLabSpecfic Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilValueLabStatus..::..IsLabSpecfic Property
OilDataSubmission..::..OilValueLabStatus Class See Also Send Feedback
Is this status specific to the lab or general to Oilography?

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsLabSpecfic { get; set; }
Visual Basic
Public Property IsLabSpecfic As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

OilDataSubmission..::..OilValueLabStatus Class
OilDataSubmission..::..OilValueLabStatus Members


OilDataSubmission.OilValueLabStatus.OilDataValueLabStatusBackgroundColor Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilValueLabStatus..::..OilDataValueLabStatusBackgroundColor Property
OilDataSubmission..::..OilValueLabStatus Class See Also Send Feedback
Background color when displayed

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string OilDataValueLabStatusBackgroundColor { get; set; }
Visual Basic
Public Property OilDataValueLabStatusBackgroundColor As String
    Get
    Set

Property Value

Type: String

See Also

OilDataSubmission..::..OilValueLabStatus Class
OilDataSubmission..::..OilValueLabStatus Members


OilDataSubmission.OilValueLabStatus.OilDataValueLabStatusForegroundColor Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilValueLabStatus..::..OilDataValueLabStatusForegroundColor Property
OilDataSubmission..::..OilValueLabStatus Class See Also Send Feedback
Foreground color when displayed

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string OilDataValueLabStatusForegroundColor { get; set; }
Visual Basic
Public Property OilDataValueLabStatusForegroundColor As String
    Get
    Set

Property Value

Type: String

See Also

OilDataSubmission..::..OilValueLabStatus Class
OilDataSubmission..::..OilValueLabStatus Members


OilDataSubmission.OilValueLabStatus.OilDataValueLabStatusName Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilValueLabStatus..::..OilDataValueLabStatusName Property
OilDataSubmission..::..OilValueLabStatus Class See Also Send Feedback
The status name

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string OilDataValueLabStatusName { get; set; }
Visual Basic
Public Property OilDataValueLabStatusName As String
    Get
    Set

Property Value

Type: String

See Also

OilDataSubmission..::..OilValueLabStatus Class
OilDataSubmission..::..OilValueLabStatus Members


OilDataSubmission.OilValueLabStatus.OilDataValueLabStatusSeverityIndex Property

[image]

Concert Web Services Library
OilDataSubmission..::..OilValueLabStatus..::..OilDataValueLabStatusSeverityIndex Property
OilDataSubmission..::..OilValueLabStatus Class See Also Send Feedback
A scale from 0-100 (0 is best, 100 is worst)

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int OilDataValueLabStatusSeverityIndex { get; set; }
Visual Basic
Public Property OilDataValueLabStatusSeverityIndex As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OilDataSubmission..::..OilValueLabStatus Class
OilDataSubmission..::..OilValueLabStatus Members


PartnerSystemSecurity Class

[image]

Concert Web Services Library
PartnerSystemSecurity Class
Members See Also Send Feedback
Used to pass security info to a partner system. Implementation is up to the partner -- you can go without if you want, but it is not recommended

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class PartnerSystemSecurity
Visual Basic
Public Class PartnerSystemSecurity

Inheritance Hierarchy

System..::..Object
Concert..::..PartnerSystemSecurity

See Also

PartnerSystemSecurity Members


PartnerSystemSecurity Members

[image] [image]

Concert Web Services Library
PartnerSystemSecurity Members
PartnerSystemSecurity Class Constructors Fields See Also Send Feedback

The PartnerSystemSecurity type exposes the following members.

Constructors

 | Name | Description
Public method | PartnerSystemSecurity | Initializes a new instance of the PartnerSystemSecurity class

Fields

 | Name | Description
Public field | Password | The partner system password
Public field | UserName | The partner system user name

See Also

PartnerSystemSecurity Class


PartnerSystemSecurity Constructor

[image]

Concert Web Services Library
PartnerSystemSecurity Constructor
PartnerSystemSecurity Class See Also Send Feedback
Initializes a new instance of the PartnerSystemSecurity class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PartnerSystemSecurity()
Visual Basic
Public Sub New

See Also

PartnerSystemSecurity Class
PartnerSystemSecurity Members


PartnerSystemSecurity Fields

[image] [image]

Concert Web Services Library
PartnerSystemSecurity Fields
PartnerSystemSecurity Class See Also Send Feedback

The PartnerSystemSecurity type exposes the following members.

Fields

 | Name | Description
Public field | Password | The partner system password
Public field | UserName | The partner system user name

See Also

PartnerSystemSecurity Class


PartnerSystemSecurity.Password Field

[image]

Concert Web Services Library
PartnerSystemSecurity..::..Password Field
PartnerSystemSecurity Class See Also Send Feedback
The partner system password

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Password
Visual Basic
Public Password As String

Field Value

Type: String

See Also

PartnerSystemSecurity Class
PartnerSystemSecurity Members


PartnerSystemSecurity.UserName Field

[image]

Concert Web Services Library
PartnerSystemSecurity..::..UserName Field
PartnerSystemSecurity Class See Also Send Feedback
The partner system user name

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string UserName
Visual Basic
Public UserName As String

Field Value

Type: String

See Also

PartnerSystemSecurity Class
PartnerSystemSecurity Members


TangoEquipment Class

[image]

Concert Web Services Library
TangoEquipment Class
Members See Also Send Feedback
Service methods used to access and control Tango equipment. Access from http://www.tf7.com/Concert/TangoEquipment.asmx

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TangoEquipment : ConcertWebServiceBase
Visual Basic
Public Class TangoEquipment
    Inherits ConcertWebServiceBase

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..MarshalByValueComponent
System.Web.Services..::..WebService
ConcertWebServiceBase
Concert..::..TangoEquipment

See Also

TangoEquipment Members


TangoEquipment Members

[image] [image]

Concert Web Services Library
TangoEquipment Members
TangoEquipment Class Methods See Also Send Feedback

The TangoEquipment type exposes the following members.

Methods

 | Name | Description
Public method | AddEquipment | Add a piece of equipment to the Tango database
Public method | CloseOpenHistoryEntry | Close an open equipment history item/entry
Public method | CurrentEquipmentHistoryItem | Fetch the current equipment history item.
Public method | GetEquipmentInfo | Get general information about a piece of equipment
Public method | GetEquipmentTypePropertyMapping | Provides a list of equipment properties for a given Tango equipment type ID
Public method | GetEquipmentTypes | Get a list of equipment types which can be used to add equipment to the Tango database.
Public method | GetPropertyUnits | Provides access to a list of the currently known Tango equipment property units.
Public method | GetVendorList | Return a list of vendors
Public method | SaveVendor | Add/Update a vendor.
Public method | TransferEquipmentToLocation | Send a piece of equipment to a specified location

See Also

TangoEquipment Class


TangoEquipment Methods

[image] [image]

Concert Web Services Library
TangoEquipment Methods
TangoEquipment Class See Also Send Feedback

The TangoEquipment type exposes the following members.

Methods

 | Name | Description
Public method | AddEquipment | Add a piece of equipment to the Tango database
Public method | CloseOpenHistoryEntry | Close an open equipment history item/entry
Public method | CurrentEquipmentHistoryItem | Fetch the current equipment history item.
Public method | GetEquipmentInfo | Get general information about a piece of equipment
Public method | GetEquipmentTypePropertyMapping | Provides a list of equipment properties for a given Tango equipment type ID
Public method | GetEquipmentTypes | Get a list of equipment types which can be used to add equipment to the Tango database.
Public method | GetPropertyUnits | Provides access to a list of the currently known Tango equipment property units.
Public method | GetVendorList | Return a list of vendors
Public method | SaveVendor | Add/Update a vendor.
Public method | TransferEquipmentToLocation | Send a piece of equipment to a specified location

See Also

TangoEquipment Class


TangoEquipment.AddEquipment Method

[image]

Concert Web Services Library
TangoEquipment..::..AddEquipment Method
TangoEquipment Class See Also Send Feedback
Add a piece of equipment to the Tango database

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid AddEquipment(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser,
    int EquipmentTypeID,
    Nullable<DateTime> WarrantyEndDate,
    TangoEquipment..::..NewPropertyValue[] PropertyValues
)
Visual Basic
Public Function AddEquipment (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser,
    EquipmentTypeID As Integer,
    WarrantyEndDate As Nullable(Of DateTime),
    PropertyValues As TangoEquipment..::..NewPropertyValue()
) As Guid

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information
EquipmentTypeID
Type: System..::..Int32
The Tango equipment type ID for the piece of equipment you wish to add.
WarrantyEndDate
Type: System..::..Nullable <(Of <(<' DateTime >)>)>
Optional. The date the equipment warranty ends.
PropertyValues
Type: array< Concert..::..TangoEquipment..::..NewPropertyValue >[]()[][]
A list of equipment property values. Note -- all required properties must be submitted to create a piece of equipment.

Return Value

Type: Guid
The GUID for the newly added piece of equipment

See Also

TangoEquipment Class
TangoEquipment Members


TangoEquipment.CloseOpenHistoryEntry Method

[image]

Concert Web Services Library
TangoEquipment..::..CloseOpenHistoryEntry Method
TangoEquipment Class See Also Send Feedback
Close an open equipment history item/entry

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoLocation..::..RemovalInfo CloseOpenHistoryEntry(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser,
    Guid EquipmentGuid,
    DateTime CloseDateTime,
    string RemovalWorkOrderNumber,
    string RemovalRemarks,
    Nullable<float> RemovalEquipmentMeterReading
)
Visual Basic
Public Function CloseOpenHistoryEntry (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser,
    EquipmentGuid As Guid,
    CloseDateTime As DateTime,
    RemovalWorkOrderNumber As String,
    RemovalRemarks As String,
    RemovalEquipmentMeterReading As Nullable(Of Single)
) As TangoLocation..::..RemovalInfo

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information
EquipmentGuid
Type: System..::..Guid
The Tango GUID for the piece of equipment we are closing the history entry for.
CloseDateTime
Type: System..::..DateTime
The date that this history entry is to be concluded.
RemovalWorkOrderNumber
Type: System..::..String
Conditional: If this equipment is installed, the work order associated with the removal.
RemovalRemarks
Type: System..::..String
Conditional: If this equipment is installed, the comments associated with the removal.
RemovalEquipmentMeterReading
Type: System..::..Nullable <(Of <(<' Single >)>)>
Optional: If this equipment is installed, the meter reading at the time of the removal.

Return Value

Type: TangoLocation..::..RemovalInfo

See Also

TangoEquipment Class
TangoEquipment Members


TangoEquipment.CurrentEquipmentHistoryItem Method

[image]

Concert Web Services Library
TangoEquipment..::..CurrentEquipmentHistoryItem Method
TangoEquipment Class See Also Send Feedback
Fetch the current equipment history item.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoEquipment..::..EquipmentHistoryItem CurrentEquipmentHistoryItem(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser,
    Guid EquipmentGuid
)
Visual Basic
Public Function CurrentEquipmentHistoryItem (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser,
    EquipmentGuid As Guid
) As TangoEquipment..::..EquipmentHistoryItem

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information
EquipmentGuid
Type: System..::..Guid
The Tango GUID for the piece of equipment we are getting the information for.

Return Value

Type: TangoEquipment..::..EquipmentHistoryItem
If there is an open history entry an history item is returned. If the equipment has never had a history entry nothing is returned.

See Also

TangoEquipment Class
TangoEquipment Members


TangoEquipment.GetEquipmentInfo Method

[image]

Concert Web Services Library
TangoEquipment..::..GetEquipmentInfo Method
TangoEquipment Class See Also Send Feedback
Get general information about a piece of equipment

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public EquipmentInfo GetEquipmentInfo(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser,
    Guid EquipmentGuid
)
Visual Basic
Public Function GetEquipmentInfo (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser,
    EquipmentGuid As Guid
) As EquipmentInfo

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information
EquipmentGuid
Type: System..::..Guid
The Tango GUID for the piece of equipment we are getting the information for.

Return Value

Type: EquipmentInfo

See Also

TangoEquipment Class
TangoEquipment Members


TangoEquipment.GetEquipmentTypePropertyMapping Method

[image]

Concert Web Services Library
TangoEquipment..::..GetEquipmentTypePropertyMapping Method
TangoEquipment Class See Also Send Feedback
Provides a list of equipment properties for a given Tango equipment type ID

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoEquipment..::..PropertyMapping[] GetEquipmentTypePropertyMapping(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser,
    int EquipmentTypeID
)
Visual Basic
Public Function GetEquipmentTypePropertyMapping (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser,
    EquipmentTypeID As Integer
) As TangoEquipment..::..PropertyMapping()

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information
EquipmentTypeID
Type: System..::..Int32
The Tango equipment type ID you would like to fetch the properties for.

Return Value

Type: array< TangoEquipment..::..PropertyMapping >[]()[][]

See Also

TangoEquipment Class
TangoEquipment Members


TangoEquipment.GetEquipmentTypes Method

[image]

Concert Web Services Library
TangoEquipment..::..GetEquipmentTypes Method
TangoEquipment Class See Also Send Feedback
Get a list of equipment types which can be used to add equipment to the Tango database.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoEquipment..::..EquipmentTypeInfo[] GetEquipmentTypes(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser
)
Visual Basic
Public Function GetEquipmentTypes (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser
) As TangoEquipment..::..EquipmentTypeInfo()

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information

Return Value

Type: array< TangoEquipment..::..EquipmentTypeInfo >[]()[][]

See Also

TangoEquipment Class
TangoEquipment Members


TangoEquipment.GetPropertyUnits Method

[image]

Concert Web Services Library
TangoEquipment..::..GetPropertyUnits Method
TangoEquipment Class See Also Send Feedback
Provides access to a list of the currently known Tango equipment property units.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PropertyUnitInfo[] GetPropertyUnits(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser
)
Visual Basic
Public Function GetPropertyUnits (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser
) As PropertyUnitInfo()

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information

Return Value

Type: array<PropertyUnitInfo>[]()[][]

See Also

TangoEquipment Class
TangoEquipment Members


TangoEquipment.GetVendorList Method

[image]

Concert Web Services Library
TangoEquipment..::..GetVendorList Method
TangoEquipment Class See Also Send Feedback
Return a list of vendors

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoEquipment..::..VendorItem[] GetVendorList(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser
)
Visual Basic
Public Function GetVendorList (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser
) As TangoEquipment..::..VendorItem()

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information

Return Value

Type: array< TangoEquipment..::..VendorItem >[]()[][]

See Also

TangoEquipment Class
TangoEquipment Members


TangoEquipment.SaveVendor Method

[image]

Concert Web Services Library
TangoEquipment..::..SaveVendor Method
TangoEquipment Class See Also Send Feedback
Add/Update a vendor.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int SaveVendor(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser,
    TangoEquipment..::..VendorItem Vendor
)
Visual Basic
Public Function SaveVendor (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser,
    Vendor As TangoEquipment..::..VendorItem
) As Integer

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information
Vendor
Type: Concert..::..TangoEquipment..::..VendorItem
A vendor object of type VendorItem.

Return Value

Type: Int32

See Also

TangoEquipment Class
TangoEquipment Members


TangoEquipment.TransferEquipmentToLocation Method

[image]

Concert Web Services Library
TangoEquipment..::..TransferEquipmentToLocation Method
TangoEquipment Class See Also Send Feedback
Send a piece of equipment to a specified location

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoEquipment..::..InstallationInfo TransferEquipmentToLocation(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser,
    Guid EquipmentGuid,
    TangoLocation..::..LocationOrAliasUnion Destination,
    DateTime InstallDate,
    string InstallRemarks,
    string InstallationWorkOrder,
    Nullable<float> InstallEquipmentMeterReading,
    Nullable<bool> IsMockInstallDate,
    Nullable<DateTime> WarrantyEndDate,
    Nullable<bool> AddTempAssetCompIfAssetMatchFoundAndComponentDoesNot
)
Visual Basic
Public Function TransferEquipmentToLocation (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser,
    EquipmentGuid As Guid,
    Destination As TangoLocation..::..LocationOrAliasUnion,
    InstallDate As DateTime,
    InstallRemarks As String,
    InstallationWorkOrder As String,
    InstallEquipmentMeterReading As Nullable(Of Single),
    IsMockInstallDate As Nullable(Of Boolean),
    WarrantyEndDate As Nullable(Of DateTime),
    AddTempAssetCompIfAssetMatchFoundAndComponentDoesNot As Nullable(Of Boolean)
) As TangoEquipment..::..InstallationInfo

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information
EquipmentGuid
Type: System..::..Guid
The Tango GUID for the piece of equipment we are sending to a location.
Destination
Type: Concert..::..TangoLocation..::..LocationOrAliasUnion
A destination object which indicates where the item is being installed to.
InstallDate
Type: System..::..DateTime
The date the equipment was installed.
InstallRemarks
Type: System..::..String
Optional: Any comments about the installation.
InstallationWorkOrder
Type: System..::..String
Optional: Any work order number associated with the installation
InstallEquipmentMeterReading
Type: System..::..Nullable <(Of <(<' Single >)>)>
Optional: The meter reading the time of installation.
IsMockInstallDate
Type: System..::..Nullable <(Of <(<' Boolean >)>)>
Is this a 'mock' install date -- a mock install date indicates that we don't know the actual install date but this is our best guess.
WarrantyEndDate
Type: System..::..Nullable <(Of <(<' DateTime >)>)>
Optional: any warranty end date for this installation.
AddTempAssetCompIfAssetMatchFoundAndComponentDoesNot
Type: System..::..Nullable <(Of <(<' Boolean >)>)>
If the location we're being asked to install the piece of equipment to is an asset component location, this flag indicates that we want an asset component location added under it.

Return Value

Type: TangoEquipment..::..InstallationInfo

See Also

TangoEquipment Class
TangoEquipment Members


TangoEquipment.EquipmentHistoryItem Class

[image]

Concert Web Services Library
TangoEquipment..::..EquipmentHistoryItem Class
TangoEquipment Class Members See Also Send Feedback
Tango Equipment history item

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class EquipmentHistoryItem
Visual Basic
Public Class EquipmentHistoryItem

Inheritance Hierarchy

System..::..Object
Concert..::..TangoEquipment..::..EquipmentHistoryItem

See Also

TangoEquipment..::..EquipmentHistoryItem Members


TangoEquipment.EquipmentHistoryItem Members

[image] [image]

Concert Web Services Library
TangoEquipment..::..EquipmentHistoryItem Members
TangoEquipment..::..EquipmentHistoryItem Class Fields See Also Send Feedback

The TangoEquipment..::..EquipmentHistoryItem type exposes the following members.

Fields

 | Name | Description
Public field | DueDate | Optional: The date the history item is due to be finished if available.
Public field | LocationID | Conditional: If the equipment is installed, the ID of the location is it instaled at.
Public field | LocationTypeID | Conditional: If the equipment is installed, what type of location is it instaled at.
Public field | PurchaseOrderNumber | Optional: The purchase order number for this hitory entry
Public field | ShopTrackingNumber | Optional: The repair shop tracking number for this hitory entry.
Public field | StartDate | When did this history entry start
Public field | State | The equipment state
Public field | VendorName | Conditional: The vendor for this history entry (used for purchases and repairs)
Public field | WorkOrderNumber | Optional: The work order number associated with this history entry

See Also

TangoEquipment..::..EquipmentHistoryItem Class


TangoEquipment.EquipmentHistoryItem Fields

[image] [image]

Concert Web Services Library
TangoEquipment..::..EquipmentHistoryItem Fields
TangoEquipment..::..EquipmentHistoryItem Class See Also Send Feedback

The TangoEquipment..::..EquipmentHistoryItem type exposes the following members.

Fields

 | Name | Description
Public field | DueDate | Optional: The date the history item is due to be finished if available.
Public field | LocationID | Conditional: If the equipment is installed, the ID of the location is it instaled at.
Public field | LocationTypeID | Conditional: If the equipment is installed, what type of location is it instaled at.
Public field | PurchaseOrderNumber | Optional: The purchase order number for this hitory entry
Public field | ShopTrackingNumber | Optional: The repair shop tracking number for this hitory entry.
Public field | StartDate | When did this history entry start
Public field | State | The equipment state
Public field | VendorName | Conditional: The vendor for this history entry (used for purchases and repairs)
Public field | WorkOrderNumber | Optional: The work order number associated with this history entry

See Also

TangoEquipment..::..EquipmentHistoryItem Class


TangoEquipment.EquipmentHistoryItem.DueDate Field

[image]

Concert Web Services Library
TangoEquipment..::..EquipmentHistoryItem..::..DueDate Field
TangoEquipment..::..EquipmentHistoryItem Class See Also Send Feedback
Optional: The date the history item is due to be finished if available.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<DateTime> DueDate
Visual Basic
Public DueDate As Nullable(Of DateTime)

Field Value

Type: Nullable <(Of <(<' DateTime >)>)>

See Also

TangoEquipment..::..EquipmentHistoryItem Class
TangoEquipment..::..EquipmentHistoryItem Members


TangoEquipment.EquipmentHistoryItem.LocationID Field

[image]

Concert Web Services Library
TangoEquipment..::..EquipmentHistoryItem..::..LocationID Field
TangoEquipment..::..EquipmentHistoryItem Class See Also Send Feedback
Conditional: If the equipment is installed, the ID of the location is it instaled at.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<int> LocationID
Visual Basic
Public LocationID As Nullable(Of Integer)

Field Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

TangoEquipment..::..EquipmentHistoryItem Class
TangoEquipment..::..EquipmentHistoryItem Members


TangoEquipment.EquipmentHistoryItem.LocationTypeID Field

[image]

Concert Web Services Library
TangoEquipment..::..EquipmentHistoryItem..::..LocationTypeID Field
TangoEquipment..::..EquipmentHistoryItem Class See Also Send Feedback
Conditional: If the equipment is installed, what type of location is it instaled at.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<int> LocationTypeID
Visual Basic
Public LocationTypeID As Nullable(Of Integer)

Field Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

TangoEquipment..::..EquipmentHistoryItem Class
TangoEquipment..::..EquipmentHistoryItem Members


TangoEquipment.EquipmentHistoryItem.PurchaseOrderNumber Field

[image]

Concert Web Services Library
TangoEquipment..::..EquipmentHistoryItem..::..PurchaseOrderNumber Field
TangoEquipment..::..EquipmentHistoryItem Class See Also Send Feedback
Optional: The purchase order number for this hitory entry

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string PurchaseOrderNumber
Visual Basic
Public PurchaseOrderNumber As String

Field Value

Type: String

See Also

TangoEquipment..::..EquipmentHistoryItem Class
TangoEquipment..::..EquipmentHistoryItem Members


TangoEquipment.EquipmentHistoryItem.ShopTrackingNumber Field

[image]

Concert Web Services Library
TangoEquipment..::..EquipmentHistoryItem..::..ShopTrackingNumber Field
TangoEquipment..::..EquipmentHistoryItem Class See Also Send Feedback
Optional: The repair shop tracking number for this hitory entry.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ShopTrackingNumber
Visual Basic
Public ShopTrackingNumber As String

Field Value

Type: String

See Also

TangoEquipment..::..EquipmentHistoryItem Class
TangoEquipment..::..EquipmentHistoryItem Members


TangoEquipment.EquipmentHistoryItem.StartDate Field

[image]

Concert Web Services Library
TangoEquipment..::..EquipmentHistoryItem..::..StartDate Field
TangoEquipment..::..EquipmentHistoryItem Class See Also Send Feedback
When did this history entry start

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<DateTime> StartDate
Visual Basic
Public StartDate As Nullable(Of DateTime)

Field Value

Type: Nullable <(Of <(<' DateTime >)>)>

See Also

TangoEquipment..::..EquipmentHistoryItem Class
TangoEquipment..::..EquipmentHistoryItem Members


TangoEquipment.EquipmentHistoryItem.State Field

[image]

Concert Web Services Library
TangoEquipment..::..EquipmentHistoryItem..::..State Field
TangoEquipment..::..EquipmentHistoryItem Class See Also Send Feedback
The equipment state

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public EquipmentStateTypes State
Visual Basic
Public State As EquipmentStateTypes

Field Value

Type: EquipmentStateTypes

See Also

TangoEquipment..::..EquipmentHistoryItem Class
TangoEquipment..::..EquipmentHistoryItem Members


TangoEquipment.EquipmentHistoryItem.VendorName Field

[image]

Concert Web Services Library
TangoEquipment..::..EquipmentHistoryItem..::..VendorName Field
TangoEquipment..::..EquipmentHistoryItem Class See Also Send Feedback
Conditional: The vendor for this history entry (used for purchases and repairs)

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string VendorName
Visual Basic
Public VendorName As String

Field Value

Type: String

See Also

TangoEquipment..::..EquipmentHistoryItem Class
TangoEquipment..::..EquipmentHistoryItem Members


TangoEquipment.EquipmentHistoryItem.WorkOrderNumber Field

[image]

Concert Web Services Library
TangoEquipment..::..EquipmentHistoryItem..::..WorkOrderNumber Field
TangoEquipment..::..EquipmentHistoryItem Class See Also Send Feedback
Optional: The work order number associated with this history entry

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string WorkOrderNumber
Visual Basic
Public WorkOrderNumber As String

Field Value

Type: String

See Also

TangoEquipment..::..EquipmentHistoryItem Class
TangoEquipment..::..EquipmentHistoryItem Members


TangoEquipment.EquipmentTypeInfo Class

[image]

Concert Web Services Library
TangoEquipment..::..EquipmentTypeInfo Class
TangoEquipment Class Members See Also Send Feedback
A Tango equipment type

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class EquipmentTypeInfo
Visual Basic
Public Class EquipmentTypeInfo

Inheritance Hierarchy

System..::..Object
Concert..::..TangoEquipment..::..EquipmentTypeInfo

See Also

TangoEquipment..::..EquipmentTypeInfo Members


TangoEquipment.EquipmentTypeInfo Members

[image] [image]

Concert Web Services Library
TangoEquipment..::..EquipmentTypeInfo Members
TangoEquipment..::..EquipmentTypeInfo Class Fields See Also Send Feedback

The TangoEquipment..::..EquipmentTypeInfo type exposes the following members.

Fields

 | Name | Description
Public field | CountOfEquipmentDefinitions | How many pieces of equpiment are there for this type
Public field | EquipmentClassName | The class that this equipment type belongs to. Example: Motors
Public field | EquipmentTypeID | Internal Tango equipment type ID
Public field | EquipmentTypeName | The name of the equpiment type. Example: AC Induction Motor

See Also

TangoEquipment..::..EquipmentTypeInfo Class


TangoEquipment.EquipmentTypeInfo Fields

[image] [image]

Concert Web Services Library
TangoEquipment..::..EquipmentTypeInfo Fields
TangoEquipment..::..EquipmentTypeInfo Class See Also Send Feedback

The TangoEquipment..::..EquipmentTypeInfo type exposes the following members.

Fields

 | Name | Description
Public field | CountOfEquipmentDefinitions | How many pieces of equpiment are there for this type
Public field | EquipmentClassName | The class that this equipment type belongs to. Example: Motors
Public field | EquipmentTypeID | Internal Tango equipment type ID
Public field | EquipmentTypeName | The name of the equpiment type. Example: AC Induction Motor

See Also

TangoEquipment..::..EquipmentTypeInfo Class


TangoEquipment.EquipmentTypeInfo.CountOfEquipmentDefinitions Field

[image]

Concert Web Services Library
TangoEquipment..::..EquipmentTypeInfo..::..CountOfEquipmentDefinitions Field
TangoEquipment..::..EquipmentTypeInfo Class See Also Send Feedback
How many pieces of equpiment are there for this type

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int CountOfEquipmentDefinitions
Visual Basic
Public CountOfEquipmentDefinitions As Integer

Field Value

Type: Int32

See Also

TangoEquipment..::..EquipmentTypeInfo Class
TangoEquipment..::..EquipmentTypeInfo Members


TangoEquipment.EquipmentTypeInfo.EquipmentClassName Field

[image]

Concert Web Services Library
TangoEquipment..::..EquipmentTypeInfo..::..EquipmentClassName Field
TangoEquipment..::..EquipmentTypeInfo Class See Also Send Feedback
The class that this equipment type belongs to. Example: Motors

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string EquipmentClassName
Visual Basic
Public EquipmentClassName As String

Field Value

Type: String

See Also

TangoEquipment..::..EquipmentTypeInfo Class
TangoEquipment..::..EquipmentTypeInfo Members


TangoEquipment.EquipmentTypeInfo.EquipmentTypeID Field

[image]

Concert Web Services Library
TangoEquipment..::..EquipmentTypeInfo..::..EquipmentTypeID Field
TangoEquipment..::..EquipmentTypeInfo Class See Also Send Feedback
Internal Tango equipment type ID

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int EquipmentTypeID
Visual Basic
Public EquipmentTypeID As Integer

Field Value

Type: Int32

See Also

TangoEquipment..::..EquipmentTypeInfo Class
TangoEquipment..::..EquipmentTypeInfo Members


TangoEquipment.EquipmentTypeInfo.EquipmentTypeName Field

[image]

Concert Web Services Library
TangoEquipment..::..EquipmentTypeInfo..::..EquipmentTypeName Field
TangoEquipment..::..EquipmentTypeInfo Class See Also Send Feedback
The name of the equpiment type. Example: AC Induction Motor

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string EquipmentTypeName
Visual Basic
Public EquipmentTypeName As String

Field Value

Type: String

See Also

TangoEquipment..::..EquipmentTypeInfo Class
TangoEquipment..::..EquipmentTypeInfo Members


TangoEquipment.InstallationInfo Class

[image]

Concert Web Services Library
TangoEquipment..::..InstallationInfo Class
TangoEquipment Class Members See Also Send Feedback
The information that indicates where the equipment was installed to.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class InstallationInfo
Visual Basic
Public Class InstallationInfo

Inheritance Hierarchy

System..::..Object
Concert..::..TangoEquipment..::..InstallationInfo

See Also

TangoEquipment..::..InstallationInfo Members


TangoEquipment.InstallationInfo Members

[image] [image]

Concert Web Services Library
TangoEquipment..::..InstallationInfo Members
TangoEquipment..::..InstallationInfo Class Fields See Also Send Feedback

The TangoEquipment..::..InstallationInfo type exposes the following members.

Fields

 | Name | Description
Public field | DestinationLocationID | The Tango location ID
Public field | DestinationLocationTypeID | The Tango location type ID
Public field | IsInPlantInstallationAsset | Indicates if the equipment was installed to an 'in plant' location rather than a location such as a stores location.

See Also

TangoEquipment..::..InstallationInfo Class


TangoEquipment.InstallationInfo Fields

[image] [image]

Concert Web Services Library
TangoEquipment..::..InstallationInfo Fields
TangoEquipment..::..InstallationInfo Class See Also Send Feedback

The TangoEquipment..::..InstallationInfo type exposes the following members.

Fields

 | Name | Description
Public field | DestinationLocationID | The Tango location ID
Public field | DestinationLocationTypeID | The Tango location type ID
Public field | IsInPlantInstallationAsset | Indicates if the equipment was installed to an 'in plant' location rather than a location such as a stores location.

See Also

TangoEquipment..::..InstallationInfo Class


TangoEquipment.InstallationInfo.DestinationLocationID Field

[image]

Concert Web Services Library
TangoEquipment..::..InstallationInfo..::..DestinationLocationID Field
TangoEquipment..::..InstallationInfo Class See Also Send Feedback
The Tango location ID

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int DestinationLocationID
Visual Basic
Public DestinationLocationID As Integer

Field Value

Type: Int32

See Also

TangoEquipment..::..InstallationInfo Class
TangoEquipment..::..InstallationInfo Members


TangoEquipment.InstallationInfo.DestinationLocationTypeID Field

[image]

Concert Web Services Library
TangoEquipment..::..InstallationInfo..::..DestinationLocationTypeID Field
TangoEquipment..::..InstallationInfo Class See Also Send Feedback
The Tango location type ID

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int DestinationLocationTypeID
Visual Basic
Public DestinationLocationTypeID As Integer

Field Value

Type: Int32

See Also

TangoEquipment..::..InstallationInfo Class
TangoEquipment..::..InstallationInfo Members


TangoEquipment.InstallationInfo.IsInPlantInstallationAsset Field

[image]

Concert Web Services Library
TangoEquipment..::..InstallationInfo..::..IsInPlantInstallationAsset Field
TangoEquipment..::..InstallationInfo Class See Also Send Feedback
Indicates if the equipment was installed to an 'in plant' location rather than a location such as a stores location.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsInPlantInstallationAsset
Visual Basic
Public IsInPlantInstallationAsset As Boolean

Field Value

Type: Boolean

See Also

TangoEquipment..::..InstallationInfo Class
TangoEquipment..::..InstallationInfo Members


TangoEquipment.NewPropertyValue Class

[image]

Concert Web Services Library
TangoEquipment..::..NewPropertyValue Class
TangoEquipment Class Members See Also Send Feedback
Data for and equipment property value

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class NewPropertyValue
Visual Basic
Public Class NewPropertyValue

Inheritance Hierarchy

System..::..Object
Concert..::..TangoEquipment..::..NewPropertyValue

See Also

TangoEquipment..::..NewPropertyValue Members


TangoEquipment.NewPropertyValue Members

[image] [image]

Concert Web Services Library
TangoEquipment..::..NewPropertyValue Members
TangoEquipment..::..NewPropertyValue Class Fields Properties See Also Send Feedback

The TangoEquipment..::..NewPropertyValue type exposes the following members.

Fields

 | Name | Description
Public field | PropertyUnitsID | Optional: Only used for properties with units. The units ID for the property value.
Public field | Value | The value for the property

Properties

 | Name | Description
Public property | AddLookupIfMissing | Optional: Only used for lookup proerties. Indicate if you want to add a lookup mapping if the value does not exist in the Tango database.
Public property | EquipmentPropertyIDorName | Either the Tango equipment property ID or the property name
Public property | IsLookupText | Optional: Only used for lookup proerties. A flag to indicate if the value being passed is actually a mapped lookup value. If true you can pass the mapped name. If false you must pass the internal ID.

See Also

TangoEquipment..::..NewPropertyValue Class


TangoEquipment.NewPropertyValue Fields

[image] [image]

Concert Web Services Library
TangoEquipment..::..NewPropertyValue Fields
TangoEquipment..::..NewPropertyValue Class See Also Send Feedback

The TangoEquipment..::..NewPropertyValue type exposes the following members.

Fields

 | Name | Description
Public field | PropertyUnitsID | Optional: Only used for properties with units. The units ID for the property value.
Public field | Value | The value for the property

See Also

TangoEquipment..::..NewPropertyValue Class


TangoEquipment.NewPropertyValue.PropertyUnitsID Field

[image]

Concert Web Services Library
TangoEquipment..::..NewPropertyValue..::..PropertyUnitsID Field
TangoEquipment..::..NewPropertyValue Class See Also Send Feedback
Optional: Only used for properties with units. The units ID for the property value.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<int> PropertyUnitsID
Visual Basic
Public PropertyUnitsID As Nullable(Of Integer)

Field Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

TangoEquipment..::..NewPropertyValue Class
TangoEquipment..::..NewPropertyValue Members


TangoEquipment.NewPropertyValue.Value Field

[image]

Concert Web Services Library
TangoEquipment..::..NewPropertyValue..::..Value Field
TangoEquipment..::..NewPropertyValue Class See Also Send Feedback
The value for the property

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Value
Visual Basic
Public Value As String

Field Value

Type: String

See Also

TangoEquipment..::..NewPropertyValue Class
TangoEquipment..::..NewPropertyValue Members


TangoEquipment.NewPropertyValue Properties

[image] [image]

Concert Web Services Library
TangoEquipment..::..NewPropertyValue Properties
TangoEquipment..::..NewPropertyValue Class See Also Send Feedback

The TangoEquipment..::..NewPropertyValue type exposes the following members.

Properties

 | Name | Description
Public property | AddLookupIfMissing | Optional: Only used for lookup proerties. Indicate if you want to add a lookup mapping if the value does not exist in the Tango database.
Public property | EquipmentPropertyIDorName | Either the Tango equipment property ID or the property name
Public property | IsLookupText | Optional: Only used for lookup proerties. A flag to indicate if the value being passed is actually a mapped lookup value. If true you can pass the mapped name. If false you must pass the internal ID.

See Also

TangoEquipment..::..NewPropertyValue Class


TangoEquipment.NewPropertyValue.AddLookupIfMissing Property

[image]

Concert Web Services Library
TangoEquipment..::..NewPropertyValue..::..AddLookupIfMissing Property
TangoEquipment..::..NewPropertyValue Class See Also Send Feedback
Optional: Only used for lookup proerties. Indicate if you want to add a lookup mapping if the value does not exist in the Tango database.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<bool> AddLookupIfMissing { get; set; }
Visual Basic
Public Property AddLookupIfMissing As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable <(Of <(<' Boolean >)>)>

See Also

TangoEquipment..::..NewPropertyValue Class
TangoEquipment..::..NewPropertyValue Members


TangoEquipment.NewPropertyValue.EquipmentPropertyIDorName Property

[image]

Concert Web Services Library
TangoEquipment..::..NewPropertyValue..::..EquipmentPropertyIDorName Property
TangoEquipment..::..NewPropertyValue Class See Also Send Feedback
Either the Tango equipment property ID or the property name

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string EquipmentPropertyIDorName { get; set; }
Visual Basic
Public Property EquipmentPropertyIDorName As String
    Get
    Set

Property Value

Type: String

See Also

TangoEquipment..::..NewPropertyValue Class
TangoEquipment..::..NewPropertyValue Members


TangoEquipment.NewPropertyValue.IsLookupText Property

[image]

Concert Web Services Library
TangoEquipment..::..NewPropertyValue..::..IsLookupText Property
TangoEquipment..::..NewPropertyValue Class See Also Send Feedback
Optional: Only used for lookup proerties. A flag to indicate if the value being passed is actually a mapped lookup value. If true you can pass the mapped name. If false you must pass the internal ID.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<bool> IsLookupText { get; set; }
Visual Basic
Public Property IsLookupText As Nullable(Of Boolean)
    Get
    Set

Property Value

Type: Nullable <(Of <(<' Boolean >)>)>

See Also

TangoEquipment..::..NewPropertyValue Class
TangoEquipment..::..NewPropertyValue Members


TangoEquipment.PropertyMapping Class

[image]

Concert Web Services Library
TangoEquipment..::..PropertyMapping Class
TangoEquipment Class Members See Also Send Feedback
A mapped property configuration

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class PropertyMapping
Visual Basic
Public Class PropertyMapping

Inheritance Hierarchy

System..::..Object
Concert..::..TangoEquipment..::..PropertyMapping

See Also

TangoEquipment..::..PropertyMapping Members


TangoEquipment.PropertyMapping Members

[image] [image]

Concert Web Services Library
TangoEquipment..::..PropertyMapping Members
TangoEquipment..::..PropertyMapping Class Fields See Also Send Feedback

The TangoEquipment..::..PropertyMapping type exposes the following members.

Fields

 | Name | Description
Public field | DefaultPropertyUnitsID | The default units type ID for the property
Public field | FullValueType | A fuller description of the value type: Simple Real Number, Real Number With Units, Simple Integer Number, Integer / Lookup String, One Line String, Multi Line String
Public field | IsLookup | Is the proprety a 'lookup'. A lookup is stored internally as an integer but is mapped to a string. The Value is the internally stored integer and the UserValueString is the mapped string.
Public field | IsRequiredProperty | Is a proprety value required
Public field | PropertyClass | How is the property classified. Is it a design value (common with all other pieces of equipment like this one or specific to this piece of equipment among all like it): Equipment Design, Equipment Specific
Public field | PropertyTypeID | The Tango equipment property type ID
Public field | PropertyTypeName | The Tango equipment property name
Public field | SimpleValueType | The value type: Real Number, Integer, String
Public field | UnitsDescription | The units decription for the property (ie. inches, RPM, kV)
Public field | UnitTypeDesc | The units type for the property (ie. Length, Speed, Voltage, etc)

See Also

TangoEquipment..::..PropertyMapping Class


TangoEquipment.PropertyMapping Fields

[image] [image]

Concert Web Services Library
TangoEquipment..::..PropertyMapping Fields
TangoEquipment..::..PropertyMapping Class See Also Send Feedback

The TangoEquipment..::..PropertyMapping type exposes the following members.

Fields

 | Name | Description
Public field | DefaultPropertyUnitsID | The default units type ID for the property
Public field | FullValueType | A fuller description of the value type: Simple Real Number, Real Number With Units, Simple Integer Number, Integer / Lookup String, One Line String, Multi Line String
Public field | IsLookup | Is the proprety a 'lookup'. A lookup is stored internally as an integer but is mapped to a string. The Value is the internally stored integer and the UserValueString is the mapped string.
Public field | IsRequiredProperty | Is a proprety value required
Public field | PropertyClass | How is the property classified. Is it a design value (common with all other pieces of equipment like this one or specific to this piece of equipment among all like it): Equipment Design, Equipment Specific
Public field | PropertyTypeID | The Tango equipment property type ID
Public field | PropertyTypeName | The Tango equipment property name
Public field | SimpleValueType | The value type: Real Number, Integer, String
Public field | UnitsDescription | The units decription for the property (ie. inches, RPM, kV)
Public field | UnitTypeDesc | The units type for the property (ie. Length, Speed, Voltage, etc)

See Also

TangoEquipment..::..PropertyMapping Class


TangoEquipment.PropertyMapping.DefaultPropertyUnitsID Field

[image]

Concert Web Services Library
TangoEquipment..::..PropertyMapping..::..DefaultPropertyUnitsID Field
TangoEquipment..::..PropertyMapping Class See Also Send Feedback
The default units type ID for the property

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<int> DefaultPropertyUnitsID
Visual Basic
Public DefaultPropertyUnitsID As Nullable(Of Integer)

Field Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

TangoEquipment..::..PropertyMapping Class
TangoEquipment..::..PropertyMapping Members


TangoEquipment.PropertyMapping.FullValueType Field

[image]

Concert Web Services Library
TangoEquipment..::..PropertyMapping..::..FullValueType Field
TangoEquipment..::..PropertyMapping Class See Also Send Feedback
A fuller description of the value type: Simple Real Number, Real Number With Units, Simple Integer Number, Integer / Lookup String, One Line String, Multi Line String

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string FullValueType
Visual Basic
Public FullValueType As String

Field Value

Type: String

See Also

TangoEquipment..::..PropertyMapping Class
TangoEquipment..::..PropertyMapping Members


TangoEquipment.PropertyMapping.IsLookup Field

[image]

Concert Web Services Library
TangoEquipment..::..PropertyMapping..::..IsLookup Field
TangoEquipment..::..PropertyMapping Class See Also Send Feedback
Is the proprety a 'lookup'. A lookup is stored internally as an integer but is mapped to a string. The Value is the internally stored integer and the UserValueString is the mapped string.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsLookup
Visual Basic
Public IsLookup As Boolean

Field Value

Type: Boolean

See Also

TangoEquipment..::..PropertyMapping Class
TangoEquipment..::..PropertyMapping Members


TangoEquipment.PropertyMapping.IsRequiredProperty Field

[image]

Concert Web Services Library
TangoEquipment..::..PropertyMapping..::..IsRequiredProperty Field
TangoEquipment..::..PropertyMapping Class See Also Send Feedback
Is a proprety value required

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsRequiredProperty
Visual Basic
Public IsRequiredProperty As Boolean

Field Value

Type: Boolean

See Also

TangoEquipment..::..PropertyMapping Class
TangoEquipment..::..PropertyMapping Members


TangoEquipment.PropertyMapping.PropertyClass Field

[image]

Concert Web Services Library
TangoEquipment..::..PropertyMapping..::..PropertyClass Field
TangoEquipment..::..PropertyMapping Class See Also Send Feedback
How is the property classified. Is it a design value (common with all other pieces of equipment like this one or specific to this piece of equipment among all like it): Equipment Design, Equipment Specific

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string PropertyClass
Visual Basic
Public PropertyClass As String

Field Value

Type: String

See Also

TangoEquipment..::..PropertyMapping Class
TangoEquipment..::..PropertyMapping Members


TangoEquipment.PropertyMapping.PropertyTypeID Field

[image]

Concert Web Services Library
TangoEquipment..::..PropertyMapping..::..PropertyTypeID Field
TangoEquipment..::..PropertyMapping Class See Also Send Feedback
The Tango equipment property type ID

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int PropertyTypeID
Visual Basic
Public PropertyTypeID As Integer

Field Value

Type: Int32

See Also

TangoEquipment..::..PropertyMapping Class
TangoEquipment..::..PropertyMapping Members


TangoEquipment.PropertyMapping.PropertyTypeName Field

[image]

Concert Web Services Library
TangoEquipment..::..PropertyMapping..::..PropertyTypeName Field
TangoEquipment..::..PropertyMapping Class See Also Send Feedback
The Tango equipment property name

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string PropertyTypeName
Visual Basic
Public PropertyTypeName As String

Field Value

Type: String

See Also

TangoEquipment..::..PropertyMapping Class
TangoEquipment..::..PropertyMapping Members


TangoEquipment.PropertyMapping.SimpleValueType Field

[image]

Concert Web Services Library
TangoEquipment..::..PropertyMapping..::..SimpleValueType Field
TangoEquipment..::..PropertyMapping Class See Also Send Feedback
The value type: Real Number, Integer, String

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string SimpleValueType
Visual Basic
Public SimpleValueType As String

Field Value

Type: String

See Also

TangoEquipment..::..PropertyMapping Class
TangoEquipment..::..PropertyMapping Members


TangoEquipment.PropertyMapping.UnitsDescription Field

[image]

Concert Web Services Library
TangoEquipment..::..PropertyMapping..::..UnitsDescription Field
TangoEquipment..::..PropertyMapping Class See Also Send Feedback
The units decription for the property (ie. inches, RPM, kV)

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string UnitsDescription
Visual Basic
Public UnitsDescription As String

Field Value

Type: String

See Also

TangoEquipment..::..PropertyMapping Class
TangoEquipment..::..PropertyMapping Members


TangoEquipment.PropertyMapping.UnitTypeDesc Field

[image]

Concert Web Services Library
TangoEquipment..::..PropertyMapping..::..UnitTypeDesc Field
TangoEquipment..::..PropertyMapping Class See Also Send Feedback
The units type for the property (ie. Length, Speed, Voltage, etc)

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string UnitTypeDesc
Visual Basic
Public UnitTypeDesc As String

Field Value

Type: String

See Also

TangoEquipment..::..PropertyMapping Class
TangoEquipment..::..PropertyMapping Members


TangoEquipment.VendorItem Class

[image]

Concert Web Services Library
TangoEquipment..::..VendorItem Class
TangoEquipment Class Members See Also Send Feedback
A vendor

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class VendorItem
Visual Basic
Public Class VendorItem

Inheritance Hierarchy

System..::..Object
Concert..::..TangoEquipment..::..VendorItem

See Also

TangoEquipment..::..VendorItem Members


TangoEquipment.VendorItem Members

[image] [image]

Concert Web Services Library
TangoEquipment..::..VendorItem Members
TangoEquipment..::..VendorItem Class Fields See Also Send Feedback

The TangoEquipment..::..VendorItem type exposes the following members.

Fields

 | Name | Description
Public field | Address | The vendor addres
Public field | City | The vendor city
Public field | Email | The vendor email
Public field | Phone | The vendor phone number
Public field | PostalCode | The vendor postal code
Public field | State | The vendor state / provence
Public field | VendorID | The internal Tango vendor ID
Public field | VendorName | The vendor name

See Also

TangoEquipment..::..VendorItem Class


TangoEquipment.VendorItem Fields

[image] [image]

Concert Web Services Library
TangoEquipment..::..VendorItem Fields
TangoEquipment..::..VendorItem Class See Also Send Feedback

The TangoEquipment..::..VendorItem type exposes the following members.

Fields

 | Name | Description
Public field | Address | The vendor addres
Public field | City | The vendor city
Public field | Email | The vendor email
Public field | Phone | The vendor phone number
Public field | PostalCode | The vendor postal code
Public field | State | The vendor state / provence
Public field | VendorID | The internal Tango vendor ID
Public field | VendorName | The vendor name

See Also

TangoEquipment..::..VendorItem Class


TangoEquipment.VendorItem.Address Field

[image]

Concert Web Services Library
TangoEquipment..::..VendorItem..::..Address Field
TangoEquipment..::..VendorItem Class See Also Send Feedback
The vendor addres

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Address
Visual Basic
Public Address As String

Field Value

Type: String

See Also

TangoEquipment..::..VendorItem Class
TangoEquipment..::..VendorItem Members


TangoEquipment.VendorItem.City Field

[image]

Concert Web Services Library
TangoEquipment..::..VendorItem..::..City Field
TangoEquipment..::..VendorItem Class See Also Send Feedback
The vendor city

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string City
Visual Basic
Public City As String

Field Value

Type: String

See Also

TangoEquipment..::..VendorItem Class
TangoEquipment..::..VendorItem Members


TangoEquipment.VendorItem.Email Field

[image]

Concert Web Services Library
TangoEquipment..::..VendorItem..::..Email Field
TangoEquipment..::..VendorItem Class See Also Send Feedback
The vendor email

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Email
Visual Basic
Public Email As String

Field Value

Type: String

See Also

TangoEquipment..::..VendorItem Class
TangoEquipment..::..VendorItem Members


TangoEquipment.VendorItem.Phone Field

[image]

Concert Web Services Library
TangoEquipment..::..VendorItem..::..Phone Field
TangoEquipment..::..VendorItem Class See Also Send Feedback
The vendor phone number

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Phone
Visual Basic
Public Phone As String

Field Value

Type: String

See Also

TangoEquipment..::..VendorItem Class
TangoEquipment..::..VendorItem Members


TangoEquipment.VendorItem.PostalCode Field

[image]

Concert Web Services Library
TangoEquipment..::..VendorItem..::..PostalCode Field
TangoEquipment..::..VendorItem Class See Also Send Feedback
The vendor postal code

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string PostalCode
Visual Basic
Public PostalCode As String

Field Value

Type: String

See Also

TangoEquipment..::..VendorItem Class
TangoEquipment..::..VendorItem Members


TangoEquipment.VendorItem.State Field

[image]

Concert Web Services Library
TangoEquipment..::..VendorItem..::..State Field
TangoEquipment..::..VendorItem Class See Also Send Feedback
The vendor state / provence

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string State
Visual Basic
Public State As String

Field Value

Type: String

See Also

TangoEquipment..::..VendorItem Class
TangoEquipment..::..VendorItem Members


TangoEquipment.VendorItem.VendorID Field

[image]

Concert Web Services Library
TangoEquipment..::..VendorItem..::..VendorID Field
TangoEquipment..::..VendorItem Class See Also Send Feedback
The internal Tango vendor ID

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<int> VendorID
Visual Basic
Public VendorID As Nullable(Of Integer)

Field Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

TangoEquipment..::..VendorItem Class
TangoEquipment..::..VendorItem Members


TangoEquipment.VendorItem.VendorName Field

[image]

Concert Web Services Library
TangoEquipment..::..VendorItem..::..VendorName Field
TangoEquipment..::..VendorItem Class See Also Send Feedback
The vendor name

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string VendorName
Visual Basic
Public VendorName As String

Field Value

Type: String

See Also

TangoEquipment..::..VendorItem Class
TangoEquipment..::..VendorItem Members


TangoLocation Class

[image]

Concert Web Services Library
TangoLocation Class
Members See Also Send Feedback
Service methods used to access and control Tango locations. Access from http://www.tf7.com/Concert/TangoLocation.asmx

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TangoLocation : ConcertWebServiceBase
Visual Basic
Public Class TangoLocation
    Inherits ConcertWebServiceBase

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..MarshalByValueComponent
System.Web.Services..::..WebService
ConcertWebServiceBase
Concert..::..TangoLocation

See Also

TangoLocation Members


TangoLocation Members

[image] [image]

Concert Web Services Library
TangoLocation Members
TangoLocation Class Methods See Also Send Feedback

The TangoLocation type exposes the following members.

Methods

 | Name | Description
Public method | CloseOpenEquipmentLocationHistoryEntry | Close an open history item for a piece of equipment at the specified location.
Public method | GetActiveAliasMappings | Provides a list of alias types mapped to a location type
Public method | GetAliasLocations | Get all the location for a specified alias/alias type
Public method | GetAttributeTypeDefinintions | Return a list of the attribute type definitions
Public method | GetLocationInfo | Return information about a location
Public method | SaveTangoItemAttribute | Save location attribute values. If there is a problem saving any of the data, nothing is saved. Returns the number of items processed.

See Also

TangoLocation Class


TangoLocation Methods

[image] [image]

Concert Web Services Library
TangoLocation Methods
TangoLocation Class See Also Send Feedback

The TangoLocation type exposes the following members.

Methods

 | Name | Description
Public method | CloseOpenEquipmentLocationHistoryEntry | Close an open history item for a piece of equipment at the specified location.
Public method | GetActiveAliasMappings | Provides a list of alias types mapped to a location type
Public method | GetAliasLocations | Get all the location for a specified alias/alias type
Public method | GetAttributeTypeDefinintions | Return a list of the attribute type definitions
Public method | GetLocationInfo | Return information about a location
Public method | SaveTangoItemAttribute | Save location attribute values. If there is a problem saving any of the data, nothing is saved. Returns the number of items processed.

See Also

TangoLocation Class


TangoLocation.CloseOpenEquipmentLocationHistoryEntry Method

[image]

Concert Web Services Library
TangoLocation..::..CloseOpenEquipmentLocationHistoryEntry Method
TangoLocation Class See Also Send Feedback
Close an open history item for a piece of equipment at the specified location.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoLocation..::..RemovalInfo CloseOpenEquipmentLocationHistoryEntry(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser,
    TangoLocation..::..LocationOrAliasUnion Location,
    DateTime CloseDateTime,
    string RemovalWorkOrderNumber,
    string RemovalRemarks,
    Nullable<float> RemovalEquipmentMeterReading
)
Visual Basic
Public Function CloseOpenEquipmentLocationHistoryEntry (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser,
    Location As TangoLocation..::..LocationOrAliasUnion,
    CloseDateTime As DateTime,
    RemovalWorkOrderNumber As String,
    RemovalRemarks As String,
    RemovalEquipmentMeterReading As Nullable(Of Single)
) As TangoLocation..::..RemovalInfo

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information
Location
Type: Concert..::..TangoLocation..::..LocationOrAliasUnion
The location where the history entry should be closed. Must map to a Asset Component.
CloseDateTime
Type: System..::..DateTime
The date the equipment was removed from the location.
RemovalWorkOrderNumber
Type: System..::..String
Conditional: If this equipment is installed, the work order associated with the removal.
RemovalRemarks
Type: System..::..String
Conditional: If this equipment is installed, the comments associated with the removal.
RemovalEquipmentMeterReading
Type: System..::..Nullable <(Of <(<' Single >)>)>
Optional: If this equipment is installed, the meter reading at the time of the removal.

Return Value

Type: TangoLocation..::..RemovalInfo

See Also

TangoLocation Class
TangoLocation Members


TangoLocation.GetActiveAliasMappings Method

[image]

Concert Web Services Library
TangoLocation..::..GetActiveAliasMappings Method
TangoLocation Class See Also Send Feedback
Provides a list of alias types mapped to a location type

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoLocation..::..AliasMapping[] GetActiveAliasMappings(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser,
    Nullable<int> FilterLocationTypeID
)
Visual Basic
Public Function GetActiveAliasMappings (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser,
    FilterLocationTypeID As Nullable(Of Integer)
) As TangoLocation..::..AliasMapping()

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information
FilterLocationTypeID
Type: System..::..Nullable <(Of <(<' Int32 >)>)>
Optional: If not providede all mapped aliases will be returned.

Return Value

Type: array< TangoLocation..::..AliasMapping >[]()[][]

See Also

TangoLocation Class
TangoLocation Members


TangoLocation.GetAliasLocations Method

[image]

Concert Web Services Library
TangoLocation..::..GetAliasLocations Method
TangoLocation Class See Also Send Feedback
Get all the location for a specified alias/alias type

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoLocation..::..AliasLocationValue[] GetAliasLocations(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser,
    Guid AliasTypeGuid,
    string FilterAliasValue,
    Nullable<int> FilterLocationTypeID
)
Visual Basic
Public Function GetAliasLocations (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser,
    AliasTypeGuid As Guid,
    FilterAliasValue As String,
    FilterLocationTypeID As Nullable(Of Integer)
) As TangoLocation..::..AliasLocationValue()

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information
AliasTypeGuid
Type: System..::..Guid
The GUID of the alias type you want to fetch
FilterAliasValue
Type: System..::..String
The optional alias value filter
FilterLocationTypeID
Type: System..::..Nullable <(Of <(<' Int32 >)>)>
The optional location type filter

Return Value

Type: array< TangoLocation..::..AliasLocationValue >[]()[][]

See Also

TangoLocation Class
TangoLocation Members


TangoLocation.GetAttributeTypeDefinintions Method

[image]

Concert Web Services Library
TangoLocation..::..GetAttributeTypeDefinintions Method
TangoLocation Class See Also Send Feedback
Return a list of the attribute type definitions

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoLocation..::..AttributeTypeDefinintion[] GetAttributeTypeDefinintions(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser
)
Visual Basic
Public Function GetAttributeTypeDefinintions (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser
) As TangoLocation..::..AttributeTypeDefinintion()

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information

Return Value

Type: array< TangoLocation..::..AttributeTypeDefinintion >[]()[][]
An array of AttributeTypeDefinintion objects.

See Also

TangoLocation Class
TangoLocation Members


TangoLocation.GetLocationInfo Method

[image]

Concert Web Services Library
TangoLocation..::..GetLocationInfo Method
TangoLocation Class See Also Send Feedback
Return information about a location

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoLocation..::..LocationInfo GetLocationInfo(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser,
    int LocationTypeID,
    int LocationID,
    bool FetchChildInfo
)
Visual Basic
Public Function GetLocationInfo (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser,
    LocationTypeID As Integer,
    LocationID As Integer,
    FetchChildInfo As Boolean
) As TangoLocation..::..LocationInfo

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information
LocationTypeID
Type: System..::..Int32
The location type we want to know about. Note that generally 1001 is the "Plant" or top level and the LocationID for that entry is generally 1.
LocationID
Type: System..::..Int32
The internal Tango ID of the location we want to get information about.
FetchChildInfo
Type: System..::..Boolean
Should child information be fetched. Please select false unless you need to traverse child items

Return Value

Type: TangoLocation..::..LocationInfo

See Also

TangoLocation Class
TangoLocation Members


TangoLocation.SaveTangoItemAttribute Method

[image]

Concert Web Services Library
TangoLocation..::..SaveTangoItemAttribute Method
TangoLocation Class See Also Send Feedback
Save location attribute values. If there is a problem saving any of the data, nothing is saved. Returns the number of items processed.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int SaveTangoItemAttribute(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser,
    TangoLocation..::..TangoItemAttributeValue[] attributeValues
)
Visual Basic
Public Function SaveTangoItemAttribute (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser,
    attributeValues As TangoLocation..::..TangoItemAttributeValue()
) As Integer

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information
attributeValues
Type: array< Concert..::..TangoLocation..::..TangoItemAttributeValue >[]()[][]
An array of attribute values to save

Return Value

Type: Int32

See Also

TangoLocation Class
TangoLocation Members


TangoLocation.AliasLocationValue Class

[image]

Concert Web Services Library
TangoLocation..::..AliasLocationValue Class
TangoLocation Class Members See Also Send Feedback
A location ID and alias value

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class AliasLocationValue
Visual Basic
Public Class AliasLocationValue

Inheritance Hierarchy

System..::..Object
Concert..::..TangoLocation..::..AliasLocationValue

See Also

TangoLocation..::..AliasLocationValue Members


TangoLocation.AliasLocationValue Members

[image] [image]

Concert Web Services Library
TangoLocation..::..AliasLocationValue Members
TangoLocation..::..AliasLocationValue Class Constructors Fields See Also Send Feedback

The TangoLocation..::..AliasLocationValue type exposes the following members.

Constructors

 | Name | Description
Public method | TangoLocation..::..AliasLocationValue | Initializes a new instance of the TangoLocation..::..AliasLocationValue class

Fields

 | Name | Description
Public field | Alias | The alias value. Alias values are useful for mapping Tango to external systems or to store meta data about a location.
Public field | LocationID | The Tango location ID
Public field | LocationTypeID | The Tango type ID

See Also

TangoLocation..::..AliasLocationValue Class


TangoLocation.AliasLocationValue Constructor

[image]

Concert Web Services Library
TangoLocation..::..AliasLocationValue Constructor
TangoLocation..::..AliasLocationValue Class See Also Send Feedback
Initializes a new instance of the TangoLocation..::..AliasLocationValue class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AliasLocationValue()
Visual Basic
Public Sub New

See Also

TangoLocation..::..AliasLocationValue Class
TangoLocation..::..AliasLocationValue Members


TangoLocation.AliasLocationValue Fields

[image] [image]

Concert Web Services Library
TangoLocation..::..AliasLocationValue Fields
TangoLocation..::..AliasLocationValue Class See Also Send Feedback

The TangoLocation..::..AliasLocationValue type exposes the following members.

Fields

 | Name | Description
Public field | Alias | The alias value. Alias values are useful for mapping Tango to external systems or to store meta data about a location.
Public field | LocationID | The Tango location ID
Public field | LocationTypeID | The Tango type ID

See Also

TangoLocation..::..AliasLocationValue Class


TangoLocation.AliasLocationValue.Alias Field

[image]

Concert Web Services Library
TangoLocation..::..AliasLocationValue..::..Alias Field
TangoLocation..::..AliasLocationValue Class See Also Send Feedback
The alias value. Alias values are useful for mapping Tango to external systems or to store meta data about a location.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Alias
Visual Basic
Public Alias As String

Field Value

Type: String

See Also

TangoLocation..::..AliasLocationValue Class
TangoLocation..::..AliasLocationValue Members


TangoLocation.AliasLocationValue.LocationID Field

[image]

Concert Web Services Library
TangoLocation..::..AliasLocationValue..::..LocationID Field
TangoLocation..::..AliasLocationValue Class See Also Send Feedback
The Tango location ID

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int LocationID
Visual Basic
Public LocationID As Integer

Field Value

Type: Int32

See Also

TangoLocation..::..AliasLocationValue Class
TangoLocation..::..AliasLocationValue Members


TangoLocation.AliasLocationValue.LocationTypeID Field

[image]

Concert Web Services Library
TangoLocation..::..AliasLocationValue..::..LocationTypeID Field
TangoLocation..::..AliasLocationValue Class See Also Send Feedback
The Tango type ID

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int LocationTypeID
Visual Basic
Public LocationTypeID As Integer

Field Value

Type: Int32

See Also

TangoLocation..::..AliasLocationValue Class
TangoLocation..::..AliasLocationValue Members


TangoLocation.AliasMapping Class

[image]

Concert Web Services Library
TangoLocation..::..AliasMapping Class
TangoLocation Class Members See Also Send Feedback
A mapping between a location and an alias type

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class AliasMapping
Visual Basic
Public Class AliasMapping

Inheritance Hierarchy

System..::..Object
Concert..::..TangoLocation..::..AliasMapping

See Also

TangoLocation..::..AliasMapping Members


TangoLocation.AliasMapping Members

[image] [image]

Concert Web Services Library
TangoLocation..::..AliasMapping Members
TangoLocation..::..AliasMapping Class Constructors Fields See Also Send Feedback

The TangoLocation..::..AliasMapping type exposes the following members.

Constructors

 | Name | Description
Public method | TangoLocation..::..AliasMapping | Initializes a new instance of the TangoLocation..::..AliasMapping class

Fields

 | Name | Description
Public field | AliasTypeGuid | The Tango GUID for the mapped alias
Public field | AliasTypeName | The name of the mapped alias
Public field | AllowMultipleAliasValues | Are multiple alias values allowed for this mapping
Public field | LocationTypeID | The location type ID for the mapped alias
Public field | UseAliasValueMapping | Indicates if the alias value is internally mapped to a set of pre-determined values.

See Also

TangoLocation..::..AliasMapping Class


TangoLocation.AliasMapping Constructor

[image]

Concert Web Services Library
TangoLocation..::..AliasMapping Constructor
TangoLocation..::..AliasMapping Class See Also Send Feedback
Initializes a new instance of the TangoLocation..::..AliasMapping class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AliasMapping()
Visual Basic
Public Sub New

See Also

TangoLocation..::..AliasMapping Class
TangoLocation..::..AliasMapping Members


TangoLocation.AliasMapping Fields

[image] [image]

Concert Web Services Library
TangoLocation..::..AliasMapping Fields
TangoLocation..::..AliasMapping Class See Also Send Feedback

The TangoLocation..::..AliasMapping type exposes the following members.

Fields

 | Name | Description
Public field | AliasTypeGuid | The Tango GUID for the mapped alias
Public field | AliasTypeName | The name of the mapped alias
Public field | AllowMultipleAliasValues | Are multiple alias values allowed for this mapping
Public field | LocationTypeID | The location type ID for the mapped alias
Public field | UseAliasValueMapping | Indicates if the alias value is internally mapped to a set of pre-determined values.

See Also

TangoLocation..::..AliasMapping Class


TangoLocation.AliasMapping.AliasTypeGuid Field

[image]

Concert Web Services Library
TangoLocation..::..AliasMapping..::..AliasTypeGuid Field
TangoLocation..::..AliasMapping Class See Also Send Feedback
The Tango GUID for the mapped alias

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid AliasTypeGuid
Visual Basic
Public AliasTypeGuid As Guid

Field Value

Type: Guid

See Also

TangoLocation..::..AliasMapping Class
TangoLocation..::..AliasMapping Members


TangoLocation.AliasMapping.AliasTypeName Field

[image]

Concert Web Services Library
TangoLocation..::..AliasMapping..::..AliasTypeName Field
TangoLocation..::..AliasMapping Class See Also Send Feedback
The name of the mapped alias

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string AliasTypeName
Visual Basic
Public AliasTypeName As String

Field Value

Type: String

See Also

TangoLocation..::..AliasMapping Class
TangoLocation..::..AliasMapping Members


TangoLocation.AliasMapping.AllowMultipleAliasValues Field

[image]

Concert Web Services Library
TangoLocation..::..AliasMapping..::..AllowMultipleAliasValues Field
TangoLocation..::..AliasMapping Class See Also Send Feedback
Are multiple alias values allowed for this mapping

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AllowMultipleAliasValues
Visual Basic
Public AllowMultipleAliasValues As Boolean

Field Value

Type: Boolean

See Also

TangoLocation..::..AliasMapping Class
TangoLocation..::..AliasMapping Members


TangoLocation.AliasMapping.LocationTypeID Field

[image]

Concert Web Services Library
TangoLocation..::..AliasMapping..::..LocationTypeID Field
TangoLocation..::..AliasMapping Class See Also Send Feedback
The location type ID for the mapped alias

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int LocationTypeID
Visual Basic
Public LocationTypeID As Integer

Field Value

Type: Int32

See Also

TangoLocation..::..AliasMapping Class
TangoLocation..::..AliasMapping Members


TangoLocation.AliasMapping.UseAliasValueMapping Field

[image]

Concert Web Services Library
TangoLocation..::..AliasMapping..::..UseAliasValueMapping Field
TangoLocation..::..AliasMapping Class See Also Send Feedback
Indicates if the alias value is internally mapped to a set of pre-determined values.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool UseAliasValueMapping
Visual Basic
Public UseAliasValueMapping As Boolean

Field Value

Type: Boolean

See Also

TangoLocation..::..AliasMapping Class
TangoLocation..::..AliasMapping Members


TangoLocation.AliasValue Class

[image]

Concert Web Services Library
TangoLocation..::..AliasValue Class
TangoLocation Class Members See Also Send Feedback
A location alias value

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class AliasValue
Visual Basic
Public Class AliasValue

Inheritance Hierarchy

System..::..Object
Concert..::..TangoLocation..::..AliasValue

See Also

TangoLocation..::..AliasValue Members


TangoLocation.AliasValue Members

[image] [image]

Concert Web Services Library
TangoLocation..::..AliasValue Members
TangoLocation..::..AliasValue Class Constructors Fields See Also Send Feedback

The TangoLocation..::..AliasValue type exposes the following members.

Constructors

 | Name | Description
Public method | TangoLocation..::..AliasValue | Initializes a new instance of the TangoLocation..::..AliasValue class

Fields

 | Name | Description
Public field | Alias | The alias value. Alias values are useful for mapping Tango to external systems or to store meta data about a location.
Public field | AliasTypeGuid | The internal Tango alias type GUID
Public field | AliasTypeName | The name of the type of alias value. Examples may include SAP, Location Barcode, Maximo, etc.

See Also

TangoLocation..::..AliasValue Class


TangoLocation.AliasValue Constructor

[image]

Concert Web Services Library
TangoLocation..::..AliasValue Constructor
TangoLocation..::..AliasValue Class See Also Send Feedback
Initializes a new instance of the TangoLocation..::..AliasValue class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AliasValue()
Visual Basic
Public Sub New

See Also

TangoLocation..::..AliasValue Class
TangoLocation..::..AliasValue Members


TangoLocation.AliasValue Fields

[image] [image]

Concert Web Services Library
TangoLocation..::..AliasValue Fields
TangoLocation..::..AliasValue Class See Also Send Feedback

The TangoLocation..::..AliasValue type exposes the following members.

Fields

 | Name | Description
Public field | Alias | The alias value. Alias values are useful for mapping Tango to external systems or to store meta data about a location.
Public field | AliasTypeGuid | The internal Tango alias type GUID
Public field | AliasTypeName | The name of the type of alias value. Examples may include SAP, Location Barcode, Maximo, etc.

See Also

TangoLocation..::..AliasValue Class


TangoLocation.AliasValue.Alias Field

[image]

Concert Web Services Library
TangoLocation..::..AliasValue..::..Alias Field
TangoLocation..::..AliasValue Class See Also Send Feedback
The alias value. Alias values are useful for mapping Tango to external systems or to store meta data about a location.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Alias
Visual Basic
Public Alias As String

Field Value

Type: String

See Also

TangoLocation..::..AliasValue Class
TangoLocation..::..AliasValue Members


TangoLocation.AliasValue.AliasTypeGuid Field

[image]

Concert Web Services Library
TangoLocation..::..AliasValue..::..AliasTypeGuid Field
TangoLocation..::..AliasValue Class See Also Send Feedback
The internal Tango alias type GUID

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid AliasTypeGuid
Visual Basic
Public AliasTypeGuid As Guid

Field Value

Type: Guid

See Also

TangoLocation..::..AliasValue Class
TangoLocation..::..AliasValue Members


TangoLocation.AliasValue.AliasTypeName Field

[image]

Concert Web Services Library
TangoLocation..::..AliasValue..::..AliasTypeName Field
TangoLocation..::..AliasValue Class See Also Send Feedback
The name of the type of alias value. Examples may include SAP, Location Barcode, Maximo, etc.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string AliasTypeName
Visual Basic
Public AliasTypeName As String

Field Value

Type: String

See Also

TangoLocation..::..AliasValue Class
TangoLocation..::..AliasValue Members


TangoLocation.AttributeTypeAndValue Class

[image]

Concert Web Services Library
TangoLocation..::..AttributeTypeAndValue Class
TangoLocation Class Members See Also Send Feedback
An attribute type and attribute value association.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class AttributeTypeAndValue
Visual Basic
Public Class AttributeTypeAndValue

Inheritance Hierarchy

System..::..Object
Concert..::..TangoLocation..::..AttributeTypeAndValue
Concert..::..TangoLocation..::..TangoItemAttributeValue

See Also

TangoLocation..::..AttributeTypeAndValue Members


TangoLocation.AttributeTypeAndValue Members

[image] [image]

Concert Web Services Library
TangoLocation..::..AttributeTypeAndValue Members
TangoLocation..::..AttributeTypeAndValue Class Constructors Fields See Also Send Feedback

The TangoLocation..::..AttributeTypeAndValue type exposes the following members.

Constructors

 | Name | Description
Public method | TangoLocation..::..AttributeTypeAndValue | Initializes a new instance of the TangoLocation..::..AttributeTypeAndValue class

Fields

 | Name | Description
Public field | TangoItemAttributeTypeID | The type of attribute
Public field | Value | The attribute value

See Also

TangoLocation..::..AttributeTypeAndValue Class


TangoLocation.AttributeTypeAndValue Constructor

[image]

Concert Web Services Library
TangoLocation..::..AttributeTypeAndValue Constructor
TangoLocation..::..AttributeTypeAndValue Class See Also Send Feedback
Initializes a new instance of the TangoLocation..::..AttributeTypeAndValue class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AttributeTypeAndValue()
Visual Basic
Public Sub New

See Also

TangoLocation..::..AttributeTypeAndValue Class
TangoLocation..::..AttributeTypeAndValue Members


TangoLocation.AttributeTypeAndValue Fields

[image] [image]

Concert Web Services Library
TangoLocation..::..AttributeTypeAndValue Fields
TangoLocation..::..AttributeTypeAndValue Class See Also Send Feedback

The TangoLocation..::..AttributeTypeAndValue type exposes the following members.

Fields

 | Name | Description
Public field | TangoItemAttributeTypeID | The type of attribute
Public field | Value | The attribute value

See Also

TangoLocation..::..AttributeTypeAndValue Class


TangoLocation.AttributeTypeAndValue.TangoItemAttributeTypeID Field

[image]

Concert Web Services Library
TangoLocation..::..AttributeTypeAndValue..::..TangoItemAttributeTypeID Field
TangoLocation..::..AttributeTypeAndValue Class See Also Send Feedback
The type of attribute

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int TangoItemAttributeTypeID
Visual Basic
Public TangoItemAttributeTypeID As Integer

Field Value

Type: Int32

See Also

TangoLocation..::..AttributeTypeAndValue Class
TangoLocation..::..AttributeTypeAndValue Members


TangoLocation.AttributeTypeAndValue.Value Field

[image]

Concert Web Services Library
TangoLocation..::..AttributeTypeAndValue..::..Value Field
TangoLocation..::..AttributeTypeAndValue Class See Also Send Feedback
The attribute value

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Value
Visual Basic
Public Value As String

Field Value

Type: String

See Also

TangoLocation..::..AttributeTypeAndValue Class
TangoLocation..::..AttributeTypeAndValue Members


TangoLocation.AttributeTypeDefinintion Class

[image]

Concert Web Services Library
TangoLocation..::..AttributeTypeDefinintion Class
TangoLocation Class Members See Also Send Feedback
Tango Tree Item Attribute. Meta data related to extended definitions of Tango locations.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class AttributeTypeDefinintion
Visual Basic
Public Class AttributeTypeDefinintion

Inheritance Hierarchy

System..::..Object
Concert..::..TangoLocation..::..AttributeTypeDefinintion

See Also

TangoLocation..::..AttributeTypeDefinintion Members


TangoLocation.AttributeTypeDefinintion Members

[image] [image]

Concert Web Services Library
TangoLocation..::..AttributeTypeDefinintion Members
TangoLocation..::..AttributeTypeDefinintion Class Constructors Fields See Also Send Feedback

The TangoLocation..::..AttributeTypeDefinintion type exposes the following members.

Constructors

 | Name | Description
Public method | TangoLocation..::..AttributeTypeDefinintion | Initializes a new instance of the TangoLocation..::..AttributeTypeDefinintion class

Fields

 | Name | Description
Public field | DisplayOrder | The display order of this attribute for the specified TangoItemIDTypeID
Public field | IsCustomAttibute | Indicates if the attribute is a standard (stock) attribute or custom. Generally stock attributes should be available for all Tango databases and custom attributes are added as needed to individual databases.
Public field | TangoItemAttributeTypeDescription | A description of the attribute. Should indicate how it is to be used.
Public field | TangoItemAttributeTypeID | The ID of the attribute. Is the integer value associated with TangoItemAttributeType
Public field | TangoItemAttributeTypeName | The name of the attribute
Public field | TangoItemAttributeVariantType | The variant type of the attribute (3=int, 4=real, 8=string)
Public field | TangoItemIDTypeID | The location that this attribute is associated with.

See Also

TangoLocation..::..AttributeTypeDefinintion Class


TangoLocation.AttributeTypeDefinintion Constructor

[image]

Concert Web Services Library
TangoLocation..::..AttributeTypeDefinintion Constructor
TangoLocation..::..AttributeTypeDefinintion Class See Also Send Feedback
Initializes a new instance of the TangoLocation..::..AttributeTypeDefinintion class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AttributeTypeDefinintion()
Visual Basic
Public Sub New

See Also

TangoLocation..::..AttributeTypeDefinintion Class
TangoLocation..::..AttributeTypeDefinintion Members


TangoLocation.AttributeTypeDefinintion Fields

[image] [image]

Concert Web Services Library
TangoLocation..::..AttributeTypeDefinintion Fields
TangoLocation..::..AttributeTypeDefinintion Class See Also Send Feedback

The TangoLocation..::..AttributeTypeDefinintion type exposes the following members.

Fields

 | Name | Description
Public field | DisplayOrder | The display order of this attribute for the specified TangoItemIDTypeID
Public field | IsCustomAttibute | Indicates if the attribute is a standard (stock) attribute or custom. Generally stock attributes should be available for all Tango databases and custom attributes are added as needed to individual databases.
Public field | TangoItemAttributeTypeDescription | A description of the attribute. Should indicate how it is to be used.
Public field | TangoItemAttributeTypeID | The ID of the attribute. Is the integer value associated with TangoItemAttributeType
Public field | TangoItemAttributeTypeName | The name of the attribute
Public field | TangoItemAttributeVariantType | The variant type of the attribute (3=int, 4=real, 8=string)
Public field | TangoItemIDTypeID | The location that this attribute is associated with.

See Also

TangoLocation..::..AttributeTypeDefinintion Class


TangoLocation.AttributeTypeDefinintion.DisplayOrder Field

[image]

Concert Web Services Library
TangoLocation..::..AttributeTypeDefinintion..::..DisplayOrder Field
TangoLocation..::..AttributeTypeDefinintion Class See Also Send Feedback
The display order of this attribute for the specified TangoItemIDTypeID

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<int> DisplayOrder
Visual Basic
Public DisplayOrder As Nullable(Of Integer)

Field Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

TangoLocation..::..AttributeTypeDefinintion Class
TangoLocation..::..AttributeTypeDefinintion Members


TangoLocation.AttributeTypeDefinintion.IsCustomAttibute Field

[image]

Concert Web Services Library
TangoLocation..::..AttributeTypeDefinintion..::..IsCustomAttibute Field
TangoLocation..::..AttributeTypeDefinintion Class See Also Send Feedback
Indicates if the attribute is a standard (stock) attribute or custom. Generally stock attributes should be available for all Tango databases and custom attributes are added as needed to individual databases.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsCustomAttibute
Visual Basic
Public IsCustomAttibute As Boolean

Field Value

Type: Boolean

See Also

TangoLocation..::..AttributeTypeDefinintion Class
TangoLocation..::..AttributeTypeDefinintion Members


TangoLocation.AttributeTypeDefinintion.TangoItemAttributeTypeDescription Field

[image]

Concert Web Services Library
TangoLocation..::..AttributeTypeDefinintion..::..TangoItemAttributeTypeDescription Field
TangoLocation..::..AttributeTypeDefinintion Class See Also Send Feedback
A description of the attribute. Should indicate how it is to be used.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string TangoItemAttributeTypeDescription
Visual Basic
Public TangoItemAttributeTypeDescription As String

Field Value

Type: String

See Also

TangoLocation..::..AttributeTypeDefinintion Class
TangoLocation..::..AttributeTypeDefinintion Members


TangoLocation.AttributeTypeDefinintion.TangoItemAttributeTypeID Field

[image]

Concert Web Services Library
TangoLocation..::..AttributeTypeDefinintion..::..TangoItemAttributeTypeID Field
TangoLocation..::..AttributeTypeDefinintion Class See Also Send Feedback
The ID of the attribute. Is the integer value associated with TangoItemAttributeType

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int TangoItemAttributeTypeID
Visual Basic
Public TangoItemAttributeTypeID As Integer

Field Value

Type: Int32

See Also

TangoLocation..::..AttributeTypeDefinintion Class
TangoLocation..::..AttributeTypeDefinintion Members


TangoLocation.AttributeTypeDefinintion.TangoItemAttributeTypeName Field

[image]

Concert Web Services Library
TangoLocation..::..AttributeTypeDefinintion..::..TangoItemAttributeTypeName Field
TangoLocation..::..AttributeTypeDefinintion Class See Also Send Feedback
The name of the attribute

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string TangoItemAttributeTypeName
Visual Basic
Public TangoItemAttributeTypeName As String

Field Value

Type: String

See Also

TangoLocation..::..AttributeTypeDefinintion Class
TangoLocation..::..AttributeTypeDefinintion Members


TangoLocation.AttributeTypeDefinintion.TangoItemAttributeVariantType Field

[image]

Concert Web Services Library
TangoLocation..::..AttributeTypeDefinintion..::..TangoItemAttributeVariantType Field
TangoLocation..::..AttributeTypeDefinintion Class See Also Send Feedback
The variant type of the attribute (3=int, 4=real, 8=string)

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int TangoItemAttributeVariantType
Visual Basic
Public TangoItemAttributeVariantType As Integer

Field Value

Type: Int32

See Also

TangoLocation..::..AttributeTypeDefinintion Class
TangoLocation..::..AttributeTypeDefinintion Members


TangoLocation.AttributeTypeDefinintion.TangoItemIDTypeID Field

[image]

Concert Web Services Library
TangoLocation..::..AttributeTypeDefinintion..::..TangoItemIDTypeID Field
TangoLocation..::..AttributeTypeDefinintion Class See Also Send Feedback
The location that this attribute is associated with.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int TangoItemIDTypeID
Visual Basic
Public TangoItemIDTypeID As Integer

Field Value

Type: Int32

See Also

TangoLocation..::..AttributeTypeDefinintion Class
TangoLocation..::..AttributeTypeDefinintion Members


TangoLocation.LocationInfo Class

[image]

Concert Web Services Library
TangoLocation..::..LocationInfo Class
TangoLocation Class Members See Also Send Feedback
Location information

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LocationInfo
Visual Basic
Public Class LocationInfo

Inheritance Hierarchy

System..::..Object
Concert..::..TangoLocation..::..LocationInfo

See Also

TangoLocation..::..LocationInfo Members


TangoLocation.LocationInfo Members

[image] [image]

Concert Web Services Library
TangoLocation..::..LocationInfo Members
TangoLocation..::..LocationInfo Class Constructors Fields See Also Send Feedback

The TangoLocation..::..LocationInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TangoLocation..::..LocationInfo | Initializes a new instance of the TangoLocation..::..LocationInfo class

Fields

 | Name | Description
Public field | AliasValues | A list of alias values for the location
Public field | Attributes | A list of location attribute values
Public field | Childern | A list of child locations for the location
Public field | Decommissioned | Is the location decommisioned? Decommisioned locations are not usually displayed to users.
Public field | LevelNameTitle | The location level/type title
Public field | LocationID | The internal Tango location ID
Public field | LocationName | The location name
Public field | LocationTypeID | The internal Tango location type ID
Public field | OrderValue | Optional display order value (1 is displayed before 2)
Public field | ParentLocationID | Indicates what the parent location ID is
Public field | ParentLocationTypeID | Indicates what the parent location ID type is

See Also

TangoLocation..::..LocationInfo Class


TangoLocation.LocationInfo Constructor

[image]

Concert Web Services Library
TangoLocation..::..LocationInfo Constructor
TangoLocation..::..LocationInfo Class See Also Send Feedback
Initializes a new instance of the TangoLocation..::..LocationInfo class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LocationInfo()
Visual Basic
Public Sub New

See Also

TangoLocation..::..LocationInfo Class
TangoLocation..::..LocationInfo Members


TangoLocation.LocationInfo Fields

[image] [image]

Concert Web Services Library
TangoLocation..::..LocationInfo Fields
TangoLocation..::..LocationInfo Class See Also Send Feedback

The TangoLocation..::..LocationInfo type exposes the following members.

Fields

 | Name | Description
Public field | AliasValues | A list of alias values for the location
Public field | Attributes | A list of location attribute values
Public field | Childern | A list of child locations for the location
Public field | Decommissioned | Is the location decommisioned? Decommisioned locations are not usually displayed to users.
Public field | LevelNameTitle | The location level/type title
Public field | LocationID | The internal Tango location ID
Public field | LocationName | The location name
Public field | LocationTypeID | The internal Tango location type ID
Public field | OrderValue | Optional display order value (1 is displayed before 2)
Public field | ParentLocationID | Indicates what the parent location ID is
Public field | ParentLocationTypeID | Indicates what the parent location ID type is

See Also

TangoLocation..::..LocationInfo Class


TangoLocation.LocationInfo.AliasValues Field

[image]

Concert Web Services Library
TangoLocation..::..LocationInfo..::..AliasValues Field
TangoLocation..::..LocationInfo Class See Also Send Feedback
A list of alias values for the location

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<TangoLocation..::..AliasValue> AliasValues
Visual Basic
Public AliasValues As List(Of TangoLocation..::..AliasValue)

Field Value

Type: List <(Of <(<' TangoLocation..::..AliasValue >)>)>

See Also

TangoLocation..::..LocationInfo Class
TangoLocation..::..LocationInfo Members


TangoLocation.LocationInfo.Attributes Field

[image]

Concert Web Services Library
TangoLocation..::..LocationInfo..::..Attributes Field
TangoLocation..::..LocationInfo Class See Also Send Feedback
A list of location attribute values

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<TangoLocation..::..AttributeTypeAndValue> Attributes
Visual Basic
Public Attributes As List(Of TangoLocation..::..AttributeTypeAndValue)

Field Value

Type: List <(Of <(<' TangoLocation..::..AttributeTypeAndValue >)>)>

See Also

TangoLocation..::..LocationInfo Class
TangoLocation..::..LocationInfo Members


TangoLocation.LocationInfo.Childern Field

[image]

Concert Web Services Library
TangoLocation..::..LocationInfo..::..Childern Field
TangoLocation..::..LocationInfo Class See Also Send Feedback
A list of child locations for the location

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<TangoLocation..::..LocationInfo> Childern
Visual Basic
Public Childern As List(Of TangoLocation..::..LocationInfo)

Field Value

Type: List <(Of <(<' TangoLocation..::..LocationInfo >)>)>

See Also

TangoLocation..::..LocationInfo Class
TangoLocation..::..LocationInfo Members


TangoLocation.LocationInfo.Decommissioned Field

[image]

Concert Web Services Library
TangoLocation..::..LocationInfo..::..Decommissioned Field
TangoLocation..::..LocationInfo Class See Also Send Feedback
Is the location decommisioned? Decommisioned locations are not usually displayed to users.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Decommissioned
Visual Basic
Public Decommissioned As Boolean

Field Value

Type: Boolean

See Also

TangoLocation..::..LocationInfo Class
TangoLocation..::..LocationInfo Members


TangoLocation.LocationInfo.LevelNameTitle Field

[image]

Concert Web Services Library
TangoLocation..::..LocationInfo..::..LevelNameTitle Field
TangoLocation..::..LocationInfo Class See Also Send Feedback
The location level/type title

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string LevelNameTitle
Visual Basic
Public LevelNameTitle As String

Field Value

Type: String

See Also

TangoLocation..::..LocationInfo Class
TangoLocation..::..LocationInfo Members


TangoLocation.LocationInfo.LocationID Field

[image]

Concert Web Services Library
TangoLocation..::..LocationInfo..::..LocationID Field
TangoLocation..::..LocationInfo Class See Also Send Feedback
The internal Tango location ID

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<int> LocationID
Visual Basic
Public LocationID As Nullable(Of Integer)

Field Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

TangoLocation..::..LocationInfo Class
TangoLocation..::..LocationInfo Members


TangoLocation.LocationInfo.LocationName Field

[image]

Concert Web Services Library
TangoLocation..::..LocationInfo..::..LocationName Field
TangoLocation..::..LocationInfo Class See Also Send Feedback
The location name

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string LocationName
Visual Basic
Public LocationName As String

Field Value

Type: String

See Also

TangoLocation..::..LocationInfo Class
TangoLocation..::..LocationInfo Members


TangoLocation.LocationInfo.LocationTypeID Field

[image]

Concert Web Services Library
TangoLocation..::..LocationInfo..::..LocationTypeID Field
TangoLocation..::..LocationInfo Class See Also Send Feedback
The internal Tango location type ID

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int LocationTypeID
Visual Basic
Public LocationTypeID As Integer

Field Value

Type: Int32

See Also

TangoLocation..::..LocationInfo Class
TangoLocation..::..LocationInfo Members


TangoLocation.LocationInfo.OrderValue Field

[image]

Concert Web Services Library
TangoLocation..::..LocationInfo..::..OrderValue Field
TangoLocation..::..LocationInfo Class See Also Send Feedback
Optional display order value (1 is displayed before 2)

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<int> OrderValue
Visual Basic
Public OrderValue As Nullable(Of Integer)

Field Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

TangoLocation..::..LocationInfo Class
TangoLocation..::..LocationInfo Members


TangoLocation.LocationInfo.ParentLocationID Field

[image]

Concert Web Services Library
TangoLocation..::..LocationInfo..::..ParentLocationID Field
TangoLocation..::..LocationInfo Class See Also Send Feedback
Indicates what the parent location ID is

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<int> ParentLocationID
Visual Basic
Public ParentLocationID As Nullable(Of Integer)

Field Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

TangoLocation..::..LocationInfo Class
TangoLocation..::..LocationInfo Members


TangoLocation.LocationInfo.ParentLocationTypeID Field

[image]

Concert Web Services Library
TangoLocation..::..LocationInfo..::..ParentLocationTypeID Field
TangoLocation..::..LocationInfo Class See Also Send Feedback
Indicates what the parent location ID type is

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<int> ParentLocationTypeID
Visual Basic
Public ParentLocationTypeID As Nullable(Of Integer)

Field Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

TangoLocation..::..LocationInfo Class
TangoLocation..::..LocationInfo Members


TangoLocation.LocationOrAliasUnion Class

[image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion Class
TangoLocation Class Members See Also Send Feedback
A union of either a location ID or a location alias

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LocationOrAliasUnion
Visual Basic
Public Class LocationOrAliasUnion

Inheritance Hierarchy

System..::..Object
Concert..::..TangoLocation..::..LocationOrAliasUnion

See Also

TangoLocation..::..LocationOrAliasUnion Members


TangoLocation.LocationOrAliasUnion Members

[image] [image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion Members
TangoLocation..::..LocationOrAliasUnion Class Constructors Fields See Also Send Feedback

The TangoLocation..::..LocationOrAliasUnion type exposes the following members.

Constructors

 | Name | Description
Public method | TangoLocation..::..LocationOrAliasUnion | Initializes a new instance of the TangoLocation..::..LocationOrAliasUnion class

Fields

 | Name | Description
Public field | Alias | The Tango location alias information
Public field | Location | The Tango location ID information

See Also

TangoLocation..::..LocationOrAliasUnion Class


TangoLocation.LocationOrAliasUnion Constructor

[image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion Constructor
TangoLocation..::..LocationOrAliasUnion Class See Also Send Feedback
Initializes a new instance of the TangoLocation..::..LocationOrAliasUnion class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LocationOrAliasUnion()
Visual Basic
Public Sub New

See Also

TangoLocation..::..LocationOrAliasUnion Class
TangoLocation..::..LocationOrAliasUnion Members


TangoLocation.LocationOrAliasUnion Fields

[image] [image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion Fields
TangoLocation..::..LocationOrAliasUnion Class See Also Send Feedback

The TangoLocation..::..LocationOrAliasUnion type exposes the following members.

Fields

 | Name | Description
Public field | Alias | The Tango location alias information
Public field | Location | The Tango location ID information

See Also

TangoLocation..::..LocationOrAliasUnion Class


TangoLocation.LocationOrAliasUnion.Alias Field

[image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion..::..Alias Field
TangoLocation..::..LocationOrAliasUnion Class See Also Send Feedback
The Tango location alias information

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoLocation..::..LocationOrAliasUnion..::..AliasData Alias
Visual Basic
Public Alias As TangoLocation..::..LocationOrAliasUnion..::..AliasData

Field Value

Type: TangoLocation..::..LocationOrAliasUnion..::..AliasData

See Also

TangoLocation..::..LocationOrAliasUnion Class
TangoLocation..::..LocationOrAliasUnion Members


TangoLocation.LocationOrAliasUnion.Location Field

[image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion..::..Location Field
TangoLocation..::..LocationOrAliasUnion Class See Also Send Feedback
The Tango location ID information

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoLocation..::..LocationOrAliasUnion..::..LocationID Location
Visual Basic
Public Location As TangoLocation..::..LocationOrAliasUnion..::..LocationID

Field Value

Type: TangoLocation..::..LocationOrAliasUnion..::..LocationID

See Also

TangoLocation..::..LocationOrAliasUnion Class
TangoLocation..::..LocationOrAliasUnion Members


TangoLocation.LocationOrAliasUnion.AliasData Class

[image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion..::..AliasData Class
TangoLocation..::..LocationOrAliasUnion Class Members See Also Send Feedback
A Tango location by its Tango alias value

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class AliasData
Visual Basic
Public Class AliasData

Inheritance Hierarchy

System..::..Object
Concert..::..TangoLocation..::..LocationOrAliasUnion..::..AliasData

See Also

TangoLocation..::..LocationOrAliasUnion..::..AliasData Members


TangoLocation.LocationOrAliasUnion.AliasData Members

[image] [image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion..::..AliasData Members
TangoLocation..::..LocationOrAliasUnion..::..AliasData Class Constructors Fields See Also Send Feedback

The TangoLocation..::..LocationOrAliasUnion..::..AliasData type exposes the following members.

Constructors

 | Name | Description
Public method | TangoLocation..::..LocationOrAliasUnion..::..AliasData | Initializes a new instance of the TangoLocation..::..LocationOrAliasUnion..::..AliasData class

Fields

 | Name | Description
Public field | AliasCategoryID | A Tango alias category. Typically this matches the location type ID
Public field | AliasTypeName | A Tango alias value type
Public field | AliasValue | A Tango alias value

See Also

TangoLocation..::..LocationOrAliasUnion..::..AliasData Class


TangoLocation.LocationOrAliasUnion.AliasData Constructor

[image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion..::..AliasData Constructor
TangoLocation..::..LocationOrAliasUnion..::..AliasData Class See Also Send Feedback
Initializes a new instance of the TangoLocation..::..LocationOrAliasUnion..::..AliasData class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AliasData()
Visual Basic
Public Sub New

See Also

TangoLocation..::..LocationOrAliasUnion..::..AliasData Class
TangoLocation..::..LocationOrAliasUnion..::..AliasData Members


TangoLocation.LocationOrAliasUnion.AliasData Fields

[image] [image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion..::..AliasData Fields
TangoLocation..::..LocationOrAliasUnion..::..AliasData Class See Also Send Feedback

The TangoLocation..::..LocationOrAliasUnion..::..AliasData type exposes the following members.

Fields

 | Name | Description
Public field | AliasCategoryID | A Tango alias category. Typically this matches the location type ID
Public field | AliasTypeName | A Tango alias value type
Public field | AliasValue | A Tango alias value

See Also

TangoLocation..::..LocationOrAliasUnion..::..AliasData Class


TangoLocation.LocationOrAliasUnion.AliasData.AliasCategoryID Field

[image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion..::..AliasData..::..AliasCategoryID Field
TangoLocation..::..LocationOrAliasUnion..::..AliasData Class See Also Send Feedback
A Tango alias category. Typically this matches the location type ID

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<int> AliasCategoryID
Visual Basic
Public AliasCategoryID As Nullable(Of Integer)

Field Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

TangoLocation..::..LocationOrAliasUnion..::..AliasData Class
TangoLocation..::..LocationOrAliasUnion..::..AliasData Members


TangoLocation.LocationOrAliasUnion.AliasData.AliasTypeName Field

[image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion..::..AliasData..::..AliasTypeName Field
TangoLocation..::..LocationOrAliasUnion..::..AliasData Class See Also Send Feedback
A Tango alias value type

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string AliasTypeName
Visual Basic
Public AliasTypeName As String

Field Value

Type: String

See Also

TangoLocation..::..LocationOrAliasUnion..::..AliasData Class
TangoLocation..::..LocationOrAliasUnion..::..AliasData Members


TangoLocation.LocationOrAliasUnion.AliasData.AliasValue Field

[image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion..::..AliasData..::..AliasValue Field
TangoLocation..::..LocationOrAliasUnion..::..AliasData Class See Also Send Feedback
A Tango alias value

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string AliasValue
Visual Basic
Public AliasValue As String

Field Value

Type: String

See Also

TangoLocation..::..LocationOrAliasUnion..::..AliasData Class
TangoLocation..::..LocationOrAliasUnion..::..AliasData Members


TangoLocation.LocationOrAliasUnion.LocationID Class

[image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion..::..LocationID Class
TangoLocation..::..LocationOrAliasUnion Class Members See Also Send Feedback
A Tango location by its internal Tango ID

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LocationID
Visual Basic
Public Class LocationID

Inheritance Hierarchy

System..::..Object
Concert..::..TangoLocation..::..LocationOrAliasUnion..::..LocationID

See Also

TangoLocation..::..LocationOrAliasUnion..::..LocationID Members


TangoLocation.LocationOrAliasUnion.LocationID Members

[image] [image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion..::..LocationID Members
TangoLocation..::..LocationOrAliasUnion..::..LocationID Class Constructors Fields See Also Send Feedback

The TangoLocation..::..LocationOrAliasUnion..::..LocationID type exposes the following members.

Constructors

 | Name | Description
Public method | TangoLocation..::..LocationOrAliasUnion..::..LocationID | Initializes a new instance of the TangoLocation..::..LocationOrAliasUnion..::..LocationID class

Fields

 | Name | Description
Public field | ID | The Tango location ID
Public field | TypeID | The Tango type ID

See Also

TangoLocation..::..LocationOrAliasUnion..::..LocationID Class


TangoLocation.LocationOrAliasUnion.LocationID Constructor

[image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion..::..LocationID Constructor
TangoLocation..::..LocationOrAliasUnion..::..LocationID Class See Also Send Feedback
Initializes a new instance of the TangoLocation..::..LocationOrAliasUnion..::..LocationID class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LocationID()
Visual Basic
Public Sub New

See Also

TangoLocation..::..LocationOrAliasUnion..::..LocationID Class
TangoLocation..::..LocationOrAliasUnion..::..LocationID Members


TangoLocation.LocationOrAliasUnion.LocationID Fields

[image] [image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion..::..LocationID Fields
TangoLocation..::..LocationOrAliasUnion..::..LocationID Class See Also Send Feedback

The TangoLocation..::..LocationOrAliasUnion..::..LocationID type exposes the following members.

Fields

 | Name | Description
Public field | ID | The Tango location ID
Public field | TypeID | The Tango type ID

See Also

TangoLocation..::..LocationOrAliasUnion..::..LocationID Class


TangoLocation.LocationOrAliasUnion.LocationID.ID Field

[image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion..::..LocationID..::..ID Field
TangoLocation..::..LocationOrAliasUnion..::..LocationID Class See Also Send Feedback
The Tango location ID

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<int> ID
Visual Basic
Public ID As Nullable(Of Integer)

Field Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

TangoLocation..::..LocationOrAliasUnion..::..LocationID Class
TangoLocation..::..LocationOrAliasUnion..::..LocationID Members


TangoLocation.LocationOrAliasUnion.LocationID.TypeID Field

[image]

Concert Web Services Library
TangoLocation..::..LocationOrAliasUnion..::..LocationID..::..TypeID Field
TangoLocation..::..LocationOrAliasUnion..::..LocationID Class See Also Send Feedback
The Tango type ID

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<int> TypeID
Visual Basic
Public TypeID As Nullable(Of Integer)

Field Value

Type: Nullable <(Of <(<' Int32 >)>)>

See Also

TangoLocation..::..LocationOrAliasUnion..::..LocationID Class
TangoLocation..::..LocationOrAliasUnion..::..LocationID Members


TangoLocation.RemovalInfo Class

[image]

Concert Web Services Library
TangoLocation..::..RemovalInfo Class
TangoLocation Class Members See Also Send Feedback
Information about the equipment removal

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class RemovalInfo
Visual Basic
Public Class RemovalInfo

Inheritance Hierarchy

System..::..Object
Concert..::..TangoLocation..::..RemovalInfo

See Also

TangoLocation..::..RemovalInfo Members


TangoLocation.RemovalInfo Members

[image] [image]

Concert Web Services Library
TangoLocation..::..RemovalInfo Members
TangoLocation..::..RemovalInfo Class Constructors Fields See Also Send Feedback

The TangoLocation..::..RemovalInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TangoLocation..::..RemovalInfo | Initializes a new instance of the TangoLocation..::..RemovalInfo class

Fields

 | Name | Description
Public field | LocationDecomissioned | Was the location decomissioned after the equipment was removed.
Public field | PreClosureEquipmentGuid | The GUID of the equipment that has been removed.
Public field | PreClosureEquipmentState | The equipment state before it was removed.
Public field | PreClosureLocationID | The Tango ID from which the equipment has been removed.
Public field | PreClosureLocationTypeID | The Tango location type from which the equipment has been removed.
Public field | WarrantyIssue | Were there any warranty issues.

See Also

TangoLocation..::..RemovalInfo Class


TangoLocation.RemovalInfo Constructor

[image]

Concert Web Services Library
TangoLocation..::..RemovalInfo Constructor
TangoLocation..::..RemovalInfo Class See Also Send Feedback
Initializes a new instance of the TangoLocation..::..RemovalInfo class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RemovalInfo()
Visual Basic
Public Sub New

See Also

TangoLocation..::..RemovalInfo Class
TangoLocation..::..RemovalInfo Members


TangoLocation.RemovalInfo Fields

[image] [image]

Concert Web Services Library
TangoLocation..::..RemovalInfo Fields
TangoLocation..::..RemovalInfo Class See Also Send Feedback

The TangoLocation..::..RemovalInfo type exposes the following members.

Fields

 | Name | Description
Public field | LocationDecomissioned | Was the location decomissioned after the equipment was removed.
Public field | PreClosureEquipmentGuid | The GUID of the equipment that has been removed.
Public field | PreClosureEquipmentState | The equipment state before it was removed.
Public field | PreClosureLocationID | The Tango ID from which the equipment has been removed.
Public field | PreClosureLocationTypeID | The Tango location type from which the equipment has been removed.
Public field | WarrantyIssue | Were there any warranty issues.

See Also

TangoLocation..::..RemovalInfo Class


TangoLocation.RemovalInfo.LocationDecomissioned Field

[image]

Concert Web Services Library
TangoLocation..::..RemovalInfo..::..LocationDecomissioned Field
TangoLocation..::..RemovalInfo Class See Also Send Feedback
Was the location decomissioned after the equipment was removed.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<bool> LocationDecomissioned
Visual Basic
Public LocationDecomissioned As Nullable(Of Boolean)

Field Value

Type: Nullable <(Of <(<' Boolean >)>)>

See Also

TangoLocation..::..RemovalInfo Class
TangoLocation..::..RemovalInfo Members


TangoLocation.RemovalInfo.PreClosureEquipmentGuid Field

[image]

Concert Web Services Library
TangoLocation..::..RemovalInfo..::..PreClosureEquipmentGuid Field
TangoLocation..::..RemovalInfo Class See Also Send Feedback
The GUID of the equipment that has been removed.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<Guid> PreClosureEquipmentGuid
Visual Basic
Public PreClosureEquipmentGuid As Nullable(Of Guid)

Field Value

Type: Nullable <(Of <(<' Guid >)>)>

See Also

TangoLocation..::..RemovalInfo Class
TangoLocation..::..RemovalInfo Members


TangoLocation.RemovalInfo.PreClosureEquipmentState Field

[image]

Concert Web Services Library
TangoLocation..::..RemovalInfo..::..PreClosureEquipmentState Field
TangoLocation..::..RemovalInfo Class See Also Send Feedback
The equipment state before it was removed.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public EquipmentStateTypes PreClosureEquipmentState
Visual Basic
Public PreClosureEquipmentState As EquipmentStateTypes

Field Value

Type: EquipmentStateTypes

See Also

TangoLocation..::..RemovalInfo Class
TangoLocation..::..RemovalInfo Members


TangoLocation.RemovalInfo.PreClosureLocationID Field

[image]

Concert Web Services Library
TangoLocation..::..RemovalInfo..::..PreClosureLocationID Field
TangoLocation..::..RemovalInfo Class See Also Send Feedback
The Tango ID from which the equipment has been removed.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int PreClosureLocationID
Visual Basic
Public PreClosureLocationID As Integer

Field Value

Type: Int32

See Also

TangoLocation..::..RemovalInfo Class
TangoLocation..::..RemovalInfo Members


TangoLocation.RemovalInfo.PreClosureLocationTypeID Field

[image]

Concert Web Services Library
TangoLocation..::..RemovalInfo..::..PreClosureLocationTypeID Field
TangoLocation..::..RemovalInfo Class See Also Send Feedback
The Tango location type from which the equipment has been removed.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int PreClosureLocationTypeID
Visual Basic
Public PreClosureLocationTypeID As Integer

Field Value

Type: Int32

See Also

TangoLocation..::..RemovalInfo Class
TangoLocation..::..RemovalInfo Members


TangoLocation.RemovalInfo.WarrantyIssue Field

[image]

Concert Web Services Library
TangoLocation..::..RemovalInfo..::..WarrantyIssue Field
TangoLocation..::..RemovalInfo Class See Also Send Feedback
Were there any warranty issues.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string WarrantyIssue
Visual Basic
Public WarrantyIssue As String

Field Value

Type: String

See Also

TangoLocation..::..RemovalInfo Class
TangoLocation..::..RemovalInfo Members


TangoLocation.TangoItemAttributeType Enumeration

[image]

Concert Web Services Library
TangoLocation..::..TangoItemAttributeType Enumeration
TangoLocation Class See Also Send Feedback
An enumeration of an attribute type. You will ned to pass this in if you want to save attribute data.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum TangoItemAttributeType
Visual Basic
Public Enumeration TangoItemAttributeType

Members

Member name | Value | Description
INVALID | 0 | Used to indicate an invalid or unknown attribute. Generally an alternative to null for enum.

See Also

Concert Namespace


TangoLocation.TangoItemAttributeValue Class

[image]

Concert Web Services Library
TangoLocation..::..TangoItemAttributeValue Class
TangoLocation Class Members See Also Send Feedback
A location, attribute type and attribute value association.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TangoItemAttributeValue : TangoLocation..::..AttributeTypeAndValue
Visual Basic
Public Class TangoItemAttributeValue
    Inherits TangoLocation..::..AttributeTypeAndValue

Inheritance Hierarchy

System..::..Object
Concert..::..TangoLocation..::..AttributeTypeAndValue
Concert..::..TangoLocation..::..TangoItemAttributeValue

See Also

TangoLocation..::..TangoItemAttributeValue Members


TangoLocation.TangoItemAttributeValue Members

[image] [image]

Concert Web Services Library
TangoLocation..::..TangoItemAttributeValue Members
TangoLocation..::..TangoItemAttributeValue Class Constructors Fields Properties See Also Send Feedback

The TangoLocation..::..TangoItemAttributeValue type exposes the following members.

Constructors

 | Name | Description
Public method | TangoLocation..::..TangoItemAttributeValue | Initializes a new instance of the TangoLocation..::..TangoItemAttributeValue class

Fields

 | Name | Description
Public field | TangoItemAttributeTypeID | The type of attribute (Inherited from TangoLocation..::..AttributeTypeAndValue.)
Public field | Value | The attribute value (Inherited from TangoLocation..::..AttributeTypeAndValue.)

Properties

 | Name | Description
Public property | location | The attribute value location

See Also

TangoLocation..::..TangoItemAttributeValue Class


TangoLocation.TangoItemAttributeValue Constructor

[image]

Concert Web Services Library
TangoLocation..::..TangoItemAttributeValue Constructor
TangoLocation..::..TangoItemAttributeValue Class See Also Send Feedback
Initializes a new instance of the TangoLocation..::..TangoItemAttributeValue class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoItemAttributeValue()
Visual Basic
Public Sub New

See Also

TangoLocation..::..TangoItemAttributeValue Class
TangoLocation..::..TangoItemAttributeValue Members


TangoLocation.TangoItemAttributeValue Fields

[image] [image]

Concert Web Services Library
TangoLocation..::..TangoItemAttributeValue Fields
TangoLocation..::..TangoItemAttributeValue Class See Also Send Feedback

The TangoLocation..::..TangoItemAttributeValue type exposes the following members.

Fields

 | Name | Description
Public field | TangoItemAttributeTypeID | The type of attribute (Inherited from TangoLocation..::..AttributeTypeAndValue.)
Public field | Value | The attribute value (Inherited from TangoLocation..::..AttributeTypeAndValue.)

See Also

TangoLocation..::..TangoItemAttributeValue Class


TangoLocation.TangoItemAttributeValue Properties

[image] [image]

Concert Web Services Library
TangoLocation..::..TangoItemAttributeValue Properties
TangoLocation..::..TangoItemAttributeValue Class See Also Send Feedback

The TangoLocation..::..TangoItemAttributeValue type exposes the following members.

Properties

 | Name | Description
Public property | location | The attribute value location

See Also

TangoLocation..::..TangoItemAttributeValue Class


TangoLocation.TangoItemAttributeValue.location Property

[image]

Concert Web Services Library
TangoLocation..::..TangoItemAttributeValue..::..location Property
TangoLocation..::..TangoItemAttributeValue Class See Also Send Feedback
The attribute value location

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoLocation..::..LocationOrAliasUnion location { get; set; }
Visual Basic
Public Property location As TangoLocation..::..LocationOrAliasUnion
    Get
    Set

Property Value

Type: TangoLocation..::..LocationOrAliasUnion

See Also

TangoLocation..::..TangoItemAttributeValue Class
TangoLocation..::..TangoItemAttributeValue Members


TangoUser Class

[image]

Concert Web Services Library
TangoUser Class
Members See Also Send Feedback
This service provides method to manage Tango user configurations externally. Please note that this is a powerful service and if used, can cause features to be visible to users who are not intended to see certain features or data in Tango. By using this service the customer acknowledges that they may expose sensitive information to users that should not have access to such information. Point of View Concepts: There are users and user templates. Templates are used to allow you to setup a set of user rights or a set of user locations and then associate users to the templates. This is very useful when using the automated interfaces and/or managing users.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TangoUser : ConcertWebServiceBase
Visual Basic
Public Class TangoUser
    Inherits ConcertWebServiceBase

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..MarshalByValueComponent
System.Web.Services..::..WebService
ConcertWebServiceBase
Concert..::..TangoUser

See Also

TangoUser Members


TangoUser Members

[image] [image]

Concert Web Services Library
TangoUser Members
TangoUser Class Constructors Methods See Also Send Feedback

The TangoUser type exposes the following members.

Constructors

 | Name | Description
Public method | TangoUser | Initializes a new instance of the TangoUser class

Methods

 | Name | Description
Public method | AddUser | Add a new user to the Tango database. Currently only standard Tango users can be added using this interface. Vendor users and/or User templates must be setup manually -- this is to ensure they are configured properly as the security implications are high for these two user types.
Public method | AddUserSession | If a Tango user name and password are provided, a new user session is created. A valid user session is generally needed if you wish to display a Tango screen.
Public method | FetchUriTypeList | List the known URI types that can be used to call Uri and a description of the usage for that Uri. This list will be extended over time.
Public method | GetCustomerInfo | Each user is associated with a customer group. Each customer group has a given number of user seats. There are also other internal configuration rights associated with the customer group that may not be exposed. This list can only be changed by 24/7 Systems.
Public method | UpdateUser | Update an existing user account
Public method | Uri | Used to get the Uri of a specific page as specified by the data you pass in. If the Uri requires a Tango user session GUID you must pass it when you make this call. If additional data is needed an extraDataXml is available. Further information regarding the formation of a Uri type is available by calling the FetchUriTypeList method.
Public method | UserList | List the existing users and their information

See Also

TangoUser Class


TangoUser Constructor

[image]

Concert Web Services Library
TangoUser Constructor
TangoUser Class See Also Send Feedback
Initializes a new instance of the TangoUser class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoUser()
Visual Basic
Public Sub New

See Also

TangoUser Class
TangoUser Members


TangoUser Methods

[image] [image]

Concert Web Services Library
TangoUser Methods
TangoUser Class See Also Send Feedback

The TangoUser type exposes the following members.

Methods

 | Name | Description
Public method | AddUser | Add a new user to the Tango database. Currently only standard Tango users can be added using this interface. Vendor users and/or User templates must be setup manually -- this is to ensure they are configured properly as the security implications are high for these two user types.
Public method | AddUserSession | If a Tango user name and password are provided, a new user session is created. A valid user session is generally needed if you wish to display a Tango screen.
Public method | FetchUriTypeList | List the known URI types that can be used to call Uri and a description of the usage for that Uri. This list will be extended over time.
Public method | GetCustomerInfo | Each user is associated with a customer group. Each customer group has a given number of user seats. There are also other internal configuration rights associated with the customer group that may not be exposed. This list can only be changed by 24/7 Systems.
Public method | UpdateUser | Update an existing user account
Public method | Uri | Used to get the Uri of a specific page as specified by the data you pass in. If the Uri requires a Tango user session GUID you must pass it when you make this call. If additional data is needed an extraDataXml is available. Further information regarding the formation of a Uri type is available by calling the FetchUriTypeList method.
Public method | UserList | List the existing users and their information

See Also

TangoUser Class


TangoUser.AddUser Method

[image]

Concert Web Services Library
TangoUser..::..AddUser Method
TangoUser Class See Also Send Feedback
Add a new user to the Tango database. Currently only standard Tango users can be added using this interface. Vendor users and/or User templates must be setup manually -- this is to ensure they are configured properly as the security implications are high for these two user types.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid AddUser(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser,
    string UserName,
    string Password,
    int CustomerID,
    string UserWorkspaceName,
    bool HasEditLocationRights,
    bool HasEditEquipmentRights,
    string UserEmailAddress,
    bool DisableLogin,
    bool AssumeDemotedUserRolesByDefault,
    string CellPhoneNumber,
    string OfficePhoneNumber,
    Nullable<Guid> UserRoleTemplateUserGuid,
    Nullable<Guid> UserLocationRightsTemplateUserGuid
)
Visual Basic
Public Function AddUser (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser,
    UserName As String,
    Password As String,
    CustomerID As Integer,
    UserWorkspaceName As String,
    HasEditLocationRights As Boolean,
    HasEditEquipmentRights As Boolean,
    UserEmailAddress As String,
    DisableLogin As Boolean,
    AssumeDemotedUserRolesByDefault As Boolean,
    CellPhoneNumber As String,
    OfficePhoneNumber As String,
    UserRoleTemplateUserGuid As Nullable(Of Guid),
    UserLocationRightsTemplateUserGuid As Nullable(Of Guid)
) As Guid

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information
UserName
Type: System..::..String
The name of the user displayed to Tango users.
Password
Type: System..::..String
The password for the user
CustomerID
Type: System..::..Int32
Which customer account this user belongs to.
UserWorkspaceName
Type: System..::..String
A general workspace name -- generally not important.
HasEditLocationRights
Type: System..::..Boolean
Indicates if this user is allowed to edit location informtion
HasEditEquipmentRights
Type: System..::..Boolean
Indicates if this user is allowed to edit equipment informtion
UserEmailAddress
Type: System..::..String
The email address for this user.
DisableLogin
Type: System..::..Boolean
Indicates if this account is active or inactive. Accounts are not deleted as it would cause problems for history information
AssumeDemotedUserRolesByDefault
Type: System..::..Boolean
Indicates if we want a user to start out with the fewest roles/rights enabled and so all additional rights need to be added piecemeal or if they start out with more rights and as needed have rights deducted. Generally this value is false for plant users, true for external users.
CellPhoneNumber
Type: System..::..String
The cell phone number for the user
OfficePhoneNumber
Type: System..::..String
The office phone number for the user
UserRoleTemplateUserGuid
Type: System..::..Nullable <(Of <(<' Guid >)>)>
If you wish the user roles/rights to be based off a template user, this is the UserGuid for the template user.
UserLocationRightsTemplateUserGuid
Type: System..::..Nullable <(Of <(<' Guid >)>)>
If you wish the user locatoin rights to be based off a template user, this is the UserGuid for the template user.

Return Value

Type: Guid
The GUID identifier for the newly added user

See Also

TangoUser Class
TangoUser Members


TangoUser.AddUserSession Method

[image]

Concert Web Services Library
TangoUser..::..AddUserSession Method
TangoUser Class See Also Send Feedback
If a Tango user name and password are provided, a new user session is created. A valid user session is generally needed if you wish to display a Tango screen.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid AddUserSession(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser,
    string UserName,
    string UserPassword,
    Nullable<int> SessionTimeoutInMinutes,
    string AppProductName
)
Visual Basic
Public Function AddUserSession (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser,
    UserName As String,
    UserPassword As String,
    SessionTimeoutInMinutes As Nullable(Of Integer),
    AppProductName As String
) As Guid

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information
UserName
Type: System..::..String
Name of the Tango user we'll add the session for.
UserPassword
Type: System..::..String
Password for the Tango user we'll add the session for.
SessionTimeoutInMinutes
Type: System..::..Nullable <(Of <(<' Int32 >)>)>
Optional. Most pages make a periodic session refresh call to the web server. If a refresh call is not made after the specified amount of time the user session is deactivated. The default value is 5 minutes.
AppProductName
Type: System..::..String
Optional. Is available for special cases but is generally not needed. The default value is "TangoWeb"

Return Value

Type: Guid
A GUID associated with the Tango user session.

See Also

TangoUser Class
TangoUser Members


TangoUser.FetchUriTypeList Method

[image]

Concert Web Services Library
TangoUser..::..FetchUriTypeList Method
TangoUser Class See Also Send Feedback
List the known URI types that can be used to call Uri and a description of the usage for that Uri. This list will be extended over time.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoUser..::..UriTypeItem[] FetchUriTypeList(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser
)
Visual Basic
Public Function FetchUriTypeList (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser
) As TangoUser..::..UriTypeItem()

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information

Return Value

Type: array< TangoUser..::..UriTypeItem >[]()[][]

See Also

TangoUser Class
TangoUser Members


TangoUser.GetCustomerInfo Method

[image]

Concert Web Services Library
TangoUser..::..GetCustomerInfo Method
TangoUser Class See Also Send Feedback
Each user is associated with a customer group. Each customer group has a given number of user seats. There are also other internal configuration rights associated with the customer group that may not be exposed. This list can only be changed by 24/7 Systems.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoUser..::..CustomerInfo[] GetCustomerInfo(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser
)
Visual Basic
Public Function GetCustomerInfo (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser
) As TangoUser..::..CustomerInfo()

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information

Return Value

Type: array< TangoUser..::..CustomerInfo >[]()[][]
A list of customer info. Each item in the list provides the customer ID, the customer name, and how many sessions are available.

See Also

TangoUser Class
TangoUser Members


TangoUser.UpdateUser Method

[image]

Concert Web Services Library
TangoUser..::..UpdateUser Method
TangoUser Class See Also Send Feedback
Update an existing user account

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void UpdateUser(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser,
    Guid UserGuid,
    string UserName,
    int CustomerID,
    string UserWorkspaceName,
    bool HasEditLocationRights,
    bool HasEditEquipmentRights,
    string UserEmailAddress,
    bool DisableLogin,
    bool AssumeDemotedUserRolesByDefault,
    string CellPhoneNumber,
    string OfficePhoneNumber,
    Nullable<Guid> UserRoleTemplateUserGuid,
    Nullable<Guid> UserLocationRightsTemplateUserGuid
)
Visual Basic
Public Sub UpdateUser (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser,
    UserGuid As Guid,
    UserName As String,
    CustomerID As Integer,
    UserWorkspaceName As String,
    HasEditLocationRights As Boolean,
    HasEditEquipmentRights As Boolean,
    UserEmailAddress As String,
    DisableLogin As Boolean,
    AssumeDemotedUserRolesByDefault As Boolean,
    CellPhoneNumber As String,
    OfficePhoneNumber As String,
    UserRoleTemplateUserGuid As Nullable(Of Guid),
    UserLocationRightsTemplateUserGuid As Nullable(Of Guid)
)

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information
UserGuid
Type: System..::..Guid
The GUID identifier for the user
UserName
Type: System..::..String
The name of the user displayed to Tango users.
CustomerID
Type: System..::..Int32
Which customer account this user belongs to.
UserWorkspaceName
Type: System..::..String
A general workspace name -- generally not important.
HasEditLocationRights
Type: System..::..Boolean
Indicates if this user is allowed to edit location informtion
HasEditEquipmentRights
Type: System..::..Boolean
Indicates if this user is allowed to edit equipment informtion
UserEmailAddress
Type: System..::..String
The email address for this user.
DisableLogin
Type: System..::..Boolean
Indicates if this account is active or inactive. Accounts are not deleted as it would cause problems for history information
AssumeDemotedUserRolesByDefault
Type: System..::..Boolean
Indicates if we want a user to start out with the fewest roles/rights enabled and so all additional rights need to be added piecemeal or if they start out with more rights and as needed have rights deducted. Generally this value is false for plant users, true for external users.
CellPhoneNumber
Type: System..::..String
The cell phone number for the user
OfficePhoneNumber
Type: System..::..String
The office phone number for the user
UserRoleTemplateUserGuid
Type: System..::..Nullable <(Of <(<' Guid >)>)>
If you wish the user roles/rights to be based off a template user, this is the UserGuid for the template user.
UserLocationRightsTemplateUserGuid
Type: System..::..Nullable <(Of <(<' Guid >)>)>
If you wish the user locatoin rights to be based off a template user, this is the UserGuid for the template user.

See Also

TangoUser Class
TangoUser Members


TangoUser.Uri Method

[image]

Concert Web Services Library
TangoUser..::..Uri Method
TangoUser Class See Also Send Feedback
Used to get the Uri of a specific page as specified by the data you pass in. If the Uri requires a Tango user session GUID you must pass it when you make this call. If additional data is needed an extraDataXml is available. Further information regarding the formation of a Uri type is available by calling the FetchUriTypeList method.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Uri(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser,
    string UriTypeName,
    Nullable<Guid> tangoUserSessionGuid,
    XmlNode extraDataXml
)
Visual Basic
Public Function Uri (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser,
    UriTypeName As String,
    tangoUserSessionGuid As Nullable(Of Guid),
    extraDataXml As XmlNode
) As String

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information
UriTypeName
Type: System..::..String
The name of a Uri that you wish to generate. Use FetchUriTypeList to determine the current set of UriTypeNames and descriptions of their usage.
tangoUserSessionGuid
Type: System..::..Nullable <(Of <(<' Guid >)>)>
A user session value used to identify which user is looking at the page for the specified Uri.
extraDataXml
Type: System.Xml..::..XmlNode
Data to further assist in the generation of the Uri. If needed, the format will be provided in the data returned by FetchUriTypeList.

Return Value

Type: String
The address of the page we're trying to send a user to.

See Also

TangoUser Class
TangoUser Members


TangoUser.UserList Method

[image]

Concert Web Services Library
TangoUser..::..UserList Method
TangoUser Class See Also Send Feedback
List the existing users and their information

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TangoUser..::..UserInfo[] UserList(
    ConcertDatabaseAliasAndExternalInterfaceUser DatabaseAndExternalInterfaceUser
)
Visual Basic
Public Function UserList (
    DatabaseAndExternalInterfaceUser As ConcertDatabaseAliasAndExternalInterfaceUser
) As TangoUser..::..UserInfo()

Parameters

DatabaseAndExternalInterfaceUser
Type: Concert..::..ConcertDatabaseAliasAndExternalInterfaceUser
Database and user identification information

Return Value

Type: array< TangoUser..::..UserInfo >[]()[][]
A list of the existing users and some facts per the UserInfo class: Are they a system administrator, which customer account are they in, what general rights do they have, what type of user are they, etc.

See Also

TangoUser Class
TangoUser Members


TangoUser.CustomerInfo Class

[image]

Concert Web Services Library
TangoUser..::..CustomerInfo Class
TangoUser Class Members See Also Send Feedback
Customer information

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CustomerInfo
Visual Basic
Public Class CustomerInfo

Inheritance Hierarchy

System..::..Object
Concert..::..TangoUser..::..CustomerInfo

See Also

TangoUser..::..CustomerInfo Members


TangoUser.CustomerInfo Members

[image] [image]

Concert Web Services Library
TangoUser..::..CustomerInfo Members
TangoUser..::..CustomerInfo Class Constructors Fields See Also Send Feedback

The TangoUser..::..CustomerInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TangoUser..::..CustomerInfo | Initializes a new instance of the TangoUser..::..CustomerInfo class

Fields

 | Name | Description
Public field | CustomerID | The internal Tango identifier for the customer
Public field | CustomerName | The name the cusomter is known by in the Tango UI
Public field | SessionsAvailable | How many user sessions are allowed at one time for users within the customer account.

See Also

TangoUser..::..CustomerInfo Class


TangoUser.CustomerInfo Constructor

[image]

Concert Web Services Library
TangoUser..::..CustomerInfo Constructor
TangoUser..::..CustomerInfo Class See Also Send Feedback
Initializes a new instance of the TangoUser..::..CustomerInfo class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CustomerInfo()
Visual Basic
Public Sub New

See Also

TangoUser..::..CustomerInfo Class
TangoUser..::..CustomerInfo Members


TangoUser.CustomerInfo Fields

[image] [image]

Concert Web Services Library
TangoUser..::..CustomerInfo Fields
TangoUser..::..CustomerInfo Class See Also Send Feedback

The TangoUser..::..CustomerInfo type exposes the following members.

Fields

 | Name | Description
Public field | CustomerID | The internal Tango identifier for the customer
Public field | CustomerName | The name the cusomter is known by in the Tango UI
Public field | SessionsAvailable | How many user sessions are allowed at one time for users within the customer account.

See Also

TangoUser..::..CustomerInfo Class


TangoUser.CustomerInfo.CustomerID Field

[image]

Concert Web Services Library
TangoUser..::..CustomerInfo..::..CustomerID Field
TangoUser..::..CustomerInfo Class See Also Send Feedback
The internal Tango identifier for the customer

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int CustomerID
Visual Basic
Public CustomerID As Integer

Field Value

Type: Int32

See Also

TangoUser..::..CustomerInfo Class
TangoUser..::..CustomerInfo Members


TangoUser.CustomerInfo.CustomerName Field

[image]

Concert Web Services Library
TangoUser..::..CustomerInfo..::..CustomerName Field
TangoUser..::..CustomerInfo Class See Also Send Feedback
The name the cusomter is known by in the Tango UI

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string CustomerName
Visual Basic
Public CustomerName As String

Field Value

Type: String

See Also

TangoUser..::..CustomerInfo Class
TangoUser..::..CustomerInfo Members


TangoUser.CustomerInfo.SessionsAvailable Field

[image]

Concert Web Services Library
TangoUser..::..CustomerInfo..::..SessionsAvailable Field
TangoUser..::..CustomerInfo Class See Also Send Feedback
How many user sessions are allowed at one time for users within the customer account.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int SessionsAvailable
Visual Basic
Public SessionsAvailable As Integer

Field Value

Type: Int32

See Also

TangoUser..::..CustomerInfo Class
TangoUser..::..CustomerInfo Members


TangoUser.UriTypeItem Class

[image]

Concert Web Services Library
TangoUser..::..UriTypeItem Class
TangoUser Class Members See Also Send Feedback
A type of Tango resource Uri

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UriTypeItem
Visual Basic
Public Class UriTypeItem

Inheritance Hierarchy

System..::..Object
Concert..::..TangoUser..::..UriTypeItem

See Also

TangoUser..::..UriTypeItem Members


TangoUser.UriTypeItem Members

[image] [image]

Concert Web Services Library
TangoUser..::..UriTypeItem Members
TangoUser..::..UriTypeItem Class Constructors Fields See Also Send Feedback

The TangoUser..::..UriTypeItem type exposes the following members.

Constructors

 | Name | Description
Public method | TangoUser..::..UriTypeItem | Initializes a new instance of the TangoUser..::..UriTypeItem class

Fields

 | Name | Description
Public field | DescriptionOfUsage | A description of the Uri item and usage
Public field | UriTypeName | The name of the Uri item

See Also

TangoUser..::..UriTypeItem Class


TangoUser.UriTypeItem Constructor

[image]

Concert Web Services Library
TangoUser..::..UriTypeItem Constructor
TangoUser..::..UriTypeItem Class See Also Send Feedback
Initializes a new instance of the TangoUser..::..UriTypeItem class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UriTypeItem()
Visual Basic
Public Sub New

See Also

TangoUser..::..UriTypeItem Class
TangoUser..::..UriTypeItem Members


TangoUser.UriTypeItem Fields

[image] [image]

Concert Web Services Library
TangoUser..::..UriTypeItem Fields
TangoUser..::..UriTypeItem Class See Also Send Feedback

The TangoUser..::..UriTypeItem type exposes the following members.

Fields

 | Name | Description
Public field | DescriptionOfUsage | A description of the Uri item and usage
Public field | UriTypeName | The name of the Uri item

See Also

TangoUser..::..UriTypeItem Class


TangoUser.UriTypeItem.DescriptionOfUsage Field

[image]

Concert Web Services Library
TangoUser..::..UriTypeItem..::..DescriptionOfUsage Field
TangoUser..::..UriTypeItem Class See Also Send Feedback
A description of the Uri item and usage

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DescriptionOfUsage
Visual Basic
Public DescriptionOfUsage As String

Field Value

Type: String

See Also

TangoUser..::..UriTypeItem Class
TangoUser..::..UriTypeItem Members


TangoUser.UriTypeItem.UriTypeName Field

[image]

Concert Web Services Library
TangoUser..::..UriTypeItem..::..UriTypeName Field
TangoUser..::..UriTypeItem Class See Also Send Feedback
The name of the Uri item

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string UriTypeName
Visual Basic
Public UriTypeName As String

Field Value

Type: String

See Also

TangoUser..::..UriTypeItem Class
TangoUser..::..UriTypeItem Members


TangoUser.UserInfo Class

[image]

Concert Web Services Library
TangoUser..::..UserInfo Class
TangoUser Class Members See Also Send Feedback
User information

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UserInfo
Visual Basic
Public Class UserInfo

Inheritance Hierarchy

System..::..Object
Concert..::..TangoUser..::..UserInfo

See Also

TangoUser..::..UserInfo Members


TangoUser.UserInfo Members

[image] [image]

Concert Web Services Library
TangoUser..::..UserInfo Members
TangoUser..::..UserInfo Class Constructors Fields See Also Send Feedback

The TangoUser..::..UserInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TangoUser..::..UserInfo | Initializes a new instance of the TangoUser..::..UserInfo class

Fields

 | Name | Description
Public field | CustomerID | Customer account the user is associated with (noted each customer has a session limit)
Public field | HasEditEquipmentRights | Can this user edit equipment information
Public field | HasEditLocationRights | Can this user edit location information
Public field | IsSystemAdministrator | Is this user a system administrator
Public field | PasswordSetOnDate | Date the user password was set
Public field | UserEmailAddress | User email address
Public field | UserGuid | Unique user identifier
Public field | UserName | User name
Public field | UserTypeName | Tango user type name (informational)
Public field | UserWorkspaceName | The workspace a customer is know to belong to -- seldom used.
Public field | VendorDescription | Vendor (for Repair Shop users)

See Also

TangoUser..::..UserInfo Class


TangoUser.UserInfo Constructor

[image]

Concert Web Services Library
TangoUser..::..UserInfo Constructor
TangoUser..::..UserInfo Class See Also Send Feedback
Initializes a new instance of the TangoUser..::..UserInfo class

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UserInfo()
Visual Basic
Public Sub New

See Also

TangoUser..::..UserInfo Class
TangoUser..::..UserInfo Members


TangoUser.UserInfo Fields

[image] [image]

Concert Web Services Library
TangoUser..::..UserInfo Fields
TangoUser..::..UserInfo Class See Also Send Feedback

The TangoUser..::..UserInfo type exposes the following members.

Fields

 | Name | Description
Public field | CustomerID | Customer account the user is associated with (noted each customer has a session limit)
Public field | HasEditEquipmentRights | Can this user edit equipment information
Public field | HasEditLocationRights | Can this user edit location information
Public field | IsSystemAdministrator | Is this user a system administrator
Public field | PasswordSetOnDate | Date the user password was set
Public field | UserEmailAddress | User email address
Public field | UserGuid | Unique user identifier
Public field | UserName | User name
Public field | UserTypeName | Tango user type name (informational)
Public field | UserWorkspaceName | The workspace a customer is know to belong to -- seldom used.
Public field | VendorDescription | Vendor (for Repair Shop users)

See Also

TangoUser..::..UserInfo Class


TangoUser.UserInfo.CustomerID Field

[image]

Concert Web Services Library
TangoUser..::..UserInfo..::..CustomerID Field
TangoUser..::..UserInfo Class See Also Send Feedback
Customer account the user is associated with (noted each customer has a session limit)

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int CustomerID
Visual Basic
Public CustomerID As Integer

Field Value

Type: Int32

See Also

TangoUser..::..UserInfo Class
TangoUser..::..UserInfo Members


TangoUser.UserInfo.HasEditEquipmentRights Field

[image]

Concert Web Services Library
TangoUser..::..UserInfo..::..HasEditEquipmentRights Field
TangoUser..::..UserInfo Class See Also Send Feedback
Can this user edit equipment information

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool HasEditEquipmentRights
Visual Basic
Public HasEditEquipmentRights As Boolean

Field Value

Type: Boolean

See Also

TangoUser..::..UserInfo Class
TangoUser..::..UserInfo Members


TangoUser.UserInfo.HasEditLocationRights Field

[image]

Concert Web Services Library
TangoUser..::..UserInfo..::..HasEditLocationRights Field
TangoUser..::..UserInfo Class See Also Send Feedback
Can this user edit location information

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool HasEditLocationRights
Visual Basic
Public HasEditLocationRights As Boolean

Field Value

Type: Boolean

See Also

TangoUser..::..UserInfo Class
TangoUser..::..UserInfo Members


TangoUser.UserInfo.IsSystemAdministrator Field

[image]

Concert Web Services Library
TangoUser..::..UserInfo..::..IsSystemAdministrator Field
TangoUser..::..UserInfo Class See Also Send Feedback
Is this user a system administrator

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsSystemAdministrator
Visual Basic
Public IsSystemAdministrator As Boolean

Field Value

Type: Boolean

See Also

TangoUser..::..UserInfo Class
TangoUser..::..UserInfo Members


TangoUser.UserInfo.PasswordSetOnDate Field

[image]

Concert Web Services Library
TangoUser..::..UserInfo..::..PasswordSetOnDate Field
TangoUser..::..UserInfo Class See Also Send Feedback
Date the user password was set

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Nullable<DateTime> PasswordSetOnDate
Visual Basic
Public PasswordSetOnDate As Nullable(Of DateTime)

Field Value

Type: Nullable <(Of <(<' DateTime >)>)>

See Also

TangoUser..::..UserInfo Class
TangoUser..::..UserInfo Members


TangoUser.UserInfo.UserEmailAddress Field

[image]

Concert Web Services Library
TangoUser..::..UserInfo..::..UserEmailAddress Field
TangoUser..::..UserInfo Class See Also Send Feedback
User email address

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string UserEmailAddress
Visual Basic
Public UserEmailAddress As String

Field Value

Type: String

See Also

TangoUser..::..UserInfo Class
TangoUser..::..UserInfo Members


TangoUser.UserInfo.UserGuid Field

[image]

Concert Web Services Library
TangoUser..::..UserInfo..::..UserGuid Field
TangoUser..::..UserInfo Class See Also Send Feedback
Unique user identifier

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid UserGuid
Visual Basic
Public UserGuid As Guid

Field Value

Type: Guid

See Also

TangoUser..::..UserInfo Class
TangoUser..::..UserInfo Members


TangoUser.UserInfo.UserName Field

[image]

Concert Web Services Library
TangoUser..::..UserInfo..::..UserName Field
TangoUser..::..UserInfo Class See Also Send Feedback
User name

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string UserName
Visual Basic
Public UserName As String

Field Value

Type: String

See Also

TangoUser..::..UserInfo Class
TangoUser..::..UserInfo Members


TangoUser.UserInfo.UserTypeName Field

[image]

Concert Web Services Library
TangoUser..::..UserInfo..::..UserTypeName Field
TangoUser..::..UserInfo Class See Also Send Feedback
Tango user type name (informational)

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string UserTypeName
Visual Basic
Public UserTypeName As String

Field Value

Type: String

See Also

TangoUser..::..UserInfo Class
TangoUser..::..UserInfo Members


TangoUser.UserInfo.UserWorkspaceName Field

[image]

Concert Web Services Library
TangoUser..::..UserInfo..::..UserWorkspaceName Field
TangoUser..::..UserInfo Class See Also Send Feedback
The workspace a customer is know to belong to -- seldom used.

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string UserWorkspaceName
Visual Basic
Public UserWorkspaceName As String

Field Value

Type: String

See Also

TangoUser..::..UserInfo Class
TangoUser..::..UserInfo Members


TangoUser.UserInfo.VendorDescription Field

[image]

Concert Web Services Library
TangoUser..::..UserInfo..::..VendorDescription Field
TangoUser..::..UserInfo Class See Also Send Feedback
Vendor (for Repair Shop users)

Namespace: Concert
Assembly: Concert (in Concert.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string VendorDescription
Visual Basic
Public VendorDescription As String

Field Value

Type: String

See Also

TangoUser..::..UserInfo Class
TangoUser..::..UserInfo Members